Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 199913 - portage won't allow removing a blocked package
Summary: portage won't allow removing a blocked package
Status: RESOLVED DUPLICATE of bug 1343
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-21 19:34 UTC by Mark Tiefenbruck
Modified: 2007-12-05 22:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Tiefenbruck 2007-11-21 19:34:47 UTC
I recently upgraded to the latest unstable release of ati-drivers, 8.42.3. Since AMD claims this driver adds support for Xorg 7.3, I decided to try it out. However, the Xorg 7.3 ebuilds are blocked by ati-drivers, so I modified my local copy to allow >= 8.42.3.

Well, I had some trouble with corruption in nedit, so I'm reverting to the old version. Naturally, when I ran `emerge --sync' again this morning, my modifications to the Xorg ebuilds were overwritten, so they now block ati-drivers again. However, when I masked the new Xorg packages and tried to update, I got the usual blocked package error:

Calculating world dependencies... done!
[ebuild     UD] x11-proto/renderproto-0.9.2 [0.9.3] 0 kB
[ebuild     UD] x11-libs/libXrender-0.9.2 [0.9.4] USE="-debug" 0 kB
[ebuild     UD] x11-base/xorg-server-1.3.0.0-r2 [1.4-r2] USE="dri kdrive nptl* sdl xorg -3dfx -debug -dmx -ipv6 -minimal -xprint (-hal%)" INPUT_DEVICES="keyboard mouse synaptics -acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -evdev -fpit -hyperpen -jamstudio -joystick -magellan -microtouch -mutouch -palmax -penmount -spaceorb -summa -tek4957 -ur98 -vmmouse -void -wacom" VIDEO_CARDS="fglrx radeon -apm -ark -chips -cirrus -cyrix -dummy -epson -fbdev -glint -i128 -i740 -i810 (-impact) -imstt -mach64 -mga -neomagic (-newport) -nsc -nv -nvidia -r128 -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vesa -vga -via -vmware -voodoo (-amd%) (-vermilion%) (-xgi%)" 0 kB
[ebuild     UD] x11-drivers/xf86-input-keyboard-1.1.1-r1 [1.2.2] USE="-debug" 0 kB
[ebuild     UD] x11-base/xorg-x11-7.2 [7.3] 0 kB
[blocks B     ] x11-drivers/ati-drivers (is blocking x11-base/xorg-server-1.4-r2)

Total: 5 packages (5 downgrades, 1 block), Size of downloads: 0 kB

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.

Note that the package being blocked is one that's being removed. None of the packages being installed are blocked by ati-drivers. Clearly, this shouldn't happen.

Reproducible: Always
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-11-21 19:39:39 UTC

*** This bug has been marked as a duplicate of bug 1343 ***
Comment 2 Mark Tiefenbruck 2007-12-05 22:00:46 UTC
Sorry, but I don't feel this bug is a duplicate of that. Fixing that bug may remove the symptoms, but it's really a different problem. Also, this bug can be fixed in a different, much easier way, that's likely to happen within three years and should be done even if that bug ever does get fixed.

The problem here is that dependencies to install a package are getting checked on a package that's getting removed. There's no reason to do that. It's a waste of time and resources, and in this case it results in wrong behavior. Certainly removing this check is a better idea than trying to be really clever about making sure the check doesn't fail.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-12-05 22:06:17 UTC
Yeah sorry if you don't think it's a dupe, but it is.


*** This bug has been marked as a duplicate of bug 1343 ***