Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 199722 - [Future EAPI] remove useq, hasq
Summary: [Future EAPI] remove useq, hasq
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Hosted Projects
Classification: Unclassified
Component: PMS/EAPI (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: PMS/EAPI
URL:
Whiteboard:
Keywords:
: 654546 (view as bug list)
Depends on:
Blocks: future-eapi 373933
  Show dependency tree
 
Reported: 2007-11-20 01:22 UTC by Petteri Räty (RETIRED)
Modified: 2019-08-24 14:43 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petteri Räty (RETIRED) gentoo-dev 2007-11-20 01:22:41 UTC
The current Portage implementation of use() is:

use() {
        useq ${1}
}

I don't see any need for useq any more so we should just remove it in EAPI 2.
Comment 1 SpanKY gentoo-dev 2007-12-02 23:22:52 UTC
i dont see the point in breaking backwards compatibility since there's no overhead and no maintenance cost
Comment 2 Petteri Räty (RETIRED) gentoo-dev 2007-12-03 15:03:37 UTC
(In reply to comment #1)
> i dont see the point in breaking backwards compatibility since there's no
> overhead and no maintenance cost
> 

Well removing it would send a clear signal that it should not be used. 
Comment 3 SpanKY gentoo-dev 2007-12-04 07:25:43 UTC
and what's wrong with using it ?
Comment 4 Ulrich Müller gentoo-dev 2009-05-21 06:15:40 UTC
See also bug 262813 which is related.

(In reply to comment #1)
> i dont see the point in breaking backwards compatibility since there's no
> overhead and no maintenance cost

I would also say that there's no (at least no urgent) need to remove the useq and hasq commands from package managers.
Comment 5 Zac Medico gentoo-dev 2011-07-08 09:00:26 UTC
There's a repoman check for useq and hasq in git now:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=de32b0d92ee28965c137bea637cddf6d8c0679c2
Comment 6 Zac Medico gentoo-dev 2011-07-08 17:26:35 UTC
Also, portage will generate a QA Notice if hasq or useq is called:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=039439c2cc1546701cbb7403ea387581f08d5be0
Comment 7 Ulrich Müller gentoo-dev 2011-07-11 08:56:39 UTC
(In reply to comment #5)
> There's a repoman check for useq and hasq in git now:

(In reply to comment #6)
> Also, portage will generate a QA Notice if hasq or useq is called:

This should be sufficient to prevent useq and hasq from being used. Closing.
Comment 8 Zac Medico gentoo-dev 2011-07-15 17:50:19 UTC
I've disabled the QA Notice for pkg_prerm and pkg_postrm, since it's annoying to see these warnings due to /var/db/pkg/*/*/environment.bz2 containing long since removed hasq and useq calls:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=6620e74643e0baf040488557b1fff7273654a44d
Comment 9 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-09-01 06:50:44 UTC
Let's consider finally removing the command in a future EAPI.
Comment 10 Ulrich Müller gentoo-dev 2013-09-01 07:00:22 UTC
A solution that everyone agreed upon is in place.

Introducing EAPI dependent treatment of these functions will be more maintenance cost than leaving things as they are. Therefore closing.
Comment 11 Ulrich Müller gentoo-dev 2018-05-01 18:31:46 UTC
*** Bug 654546 has been marked as a duplicate of this bug. ***