Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 199052 - Audit 1.5.4 failing to install
Summary: Audit 1.5.4 failing to install
Status: VERIFIED DUPLICATE of bug 199051
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-13 15:25 UTC by Jason Paulson
Modified: 2007-11-13 17:48 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Paulson 2007-11-13 15:25:58 UTC
emerge -v audit is resulting in the following error.

 * 
 * ERROR: sys-process/audit-1.5.4 failed.
 * Call stack:
 *            ebuild.sh, line 1701:  Called dyn_compile
 *            ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *            ebuild.sh, line   44:  Called src_compile
 *   audit-1.5.4.ebuild, line   34:  Called die
 * The specific snippet of code:
 *      emake || die "emake failed"
 *  The die message:
 *   emake failed
 * 

Any help or pointers would be appreciated.

Reproducible: Always

Steps to Reproduce:
1. emerge -v audit

Actual Results:  
Lots of output, but this is the relevant part.

 * 
 * ERROR: sys-process/audit-1.5.4 failed.
 * Call stack:
 *            ebuild.sh, line 1701:  Called dyn_compile
 *            ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *            ebuild.sh, line   44:  Called src_compile
 *   audit-1.5.4.ebuild, line   34:  Called die
 * The specific snippet of code:
 *      emake || die "emake failed"
 *  The die message:
 *   emake failed
 * 


and this is the output from gcc just before it gives it:
gcc -fno-strict-aliasing -DNDEBUG -O2 -march=pentium4 -fomit-frame-pointer -pipe -fPIC -I../../auparse -I/usr/include/python2.4 -c auparse_python.c -o build/temp.linux-i686-2.4/auparse_python.o
auparse_python.c:1181:1: missing terminating " character
auparse_python.c:1184:1: missing terminating " character
auparse_python.c:1204:1: missing terminating " character
auparse_python.c:1208:1: missing terminating " character
error: command 'gcc' failed with exit status 1


Expected Results:  
auditd should have successfully installed.

emerge --info

Parse Error reading PROVIDE and USE in '/var/db/pkg/x11-base/xorg-x11-6.8.2-r4'
Possibly Invalid: 'virtual/x11 opengl? virtual/opengl opengl? virtual/glu virtual/xft'
Exception: Conditional without parenthesis: 'opengl?'

Portage 2.1.3.19 (default-linux/x86/2007.0, gcc-3.3.4, glibc-2.3.4.20040808-r1, 2.6.10-gentoo-r6 i686)
=================================================================
System uname: 2.6.10-gentoo-r6 i686 Intel(R) Pentium(R) 4 CPU 2.80GHz
Timestamp of tree: Tue, 13 Nov 2007 14:30:07 +0000
app-shells/bash:     3.2_p17
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.9.4-r6
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.61-r1
sys-devel/automake:  1.8.5-r1, 1.9.6-r2, 1.10
sys-devel/binutils:  2.14.90.0.8-r1
sys-devel/gcc-config: 1.3.6-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/php/apache2-php4/ext-active/ /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php4/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php4/ext-active/ /etc/php/cli-php5/ext-active/ /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl apache2 berkdb bitmap-fonts cli cracklib crypt curl dri fortran ftp gd gdbm gpm iconv isdnlog lmtp midi mudflap mysql ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline reflection session simplexml spl ssl tcpd truetype-fonts type1-fonts unicode x86 xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Jason Paulson 2007-11-13 16:09:52 UTC

*** This bug has been marked as a duplicate of bug 199051 ***