Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 198929 - net-misc/nxserver-freenx-0.7.1: adding init.d script for cleaning up during bootup/shutdown
Summary: net-misc/nxserver-freenx-0.7.1: adding init.d script for cleaning up during b...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: NX Server Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-12 13:27 UTC by Bruno Redondi
Modified: 2007-12-03 20:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild patch to add the init.d script (nxserver_initd.patch,660 bytes, patch)
2007-11-12 13:30 UTC, Bruno Redondi
Details | Diff
the init.d script (nxserver.init,299 bytes, text/plain)
2007-11-12 13:31 UTC, Bruno Redondi
Details
fix for nxserver to run without the $USER variable (nxserver-freenx-0.7.1-nxserver_fixes.patch,469 bytes, patch)
2007-11-12 13:33 UTC, Bruno Redondi
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Redondi 2007-11-12 13:27:02 UTC
IMHO it would be nice to add an init.d script that cleans up dead sessions during bootup, and stops service during shutdown

Reproducible: Always
Comment 1 Bruno Redondi 2007-11-12 13:30:01 UTC
Created attachment 135825 [details, diff]
ebuild patch to add the init.d script
Comment 2 Bruno Redondi 2007-11-12 13:31:13 UTC
Created attachment 135826 [details]
the init.d script
Comment 3 Bruno Redondi 2007-11-12 13:33:38 UTC
Created attachment 135827 [details, diff]
fix for nxserver to run without the $USER variable

when called from init.d script, nxserver gives an error due to missing $USER variable
Comment 4 Bernard Cafarelli gentoo-dev 2007-12-03 20:01:14 UTC
Thanks a lot, added in nxserver-freenx-0.7.1-r1