Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 198432 - xorg-server should be forcing libXrender to downgrade too
Summary: xorg-server should be forcing libXrender to downgrade too
Status: RESOLVED DUPLICATE of bug 1343
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
: 200919 202839 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-11-08 08:04 UTC by Martin Mokrejš
Modified: 2007-12-29 17:17 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Mokrejš 2007-11-08 08:04:05 UTC
# emerge -Dvp =x11-base/xorg-server-1.3.0.0-r2

These are the packages that would be merged, in order:

Calculating dependencies -
!!! Multiple versions within a single package slot have been 
!!! pulled into the dependency graph:

('installed', '/', 'x11-proto/renderproto-0.9.3', 'nomerge') pulled in by
  ('installed', '/', 'x11-libs/libXrender-0.9.4', 'nomerge')

('ebuild', '/', 'x11-proto/renderproto-0.9.2', 'merge') pulled in by
  ('ebuild', '/', 'x11-base/xorg-server-1.3.0.0-r2', 'merge')

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.
                                                                                                                                                                                                                                    ... done!
[ebuild     UD] x11-proto/renderproto-0.9.2 [0.9.3] USE="-debug" 40 kB 
[ebuild     U ] x11-proto/glproto-1.4.9 [1.4.8] USE="-debug" 57 kB 
[ebuild     UD] x11-libs/libXrender-0.9.2 [0.9.4] USE="-debug" 241 kB 
[ebuild     U ] net-misc/netkit-rsh-0.17-r8 [0.17-r7] USE="pam" 89 kB 
[ebuild     UD] x11-base/xorg-server-1.3.0.0-r2 [1.4-r2] USE="dri nptl xorg xprint -3dfx -debug -dmx -ipv6 -kdrive -minimal -sdl (-hal%*)" INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -fpit -hyperpen -jamstudio -joystick -magellan -microtouch -mutouch -palmax -penmount -spaceorb -summa -synaptics -tek4957 -ur98 -vmmouse -void -wacom" VIDEO_CARDS="radeon -apm -ark -chips -cirrus -cyrix -dummy -epson -fbdev -fglrx% -glint -i128 -i740 -i810 (-impact) -imstt -mach64 -mga -neomagic (-newport) -nsc -nv -nvidia -r128 -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vesa -vga -via -vmware -voodoo (-amd%) (-vermilion%) (-xgi%)" 0 kB 
[ebuild     UD] x11-drivers/xf86-input-keyboard-1.1.1-r1 [1.2.2] USE="-debug" 230 kB 

Total: 6 packages (2 upgrades, 4 downgrades), Size of downloads: 654 kB
# emerge --info
Portage 2.1.3.19 (default-linux/x86/2007.0/desktop, gcc-4.2.2, glibc-2.7-r0, 2.6.23.1 i686)
=================================================================
System uname: 2.6.23.1 i686 Mobile Intel(R) Pentium(R) 4 - M CPU 1.80GHz
Timestamp of tree: Wed, 07 Nov 2007 11:00:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.2-r1
dev-lang/python:     2.3.6-r3, 2.4.4-r6, 2.5.1-r3
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -mmmx -msse -msse2 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/spool/PBS /var/bind /var/qmail/alias /var/qmail/control /var/vpopmail/domains /var/vpopmail/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium4 -mmmx -msse -msse2 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LINGUAS="en cs cz"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="FFmpeg X Xaw3d a52 aac aalib acl acpi alsa amr amrnb amrwb apache2 asf ati avi berkdb bitmap-fonts bonobo caca cairo cddb cdio cdparanoia cdr cli cpudetection cracklib crypt cscope ctype cups curl dba dbus dga directfb divx divx5 divx5linux dri dts dv dvb dvd dvdr dvdread eds emacs emacs-w3 emboss emf encode ethereal evo f77 faad faad2 fam fame fbcon ffmpeg firefox flac flash fortran fvwm fvwm2 gb gcj gd gdbm ggi gif gphoto2 gpm gstreamer gtk gtk2 gtkhtml hal highvolume i8x0 icc iconv ieee1394 ifc imagemagick imlib imlib2 inifile innodb isdnlog ithreads jack java jpeg kdtree kerberos lcms leim libcaca libedit libwww live lzo mad matroska mcal mesa mhash midi mikmod ming mjpeg mmx mmx2 mmxext mng modplug motif mozilla mp2 mp3 mpeg mpi mudflap mule musepack mysql ncurses network nls nptl nptlonly ogg oggvorbis opengl openmp oss pam pcre pda pdf pdflib perl plotutils plugin png poppler ppds pppd pthread pthreads python qt qt3 qt3support qt4 qtx quicktime readline reflection rtc samba scanner scp server session slp spell spl sse sse2 ssl ssse3 stroke svg tcl tcltk tcpd tetex theora thread threads tiff tk truetype truetype-fonts type1-fonts unicode usb userlocales v4l v4l2 vcd vidix vorbis win32codecs winvidix wlan wmf x264 x86 xanim xml xml2 xorg xosd xprint xv xvid xvmc zeo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en cs cz" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

#

From: dberkholz@gentoo.org
> That's weird. xorg-server should be forcing libXrender to downgrade too. 
> Seems like a bug to me.
Comment 1 Zac Medico gentoo-dev 2007-11-08 08:09:17 UTC

*** This bug has been marked as a duplicate of bug 1343 ***
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-12-01 13:05:28 UTC
*** Bug 200919 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-12-20 07:53:01 UTC
*** Bug 202839 has been marked as a duplicate of this bug. ***
Comment 4 Robert Golding 2007-12-29 15:38:50 UTC
(In reply to comment #1)
> 
> *** This bug has been marked as a duplicate of bug 1343 ***
> 

Have you looked at bug#1343?  The page is virtually a list of duplicate bugs dating from 2004-10-04.  After that it is ALL;
*** Bug [number] has been marked as a duplicate of this bug. ***
starting from #7885 in Nov/04 till this one.

I don't think these are being fixed!

Comment 5 Zac Medico gentoo-dev 2007-12-29 17:17:48 UTC
(In reply to comment #4)
> Have you looked at bug#1343?  The page is virtually a list of duplicate bugs
> dating from 2004-10-04.  After that it is ALL;
> *** Bug [number] has been marked as a duplicate of this bug. ***
> starting from #7885 in Nov/04 till this one.
> 
> I don't think these are being fixed!
> 

I'm working on it. Please be patient.