Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 198365 - x11-apps/fusion-icon (new ebuild)
Summary: x11-apps/fusion-icon (new ebuild)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 5 votes (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2007-11-07 15:41 UTC by Cédric Cabessa
Modified: 2008-10-29 15:18 UTC (History)
15 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fusion-icon ebuild from layman (fusion-icon-9999.ebuild,1.19 KB, text/plain)
2007-11-07 16:55 UTC, Cédric Cabessa
Details
fusion-icon ebuild (fusion-icon-0.6.0.ebuild,1.23 KB, text/plain)
2007-11-07 21:06 UTC, Cédric Cabessa
Details
fusion-icon-0.1 ebuild (fusion-icon-0.1.ebuild,1.17 KB, text/plain)
2008-04-20 00:40 UTC, Mathieu Le Gall
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cédric Cabessa 2007-11-07 15:41:35 UTC
please could you add x11-apps/fusion-icon into the main tree?
It is available in layman xeffects, but since compiz-fusion is now in the main tree, I think fusion-icon should be too.

thank

Reproducible: Always
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-11-07 16:45:41 UTC
Attach the ebuild here.
Comment 2 Cédric Cabessa 2007-11-07 16:55:02 UTC
Created attachment 135434 [details]
fusion-icon ebuild from layman

here is the x11-apps/fusion-icon-9999 from layman / xeffects
Comment 3 Cédric Cabessa 2007-11-07 21:06:41 UTC
Created attachment 135449 [details]
fusion-icon ebuild 

ok, I've tried to make an ebuild from the xeffects' one.

Works fine, but I take the snapshot from the gitweb interface of compiz. (http://gitweb.opencompositing.org/?p=users/crdlb/fusion-icon;a=summary)
The problem is the tar.gz seems to have a time stamp in metadata, so the checksum fails...

May be gentoo people could host the snapshot somewhere...

Oh, and this is my first ebuild ;-)
Comment 4 Petteri Räty (RETIRED) gentoo-dev 2007-12-04 09:48:58 UTC
Would be best to have an official upstream release to package.
Comment 5 Pacho Ramos gentoo-dev 2007-12-19 20:00:50 UTC
I have tried with -9999 git version with xeffects ebuild and compiz from main tree and it works fine :-D
Comment 6 Gabor Garami 2008-01-16 20:08:30 UTC
(In reply to comment #5)
> I have tried with -9999 git version with xeffects ebuild and compiz from main
> tree and it works fine :-D
> 

Works for me too. Ever AMD 64 architecture and x86 architecture too. It makes easier to handle compiz-fusion. 
Comment 7 Roman Gruber 2008-01-22 12:30:23 UTC
>> It makes easier to handle compiz-fusion. 

Works also here on amd64 for a long time. I use the ebuild from the xeffects overlay. Its very essential, I think.

Comment 8 RNZ 2008-02-12 16:49:15 UTC
/usr/local/portage/x11-apps/fusion-icon $ sudo ebuild fusion-icon-0.6.0.ebuild digest
>>> Downloading 'http://distfiles.gentoo.org/distfiles/fusion-icon;a=snapshot;h=82ce586187ded167c6e56ecde6dcb3f354909faf;sf=tgz'
Searching for a previously downloaded file in /usr/portage/distfiles

....

The dtu could not be fetched, downloading full file from original URL

--2008-02-12 19:38:34--  http://gitweb.opencompositing.org/?p=users/crdlb/fusion-icon;a=snapshot;h=82ce586187ded167c6e56ecde6dcb3f354909faf;sf=tgz
Resolving gitweb.opencompositing.org... 195.114.19.35
Connecting to gitweb.opencompositing.org|195.114.19.35|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [application/x-gzip]
Saving to: `index.html?p=users%2Fcrdlb%2Ffusion-icon;a=snapshot;h=82ce586187ded167c6e56ecde6dcb3f354909faf;sf=tgz.3'

    [   <=>                                                                                          ] 30,431      43.0K/s   in 0.7s   

2008-02-12 19:38:36 (43.0 KB/s) - `index.html?p=users%2Fcrdlb%2Ffusion-icon;a=snapshot;h=82ce586187ded167c6e56ecde6dcb3f354909faf;sf=tgz.3' saved [30431]

>>> Creating Manifest for /usr/local/portage/x11-apps/fusion-icon
!!! File /usr/portage/distfiles/fusion-icon;a=snapshot;h=82ce586187ded167c6e56ecde6dcb3f354909faf;sf=tgz doesn't exist, can't update Manifest

/usr/local/portage/x11-apps/fusion-icon $ 

Comment 9 Cédric Cabessa 2008-02-12 18:22:45 UTC
Yes, for each download the checksum changes.
It is probably because the file is generated on the fly with metadata in the file (I do not know what happen really).

That is the reason why I have suggested the file should be hosted by gentoo.
Comment 10 Ryan 2008-03-19 13:12:49 UTC
2008-02-16 the developer marked the release of verion .1


The snapshot ID is - 5e2dc91599f559040fd0c9d2040cd8906e302825, just changing the git_snapshot should in the ebuild should be all that's necessary
Comment 11 Markos Chandras (RETIRED) gentoo-dev 2008-04-09 08:50:09 UTC
This ebuild works fine on amd64 Gentoo. I think it should be in portage
Comment 12 Mathieu Le Gall 2008-04-20 00:40:49 UTC
Created attachment 150337 [details]
fusion-icon-0.1 ebuild

A new ebuild of fusion-icon-0.1 (to follow project version).
It should be suitable with any release of compiz >=0.6.0 (e.g. http://bugs.gentoo.org/show_bug.cgi?id=216621)
Comment 13 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-05-14 00:02:01 UTC
I also confirm that this ebuild works fine for both x86 and amd64 Gentoo. I use it for about 6-7 months with no problem
Comment 14 Erik Boritsch 2008-07-03 14:29:03 UTC
Used the ebuild for a long time on both x86 and amd64. Works fine. Should really be added to the tree.
Comment 15 Nikos Chantziaras 2008-07-25 09:59:36 UTC
This really is a very simple program; it just displays a list of window managers and starts the one you select.  Simple but useful.  Can we have it in portage at last?
Comment 16 bb 2008-08-11 18:39:03 UTC
I also confirm that this ebuild works fine for amd64 Gentoo. Should really be added to the main tree.
Comment 17 Anton Bolshakov 2008-10-29 12:34:10 UTC
It's in the portage. Close the bug.
Comment 18 Petteri Räty (RETIRED) gentoo-dev 2008-10-29 15:18:22 UTC
(In reply to comment #17)
> It's in the portage. Close the bug.
> 

so it seems

*fusion-icon-0.1 (27 Oct 2008)
27 Oct 2008; Jorge Manuel B. S. Vicetto (jmbsvicetto)
+metadata.xml, +fusion-icon-0.1.ebuild:
Initial import of fusion-icon to the tree.