Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 198195 - the eXperience theme does not appear in the Gnome 2.18.3 theme selector
Summary: the eXperience theme does not appear in the Gnome 2.18.3 theme selector
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-05 19:27 UTC by Daniel Tourde
Modified: 2008-03-02 13:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Tourde 2007-11-05 19:27:44 UTC
Hello,

I have been unmasking and building the eXperience theme and to my big surprise I cannot select it in the theme selector (It's not there...)

Reproducible: Always

Steps to Reproduce:
1. unmask gtk-engines-experience ( =x11-themes/gtk-engines-experience-0.10.4 ~x86 in /etc/portage/package.keywords)
2. emerge experience
3. open the Gnome theme selector

Actual Results:  
No eXperience theme to choose

Expected Results:  
The eXperience theme in the selector
Comment 1 Gilles Dartiguelongue gentoo-dev 2007-11-05 22:26:56 UTC
maybe that's because you need to actually install a theme. iirc engines often doesn't install demonstration themes with it so you have to go pick one on the internet.
Comment 2 Gilles Dartiguelongue gentoo-dev 2007-11-05 22:27:04 UTC
maybe that's because you need to actually install a theme. iirc engines often doesn't install demonstration themes with it so you have to go pick one on the internet.
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-03-02 12:36:21 UTC
there is a good change this is because newer theme capplet got stricter, here is the output I get when starting it on the console:

/usr/share/themes/eXperience-olive/gtk-2.0/gtkrc:332: Impossible de trouver le fichier à inclure : « tweaks/file-list »
/usr/share/themes/eXperience-olive/gtk-2.0/gtkrc:334: Impossible de trouver le fichier à inclure : « tweaks/apply_styles »
/usr/share/themes/eXperience-olive/gtk-2.0/gtkrc:343: error: invalid string constant "FileChooser", expected valid string constant
/usr/share/themes/eXperience-ice/gtk-2.0/gtkrc:332: Impossible de trouver le fichier à inclure : « tweaks/file-list »
/usr/share/themes/eXperience-ice/gtk-2.0/gtkrc:334: Impossible de trouver le fichier à inclure : « tweaks/apply_styles »
/usr/share/themes/eXperience-ice/gtk-2.0/gtkrc:343: error: invalid string constant "FileChooser", expected valid string constant
Comment 4 Gilles Dartiguelongue gentoo-dev 2008-03-02 13:23:42 UTC
ok, I finally identified the problem. The real problem here is that the experience theme doesn't include index.theme files which are needed by gnome-appearance-properties to find theme associations. Please bug the creator of this theme to fix it, it's fairly simple to do and then we can bump it. Thanks for reporting.