Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 198019 - app-misc/mc - updated ebuild.syntax file
Summary: app-misc/mc - updated ebuild.syntax file
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Samuli Suominen
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-04 05:50 UTC by Lars Wendler (Polynomial-C)
Modified: 2009-08-05 11:32 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild.syntax (ebuild.syntax,2.92 KB, text/plain)
2007-11-04 05:51 UTC, Lars Wendler (Polynomial-C)
Details
ebuild.syntax (ebuild.syntax,2.95 KB, text/plain)
2007-11-15 14:06 UTC, Lars Wendler (Polynomial-C)
Details
ebuild.syntax (ebuild.syntax,3.26 KB, text/plain)
2008-04-28 12:37 UTC, Lars Wendler (Polynomial-C)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2007-11-04 05:50:21 UTC
Hi,

mc's ebuild.syntax file is from 2004. There were many additions to the syntax an ebuild can use since then. So I started to add all stuff I missed while working with some ebuilds. I also "cleaned" the file up somehow by sorting most keywords stuff alphabetically by their way of treatment ("keyword linestart" sorted as well as "keyword whole" stuff).

Maybe some interested developer can push this syntax file into portage while app-misc/mc is still looking for a maintainer? :D

Added keywords:

PDEPEND
WANT_AUTOCONF
WANT_AUTOMAKE
doconfd
doicon
doinitd
eautoconf
eautomake
eautoreconf
elog
newinitd


Cheers
Poly-C

Reproducible: Always

Steps to Reproduce:
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2007-11-04 05:51:21 UTC
Created attachment 135133 [details]
ebuild.syntax
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2007-11-15 14:06:18 UTC
Created attachment 136045 [details]
ebuild.syntax

Added "newconfd".
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2008-04-28 12:37:25 UTC
Created attachment 151233 [details]
ebuild.syntax

Added the following keywords:

EAPI
_elibtoolize
built_with_use
doenvd
domenu
dosed
elibtoolize
has
hasq

Just let me know if there are still missing some keywords...
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2008-12-02 17:08:47 UTC
Since mc has a new maintainer, I reassign this bug.
Comment 5 Samuli Suominen gentoo-dev 2009-08-02 14:43:38 UTC
Committed, thanks.