Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 197850 - >=x11-drivers/xf86-video-i810-2.1.0 driver fails to play video
Summary: >=x11-drivers/xf86-video-i810-2.1.0 driver fails to play video
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: High critical (vote)
Assignee: Rémi Cardona
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-02 07:02 UTC by Robert Bradbury
Modified: 2008-05-23 08:09 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Bradbury 2007-11-02 07:02:46 UTC
The Intel Video Driver for X-windows: xf86-video-i810 versions 2.1.0 and above when running on an i915 chip (standard for most basic motherboards ~2-3 years old) fails to properly play video.  All mpeg, avi, wmv files played through totem or mplayer have a triple reflection (echo) aspect to the video.  The same files played through the xf86-video-i810-2.0.0 driver work but that driver seems to be incompatible with xorg-server-1.4 (apparently the X protocol changed).

Until this problem is fixed both xorg-server and xf86-video-i810 should be masked back to their functional states.

The problem occurs on VTs (and X/Xorg) both with and without AIGLX/DRI (since DRI is only supported on a single VT).  This is on a system with the patch documented in Bug 197307 applied so it has been tested in both X AIGLX/DRI states.

It is strongly suggested that Gentoo incorporate testing procedures that would include video tests for the variety of drivers as well as testing for running multiple virtual terminals, switching between them (so one can test those with and without DRI) and include running playback of common video formats and perhaps even a Hauppauge TV card.  While I realize one cannot test everything, video playback is a pretty standard requirement for desktop/home office PCs now-a-days.
Comment 1 Rémi Cardona gentoo-dev 2008-01-24 13:50:35 UTC
I've just added a snapshot of the upcoming 2.2.1 release, as upstream wants
more testing before making official releases. This snapshot contains a lot of Xv related fixes, so hopefully your issues should be solved.

Please try this snapshot on top of xorg-server-1.4.0.90. If it isn't fixed,
please open a bug in freedesktop's bugzilla [1] and paste the url here.

Thanks

[1] https://bugs.freedesktop.org/
Comment 2 Rémi Cardona gentoo-dev 2008-02-27 12:19:02 UTC
Ping :) Any updates here? I've just pushed 2.2.1 to portage. Could you try it out?

Thanks
Comment 3 Rémi Cardona gentoo-dev 2008-05-23 08:09:37 UTC
No updates in 6 months...

Please try again with the latest xf86-video-i810 in ~arch. If you can still reproduce, don't hesitate to reopen this bug.

Thanks