Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 197377 - x11-libs/pango-1.16.5 fails with missing libexpat.so
Summary: x11-libs/pango-1.16.5 fails with missing libexpat.so
Status: VERIFIED DUPLICATE of bug 128069
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-29 07:12 UTC by Arno Hahma
Modified: 2008-03-05 09:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arno Hahma 2007-10-29 07:12:58 UTC
Emerging pango yields:

Writing a pango.modules file to use with tests/examples.
/var/tmp/portage/x11-libs/pango-1.16.5/work/pango-1.16.5/pango/.libs/lt-pango-querymodules: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory
make[3]: *** [pango.modules] Error 127
make[3]: Leaving directory `/var/tmp/portage/x11-libs/pango-1.16.5/work/pango-1.16.5/modules'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/x11-libs/pango-1.16.5/work/pango-1.16.5/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-libs/pango-1.16.5/work/pango-1.16.5'
make: *** [all] Error 2

But:

ls -l /usr/lib/libexpat.so
lrwxrwxrwx 1 root root 17 Sep  5 07:42 /usr/lib/libexpat.so -> libexpat.so.1.5.2
ls -l /usr/lib/libexpat.so.1.5.2 
-rwxr-xr-x 1 root root 189976 Sep  5 07:42 /usr/lib/libexpat.so.1.5.2

shows, that the library is there. How to tell pango -ebuild how to find libexpat?

Reproducible: Always

Steps to Reproduce:
1. emerge pango
2. wait, until it crashes
3.




emerge --info:

kovetz ~ # emerge --info 
Portage 2.1.3.9 (default-linux/amd64/2007.0/server, gcc-3.4.6, glibc-2.5-r4, 2.6.18-gentoo-r6 x86_64)
=================================================================
System uname: 2.6.18-gentoo-r6 x86_64 AMD Opteron(tm) Processor 244
Timestamp of tree: Sat, 27 Oct 2007 23:20:01 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r5
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -march=opteron -m64"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O3 -march=opteron -m64"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.public.fix.fi/gentoo/ http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ http://85.25.128.62"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X X509 acl alsa amd64 apache2 berkdb bitmap-fonts cli cracklib crypt cups dri dvd fortran gdbm gnome gpm gtk iconv ipv6 isdnlog kde kerberos ldap mailwrapper midi mmx mudflap mysql ncurses nls nptl nptlonly openmp pam pcre perl postgres pppd python qt readline reflection samba session snmp spl sse sse2 ssl tcpd threads truetype truetype-fonts type1-fonts unicode winbind xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i810 mach64 mga neomagic nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-10-29 07:29:17 UTC
Run revdep-rebuild.

*** This bug has been marked as a duplicate of bug 128069 ***
Comment 2 Arno Hahma 2007-10-29 09:03:38 UTC
Well, revdep rebuild doesn't quite work, since it returns the same problem, just with another library! We have a chicken-and-egg problem here:


/var/tmp/portage/x11-libs/gtk+-2.10.14/work/gtk+-2.10.14/gtk/.libs/lt-gtk-query-immodules-2.0: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory
make[3]: *** [gtk.immodules] Error 127
make[3]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-2.10.14/work/gtk+-2.10.14/modules/input'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-2.10.14/work/gtk+-2.10.14/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-2.10.14/work/gtk+-2.10.14'
make: *** [all] Error 2
 * 
 * ERROR: x11-libs/gtk+-2.10.14 failed.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-10-29 09:07:12 UTC
If gentoolkit-0.2.4_pre8 doesn't work for you, then file a new bug about revdep-rebuild and include all the /root/.revdep_rebuild* files, emerge --info etc. there.

This is not a pango/gtk+ bug.


*** This bug has been marked as a duplicate of bug 128069 ***
Comment 4 Niklas Johansson 2008-03-05 09:51:15 UTC
I have the same problem but I think I found a work around.

As you say, the libexpat.so is there but the problem is the libexpat.so.0 (dot zero) so all I did was:
   
   ls -s /usr/lib/libexpat.so.1.5.2 /usr/lib/libexpat.so.0

and I was able to build. This is of course just a work around but fixing this for "everyone" is over my head.

Have a great day!