Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 197254 - gnome-applets-2.20.0 merge failed (file collision)
Summary: gnome-applets-2.20.0 merge failed (file collision)
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on: 207667
Blocks:
  Show dependency tree
 
Reported: 2007-10-27 21:49 UTC by Mik B. Shvets
Modified: 2008-02-11 17:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mik B. Shvets 2007-10-27 21:49:37 UTC
* Messages for package gnome-base/gnome-applets-2.20.0:

 * This package will overwrite one or more files that may belong to other
 * packages (see list below). You can use a command such as `portageq
 * owners / <filename>` to identify the installed package that owns a
 * file. If portageq reports that only one package owns a file then do
 * NOT file a bug report. A bug report is only useful if it identifies at
 * least two or more packages that are known to install the same file(s).
 * If a collision occurs and you can not explain where the file came from
 * then you should simply ignore the collision since there is not enough
 * information to determine if a real problem exists. Please do NOT file
 * a bug report at http://bugs.gentoo.org unless you report exactly which
 * two packages install the same file(s). Once again, please do NOT file
 * a bug report unless you have completely understood the above message.
 *
 * package gnome-base/gnome-applets-2.20.0 NOT merged
 *
 * Detected file collision(s):
 *
 *      /usr/lib64/python2.5/site-packages/invest/quotes.pyc
 *      /usr/lib64/python2.5/site-packages/invest/quotes.pyo
 *      /usr/lib64/python2.5/site-packages/invest/widgets.pyc
 *      /usr/lib64/python2.5/site-packages/invest/widgets.pyo
 *      /usr/lib64/python2.5/site-packages/invest/chart.pyc
 *      /usr/lib64/python2.5/site-packages/invest/chart.pyo
 *      /usr/lib64/python2.5/site-packages/invest/defs.pyc
 *      /usr/lib64/python2.5/site-packages/invest/defs.pyo
 *      /usr/lib64/python2.5/site-packages/invest/__init__.pyc
 *      /usr/lib64/python2.5/site-packages/invest/__init__.pyo
 *      /usr/lib64/python2.5/site-packages/invest/about.pyc
 *      /usr/lib64/python2.5/site-packages/invest/about.pyo
 *      /usr/lib64/python2.5/site-packages/invest/applet.pyc
 *      /usr/lib64/python2.5/site-packages/invest/applet.pyo
 *      /usr/lib64/python2.5/site-packages/invest/preferences.pyc
 *      /usr/lib64/python2.5/site-packages/invest/preferences.pyo
 *
 * Searching all installed packages for file collisions...
 *
 * Press Ctrl-C to Stop
 *
 * None of the installed packages claim the file(s).


Reproducible: Always




emerge --info
Portage 2.1.3.16 (default-linux/amd64/2007.0, gcc-4.2.2, glibc-2.6.1-r0, 2.6.22-gentoo-r6 x86_64)
=================================================================
System uname: 2.6.22-gentoo-r6 x86_64 AMD Athlon(tm) 64 Processor 3200+
Timestamp of tree: Sat, 27 Oct 2007 11:30:09 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4, 2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -mmmx -msse -msse2 -m3dnow -mtune=athlon64 -march=athlon64 -mfpmath=sse -falign-functions=64"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -mmmx -msse -msse2 -m3dnow -mtune=athlon64 -march=athlon64 -mfpmath=sse -falign-functions=64"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache collision-protect distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LC_ALL="ru_UA.utf8"
LINGUAS="ru en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/enlightenment /usr/portage/local/layman/gentoo-china /usr/portage/local/layman/sunrise /usr/portage/local/layman/xeffects /usr/portage/local/layman/synce /usr/portage/local/layman/flameeyes-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 7zip X a52 aac aalib acl alsa amd64 apache2 artworkextra bash-completion beagle berkdb bgg bitmap-fonts bluetooth branding bzip2 cairo cdinstall cdparanoia cdr chardet clearcase cli cracklib crypt css cups curl cvs dba dbus directfb dri dv dvd dvdr dvdread effects encode exif extras fat fbcon fbsplash ffmpeg firefox flac font-server fortran ftp gd gdbm ggi gif gimp glitz glut gnokii gnome gpm gstreamer gtk gtk2 hal iconv icq imagemagick isdnlog jabber java javascript jpeg jpeg2k kde kdexdeltas libcaca libnotify lm_sensors logrotate mad maildir mailwrapper mbox midi mime mmx mmxext modplug mono mozdevelop mp3 mpeg mpm-prefork mudflap musepack mysql ncurses nls nptl nptlonly nsplugin ntfs nvidia oav ogg opengl openmp oss pam pascal pcre pdf perl pertty php png pppd pulseaudio python qt qt-copy qt4 quicktime readline reflection reiserfs ruby samba scanner script sdl seamonkey server session sharedmem skins slang sndfile soap spell spl sql sse sse2 ssl startup-notification subversion svg tagwriting tcl tcltk tcpd threads tidy tiff tk tokenizer tools transparency truetype truetype-fonts type1-fonts udev unicode usb utf8 v4l2 vcd verbose vhosts vim vim-pager vim-syntax vim-with-x vorbis wavpack wma wmf xcomposite xine xml xmldoclet xorg xosd xpm xsl xv xvid zip zlib" ALSA_CARDS="via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-10-27 22:20:28 UTC
(In reply to comment #0)
>  * A bug report is only useful if it identifies at
>  * least two or more packages that are known to install the same file(s).
>  * If a collision occurs and you can not explain where the file came from
>  * then you should simply ignore the collision since there is not enough
>  * information to determine if a real problem exists. Please do NOT file
>  * a bug report at http://bugs.gentoo.org unless you report exactly which
>  * two packages install the same file(s). Once again, please do NOT file
>  * a bug report unless you have completely understood the above message.

Please, re-read the above snippet a couple of times.
Comment 2 Jouni Kosonen 2007-11-22 09:26:24 UTC
I just came here to see if there's a recommended procedure for this, as this just happened on my gnome update on stable x86 as well.

I did read the snippet so I'm not opening a bug, just adding to a closed one... 

From the file timestamps it seems to me that this was caused by gnome-menus-2.20.1 postinst routine running python_mod_optimize on *.py -files from the pre-existing <gnome-base/gnome-applets-2.20.0 package, so the generated *.pyc and *.pyo -files really don't belong to any package. 

Removing those files manually of course fixes this, but is there any way to avoid this in the first place?

Comment 3 Rémi Cardona gentoo-dev 2007-11-22 09:39:19 UTC
Not my knowledge. It was probably due to a wrong ebuild or eclass at some point. The proper fix is to remove those files and remerge the package like you did.
Comment 4 Gilles Dartiguelongue gentoo-dev 2008-02-11 17:08:25 UTC
Actually it seems this bug depends on bug #207667 as gnome-applets ebuild doesn't use the eclass perfectly yet. Although for all users that are already using 2.20, it won't make a difference, it will fix things for users waiting far too long to update their boxes :)