Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 195886 - x11-base/xorg-server-1.4.0-r2 built with hal USE flag crashes on shutdown if dbus service is not running
Summary: x11-base/xorg-server-1.4.0-r2 built with hal USE flag crashes on shutdown if ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords: Inclusion
: 192349 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-10-14 20:19 UTC by Ewgenij Starostin
Modified: 2007-12-14 18:12 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
log of X crash (Xorg.0.log,38.92 KB, text/plain)
2007-10-14 20:24 UTC, Ewgenij Starostin
Details
dont-segfault-if-dbus-isnt-running.patch (dont-segfault-if-dbus-isnt-running.patch,466 bytes, text/plain)
2007-10-14 20:33 UTC, Donnie Berkholz (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ewgenij Starostin 2007-10-14 20:19:43 UTC
If xorg-xserver has been built with the hal USE flag and is started while the dbus service is not running, it crashes when shut down by exiting the wm or pressing ctrl-alt-backspace. The console is unusable but the rest of the system is not affected (e. g. remote login works).

When dbus is running, X shuts down properly. From the backtrace, I suspect that the problem is in teardown() in xorg-server-1.4/config/dbus-core.c, but I have not been able to test that in gdb.

Reproducible: Always

Steps to Reproduce:
1. Build x11-base/xorg-xserver-1.4.0-r2 with hal.
2. Stop dbus.
3. Run X.
4. Stop X.
Actual Results:  
X crashes on a segmentation fault.

Expected Results:  
X should shut down properly (or fail to start, if that is not possible).

Backtrace from Xorg.0.log:
0: X [0x80e9c66]
1: X(xf86SigHandler+0xa3) [0x80e9c12]
2: [0xb7fbd420]
3: X [0x80babd2]
4: X(config_dbus_core_fini+0xb) [0x80baf60]
5: X(config_fini+0x15) [0x80bab06]
6: X(main+0x766) [0x807484e]
7: /lib/libc.so.6(__libc_start_main+0xe3) [0xb7c87fd3]

Output of emerge --info:
Portage 2.1.3.12 (hardened/x86/2.6, gcc-4.2.2, glibc-2.6.1-r0, 2.6.22-hardened-r7 i686)
=================================================================
System uname: 2.6.22-hardened-r7 i686 Intel(R) Core(TM)2 CPU T5600 @ 1.83GHz
Timestamp of tree: Sun, 14 Oct 2007 18:50:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.1
dev-lang/python:     2.4.4-r4, 2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=nocona -O0 -ggdb -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O0 -ggdb -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="candy collision-protect distlocks installsources metadata-transfer nostrip parallel-fetch sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://213.186.33.37/gentoo-distfiles/"
LANG="en_GB.UTF-8"
LINGUAS="en_GB en en_US de fr es ru"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3ds 7zip X X509 a52 aac aalib abook ace acl acpi additions aim alisp alsa amr ansi apache2 arj artworkextra asf async audiofile auth bash-completion bcmath berkdb bidi binfilter blender-game bluetooth bonusscripts boost bzip2 cairo cal3d calendar cardbus cddb cdparanoia chipcard chipcard2 chm cjk cli colordiff cpudetection cracklib crypt cscope css ctype cups curl curlwrappers dbase dbm dbus dbx devhelp dga dhcp dia divx djvu doc doomsday dri dts dv dvd dvdnav dvdr dvdread eap-tls ecc effects emf enca encode erandom examples exif extensions extrafilters fame fbcon fbsplash ffmpeg fftw figlet filter finger firefox flac flash flatfile fltk fluidsynth foomaticdb fpx ftp fuse gcc-libffi gcc64 gcj gconf gd gdbm geldkarte geoip ggi gif gimp gimpprint ginac glade glep glgd glib glibc-omitfp glitz glut gmedia gmp gnuplot gnutls gopher gpgme gphoto2 gpm graphviz gs gsl gsm gtk gtk2 gtkhtml guile hal hardened hash hbci hddtemp hfs html i8x0 iconv icq icu id3 idea idn imagemagick imap imlib immqt inkjar insecure-savers ipod ipv6 ipw3945 irda iso14755 ithreads jabber java jce john jpeg jpeg2k json kerberos keyscrub kqemu ladspa lame lash lcms ldap ldap-sasl libcaca libdsk libnotify libsamplerate libsexy libwww lights linuxthreads-tls live lm_sensors logrotate lua lzo lzw m17n-lib math matroska mbox mcal mccp md5sum meanwhile mhash midi mime mimencode ming mjpeg mmap mmx mmxext mng mozbranding mozdevelop mozembed mozilla moznocompose moznoirc moznomail mozsvg mp2 mp3 mp3rtp mp4 mp4live mpeg mpeg2 mplayer mpm-worker msn musepack mysql ncurses net nethack network networking new-interface nfconntrack nfs nis nls nntp normalizemime nptl nptlonly nsplugin ntlm offensive ofx ogg on-the-fly-crypt openal openct openexr opengl openmp oscar overload pam pango passwordsave pch pcmcia pcntl pcre pda perl php pic plotutils plugin png pnm posix print python qt3support quicktime rar readline real realmedia reflection regex resolvconf rle rtc ruby scanner sdl sensord session sharedext shorten sift silc simplexml slang smartcard smime smp smtp sndfile sockets sound sox speex spell spl sqlite sqlite3 sse sse2 ssl subtitles suhosin svg svgz syslog sysvipc t1lib tcpd tetex tga theora threads threadsafe tidy tiff tokenizer truetype type1 ucs2 ucs4 unicode urandom usb vcd vim vim-syntax vorbis vorbis-psy wavpack wifi win32codecs wma wmf wmp x264 x86 xanim xcb xchatdccserver xcomposite xface xforms xim xinetd xml xmlreader xmlrpc xmlwriter xorg xosd xplanet xpm xprint xrandr xscreensaver xsl xslt xv xvid xvmc yahoo yv12 zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" CAMERAS="fuji" ELIBC="glibc" INPUT_DEVICES="evdev keyboard synaptics mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en en_US de fr es ru" USERLAND="GNU" VIDEO_CARDS="i810"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Ewgenij Starostin 2007-10-14 20:24:07 UTC
Created attachment 133470 [details]
log of X crash
Comment 2 Donnie Berkholz (RETIRED) gentoo-dev 2007-10-14 20:33:02 UTC
Created attachment 133471 [details]
dont-segfault-if-dbus-isnt-running.patch

Here's a patch from upstream git to fix that. Can you test it?
Comment 3 Ewgenij Starostin 2007-10-14 21:18:22 UTC
The patch fixes the problem. Thanks for the quick reply. :)
Comment 4 Donnie Berkholz (RETIRED) gentoo-dev 2007-12-14 07:59:51 UTC
Should be fixed in 1.4.0.90, please reopen if it's not.
Comment 5 trefoil 2007-12-14 18:12:37 UTC
*** Bug 192349 has been marked as a duplicate of this bug. ***