Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 195835 - sci.mathematics/scilab-4.1.1 fails to build with dev-libs/expat-2.0.1
Summary: sci.mathematics/scilab-4.1.1 fails to build with dev-libs/expat-2.0.1
Status: RESOLVED DUPLICATE of bug 128069
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-14 13:21 UTC by Pablo De Nápoli
Modified: 2007-10-14 13:26 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pablo De Nápoli 2007-10-14 13:21:45 UTC
After upgrading dev-libs/expat from 1.95.8 to 2.0.1, sci-mathematics/scilab-4.1.1 failed to build doe to linking inconsistencies in the program scilex (since it is linked with
libexpat.so.0 and the .so name of that library changed to libexpat.so.1. 
Here are the error messages:  

gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags`  -o Forwin Forwin.c  -lieee  
../bin/scilab -nwni -ns -f buildmacros.sce
/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/bin/scilex: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory
make[1]: *** [all] Error 127
make[1]: Leaving directory `/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/macros'
making all in imp...
make[1]: Entering directory `/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/imp'
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags`   -c -o Slpr.o Slpr.c
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags`   -c -o util.o util.c
rm -f ../bin/Slpr
gcc -o ../bin/Slpr Slpr.o util.o  -lieee 
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags`   -c -o Slatexprs.o Slatexprs.c
rm -f ../bin/Slatexprs
gcc -o ../bin/Slatexprs Slatexprs.o util.o  -lieee 
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags`   -c -o Slatexpr2.o Slatexpr2.c
rm -f ../bin/Slatexpr2
gcc -o ../bin/Slatexpr2 Slatexpr2.o util.o  -lieee 
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags`   -c -o Slatdocs.o Slatdocs.c
rm -f ../util/Slatdocs
gcc -o ../util/Slatdocs Slatdocs.o util.o   -lieee 
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags`   -c -o SEpsf.o SEpsf.c
rm -f ../bin/SEpsf
gcc -o ../bin/SEpsf SEpsf.o util.o  -lieee 
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags`   -c -o Slatexpr.o Slatexpr.c
rm -f ../bin/Slatexpr
gcc -o ../bin/Slatexpr Slatexpr.o util.o  -lieee 
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags`   -c -o Slatdoc.o Slatdoc.c
rm -f ../util/Slatdoc
gcc -o ../util/Slatdoc Slatdoc.o util.o   -lieee 
make[1]: Leaving directory `/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/imp'
making all in intersci...
make[1]: Entering directory `/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/intersci'
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags` -I../routines/   -c -o intersci.o intersci.c
rm -f ../bin/intersci
gcc -o ../bin/intersci intersci.o -lieee 
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags` -I../routines/   -c -o intersci-n.o intersci-n.c
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags` -I../routines/   -c -o getrhs.o getrhs.c
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags` -I../routines/   -c -o crerhs.o crerhs.c
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags` -I../routines/   -c -o variables.o variables.c
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags` -I../routines/   -c -o read.o read.c
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags` -I../routines/   -c -o fornames.o fornames.c
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags` -I../routines/   -c -o out.o out.c
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags` -I../routines/   -c -o outext.o outext.c
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags` -I../routines/   -c -o declare.o declare.c
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags` -I../routines/   -c -o opt.o opt.c
gcc -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags` -I../routines/   -c -o check.o check.c
rm -f ../bin/intersci-n
gcc -o ../bin/intersci-n intersci-n.o getrhs.o crerhs.o variables.o read.o fornames.o out.o outext.o declare.o opt.o check.o -lieee 
make[1]: Leaving directory `/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/intersci'
making all in tcl...
make[1]: Entering directory `/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/tcl'
gcc -o browsehelpexe browsehelpexe.c -O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer `pkg-config gtk+-2.0 --cflags`    -I.  -lieee  -L/usr/lib -ltk8.4   -L/usr/lib -ltcl8.4  -ldl `pkg-config gtk+-2.0 libgtkhtml-2.0 --libs`        -lm
/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../../../i686-pc-linux-gnu/bin/ld: warning: libexpat.so.0, needed by /usr/lib/libgtkhtml-2.so, not found (try using -rpath or -rpath-link)
make[1]: Leaving directory `/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/tcl'
making all in examples...
make[1]: Entering directory `/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/examples'
Type "make tests" in examples directory
  to test link and addinter features
make[1]: Leaving directory `/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/examples'
making man in man...
make[1]: Entering directory `/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/man'
make[2]: Entering directory `/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/man/eng'
Creating html help files
/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/bin/scilab -l eng  \
		-nwni  -e "xmltohtml([],[],'html-rev.xsl');quit" -args -nouserstartup
/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/bin/scilex: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory
make[2]: *** [man] Error 127
make[2]: Leaving directory `/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/man/eng'
make[2]: Entering directory `/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/man/fr'
Creating html help files
/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/bin/scilab -l fr \
		-nwni  -e "xmltohtml([],[],'html-rev.xsl');quit" -args -nouserstartup
/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/bin/scilex: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory
make[2]: *** [man] Error 127
make[2]: Leaving directory `/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/man/fr'
make[1]: *** [man] Error 2
make[1]: Leaving directory `/var/tmp/portage/sci-mathematics/scilab-4.1.1/work/scilab-4.1.1/man'
make: *** [man] Error 2
 [31;01m*[0m 
 [31;01m*[0m ERROR: sci-mathematics/scilab-4.1.1 failed.
 [31;01m*[0m Call stack:
 [31;01m*[0m   ebuild.sh, line 1654:   Called dyn_compile
 [31;01m*[0m   ebuild.sh, line 990:   Called qa_call 'src_compile'
 [31;01m*[0m   ebuild.sh, line 44:   Called src_compile
 [31;01m*[0m   scilab-4.1.1.ebuild, line 95:   Called die
 [31;01m*[0m 
 [31;01m*[0m emake failed
 [31;01m*[0m If you need support, post the topmost build error, and the call stack if relevant.
 [31;01m*[0m A complete build log is located at '/var/tmp/portage/sci-mathematics/scilab-4.1.1/temp/build.log'.
 [31;01m*[0m 
!!! When you file a bug report, please include the following information:
GENTOO_VM=sun-jdk-1.6  CLASSPATH="." JAVA_HOME="/opt/sun-jdk-1.6.0.03"
JAVACFLAGS="-source 1.4 -target 1.4" COMPILER=""
and of course, the output of emerge --info

here is my emerge --info
Portage 2.1.3.9 (default-linux/x86/2006.1/desktop, gcc-4.1.2, glibc-2.5-r4, 2.6.22.9 i686)
=================================================================
System uname: 2.6.22.9 i686 AMD Duron(tm)
Timestamp of tree: Sat, 13 Oct 2007 14:30:01 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.3.5-r3, 2.4.4-r5
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.20-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O3 -march=athlon -funroll-loops -pipe -fomit-frame-pointer"
DISTDIR="/distfiles"
FEATURES="buildpkg distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://gentoo.mirrors.tds.net/gentoo http://gentoo.mirrors.tds.net/gentoo http://gentoo.mirrors.easynews.com/linux/gentoo/"
LANG="POSIX"
LC_ALL="POSIX"
LINGUAS="es_AR es en"
PKGDIR="/hdc4/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/i686-mingw32/portage /usr/local/portage /usr/local/layman/kde /usr/local/layman/science /usr/local/layman/d"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowex 3dnowext X aac aalib accesibility alsa ansi apache2 arts asf audiofile avi berkdb bitmap-fonts blas bzip2 cairo cdparanoia cdr cli cracklib crypt css cups cvs dbus divx doc dri dts dv dvd dvdr dvdread eds emboss encode f77 fam fbcon ffmpeg fftw firefox flac foomaticdb fortran gcj gdbm gif gimpprint ginac glibc-omitfp gmp gpm gstreamer gtk gtk2 gtkhtml iconv icq idea imagemagick imlib ipv6 isdnlog jabber java jce jpeg kde kdeenablefinal kdehiddenvisibility kqemu ladspa lame lapack lcms lesstif lzo lzw-tiff mad matroska mbrola midi mikmod mmx mmx2 mng motif mp3 mpeg msn mudflap musicbrainz nas ncurses network nls no_wxgtk1 nodrm nptl nptlonly ogg oggvorbis opengl openmp oscar oss pcre pdf perl plotutils png ppds pppd python qt qt3 qt4 quicktime readline reflection rtc rts samba sdl session sld sndfile speex spell spl sse sse2 ssl subversion svga tcltk tcpd tetex theora tiff truetype truetype-fonts trutype-fonts type1-fonts userlocales vorbis win32codecs wxwindows x264 x86 xchattext xcomposite xine xml xml2 xorg xv xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es_AR es en" USERLAND="GNU" VIDEO_CARDS="savage"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Reproducible: Always

Steps to Reproduce:
1. emerge =dev-libs/expat-2.0.1
2. emerge =sci-mathematics/scilab-4.1.1
3.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-10-14 13:26:38 UTC

*** This bug has been marked as a duplicate of bug 128069 ***