Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 195529 - media-gfx/splashutils-1.5.2.1 doesn't compile w/ LDFLAGS="-s"
Summary: media-gfx/splashutils-1.5.2.1 doesn't compile w/ LDFLAGS="-s"
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Michal Januszewski (RETIRED)
URL:
Whiteboard:
Keywords:
: 197149 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-10-11 18:38 UTC by Radko Lazarov
Modified: 2007-10-27 11:33 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,8.09 KB, text/plain)
2007-10-11 19:46 UTC, Radko Lazarov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Radko Lazarov 2007-10-11 18:38:12 UTC
elf:~# USE=mng emerge -pv splashutils

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] media-gfx/splashutils-1.5.2.1 [1.5] USE="gpm -hardened mng png truetype" 3,067 kB

Total: 1 package (1 upgrade), Size of downloads: 3,067 kB
elf:~# USE=mng emerge splashutils
Calculating dependencies... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) media-gfx/splashutils-1.5.2.1 to /
>>> Downloading 'ftp://mirrors.ludost.net/gentoo/distfiles/freetype-2.3.5.tar.bz2'
--21:31:32--  ftp://mirrors.ludost.net/gentoo/distfiles/freetype-2.3.5.tar.bz2
           => `/usr/portage/distfiles/freetype-2.3.5.tar.bz2'
Resolving mirrors.ludost.net... 194.12.255.250

.
.
. CONF    freetype2
configure: error: C compiler cannot create executables
See `config.log' for more details.
make[1]: *** [setup] Error 77
make[1]: Entering directory `/var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/objs/freetype2'
config.mk:25: /var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/libs/freetype-2.3.5/builds/unix/unix-def.mk: No suc
config.mk:26: /var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/libs/freetype-2.3.5/builds/unix/unix-cc.mk: No such
make[1]: *** No rule to make target `/var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/libs/freetype-2.3.5/builds/u
make[1]: Leaving directory `/var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/objs/freetype2'
  MAKE    freetype2
config.mk:25: /var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/libs/freetype-2.3.5/builds/unix/unix-def.mk: No suc
config.mk:26: /var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/libs/freetype-2.3.5/builds/unix/unix-cc.mk: No such
make[1]: *** No rule to make target `/var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/libs/freetype-2.3.5/builds/u
make: *** [ft2] Error 2
 *
 * ERROR: media-gfx/splashutils-1.5.2.1 failed.
 * Call stack:
 *                    ebuild.sh, line 1687:  Called dyn_compile
 *                    ebuild.sh, line 1025:  Called qa_call 'src_compile'
 *                    ebuild.sh, line   44:  Called src_compile
 *   splashutils-1.5.2.1.ebuild, line  129:  Called die
 * The specific snippet of code:
 *      emake -j1 || die "failed to build splashutils"
 *  The die message:
 *   failed to build splashutils
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-gfx/splashutils-1.5.2.1/temp/build.log'.
 *

 * Messages for package media-gfx/splashutils-1.5.2.1:

 * The kernel tree against which dev-libs/klibc was built was not patched
 * with a compatible version of fbcondecor. Splashutils will be compiled
 * without fbcondecor support (i.e. verbose mode will not work).
 *
 * ERROR: media-gfx/splashutils-1.5.2.1 failed.
 * Call stack:
 *                    ebuild.sh, line 1687:  Called dyn_compile
 *                    ebuild.sh, line 1025:  Called qa_call 'src_compile'
 *                    ebuild.sh, line   44:  Called src_compile
 *   splashutils-1.5.2.1.ebuild, line  129:  Called die
 * The specific snippet of code:
 *      emake -j1 || die "failed to build splashutils"
 *  The die message:
 *   failed to build splashutils
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-gfx/splashutils-1.5.2.1/temp/build.log'.






Reproducible: Always




elf:~# emerge --info
Portage 2.1.3.12 (default-linux/x86/2007.0, gcc-4.2.0, glibc-2.6.1-r0, 2.6.22-ck1 i686)
=================================================================
System uname: 2.6.22-ck1 i686 Intel(R) Pentium(R) M processor 1.80GHz
Timestamp of tree: Thu, 11 Oct 2007 17:50:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.1
dev-lang/python:     2.4.4-r5, 2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
dev-util/confcache:  0.4.2-r1
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=pentium-m -pipe -fomit-frame-pointer -ftracer -fprefetch-loop-arrays"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/service"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O3 -march=pentium-m -pipe -fomit-frame-pointer -ftracer -fprefetch-loop-arrays -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--alphabetical"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="ftp://mirrors.ludost.net/gentoo/ http://mirrors.ludost.net/gentoo/ ftp://ftp.gentoo.bg/ http://distfiles.gentoo.bg/ ftp://mirrors.netbg.com/gentoo/ http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo http://www.ibiblio.org/pub/Linux/distributions/gentoo http://gentoo.osuosl.org"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -s"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.bg/gentoo-portage/"
USE="X acl acpi aiglx alsa apache2 berkdb bitmap-fonts bzip2 cli cracklib crypt dga dri dvd gdbm gif glibc-omitfp gnutls gpm gtk gtk2 iconv isdnlog ithreads jpeg kde ldap midi mmx mp3 mpeg mppc mppe mudflap mysql ncurses nls nptl nptlonly openmp pam pcre perl png postgres pppd python qt readline reflection rtc session spl sse sse2 ssl tcpd tiff truetype truetype-fonts type1-fonts unicode userlocales x86 xinetd xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fglrx radeon ati vesa fbdev apm"
Unset:  CTARGET, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-10-11 19:27:39 UTC
(In reply to comment #0)
> configure: error: C compiler cannot create executables
> See `config.log' for more details.

Is hardly a splashutils bug; you didn't attach the config.log here.
Comment 2 Radko Lazarov 2007-10-11 19:46:51 UTC
Created attachment 133206 [details]
config.log

Hee it is.
I guess that's one is the right on as there are two:
/var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/objs/jpeglib/config.log
/var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/objs/freetype2/config.log
Comment 3 Radko Lazarov 2007-10-11 19:47:49 UTC
Required log attached
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-10-11 20:12:26 UTC
<snip>
configure:2431: klcc -v >&5
/usr/bin/klcc: No input files!
configure:2434: $? = 25
configure:2441: klcc -V >&5
/usr/bin/klcc: unknown option: -V
configure:2444: $? = 25
configure:2467: checking for C compiler default output file name
configure:2494: klcc -fno-stack-protector -Os -w -ffunction-sections -fdata-sections  -I/var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/libs/zlib-1.2.3 -I/var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/libs/freetype-2.3.5/include -I/var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/objs/jpeglib -DWITH_ERRLIST -DTARGET_KERNEL -DTT_CONFIG_OPTION_BYTECODE_INTERPRETER -I/var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/libs/libpng-1.2.18 -I/var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/libs/jpeg-6b -include /var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/klibc_compat.h -I/var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/libs/zlib-1.2.3 -Wl,-O1 -Wl,--sort-common -s conftest.c  >&5
/usr/bin/strip: '': No such file
configure:2497: $? = 1
</snip>
Comment 5 Michal Januszewski (RETIRED) gentoo-dev 2007-10-11 20:16:52 UTC
Please remerge klibc (make sure you're using the latest one) and check whether it fixes the problem.
Comment 6 Radko Lazarov 2007-10-11 20:41:56 UTC
Hi,

I have reemerged klibc-1.5 and then tried to emerge splashutils-1.5.2.1
but the same error appear.

I have checked the 
/var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/objs/freetype2/config.log

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by FreeType configure 2.3.5, which was
generated by GNU Autoconf 2.61.  Invocation command line was

  $ /var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/libs/freetype-2.3.5/builds/unix/configure --disable-shared

## --------- ##
## Platform. ##
## --------- ##


.
.
.## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_NAME "FreeType"
#define PACKAGE_TARNAME "freetype"
#define PACKAGE_VERSION "2.3.5"
#define PACKAGE_STRING "FreeType 2.3.5"
#define PACKAGE_BUGREPORT "freetype@nongnu.org"

configure: exit 77


The same error.

But If I run 


/var/tmp/portage/media-gfx/splashutils-1.5.2.1/work/splashutils-1.5.2.1/libs/freetype-2.3.5/builds/unix/configure --disable-shared

manualy, seems it's passing and if I do make in that directory it's passing.

I do not know if this help indeed, but I hope so
Comment 7 Michal Januszewski (RETIRED) gentoo-dev 2007-10-11 21:00:00 UTC
Please try emerging splashutils with:

1) ccache removed from FEATURES
2) unset LDFLAGS

and let us know whether it changes anything.
Comment 8 Radko Lazarov 2007-10-11 21:33:11 UTC
Hello,

I have removed ccache form FEATURES, but it failed again.

After I comment out LDFLAGS in make.conf emerge passed successfully.

Thank you for support.

Will you consider eventually to work with such LDFLAGS, as previous version (1.5)was working for me? 
Comment 9 Michal Januszewski (RETIRED) gentoo-dev 2007-10-12 18:38:55 UTC
I'll investigate what exactly causes the problem and if it's nothing major, this LDFLAGS set should be supported in the next release of splashutils.
Comment 10 Michal Januszewski (RETIRED) gentoo-dev 2007-10-12 20:29:39 UTC
Changing resolution..
Comment 11 Michal Januszewski (RETIRED) gentoo-dev 2007-10-12 20:32:17 UTC
The problem is caused by the '-s' about which GCC manual says: "Remove all symbol table and relocation information from the executable."

I do not consider this to be supported and I think you should remove this from your LDFLAGS. It's not your call to remove relocation information from object files and since we normally strip all executables anyway, you don't really gain anything from using it.
Comment 12 Jakub Moc (RETIRED) gentoo-dev 2007-10-27 11:32:42 UTC
*** Bug 197149 has been marked as a duplicate of this bug. ***