Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 19527 - xfsprogs ebuild USERPRIV issue
Summary: xfsprogs ebuild USERPRIV issue
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High blocker (vote)
Assignee: Nicholas Jones (RETIRED)
Depends on:
Reported: 2003-04-17 21:17 UTC by Antonio D'souza
Modified: 2003-06-10 09:12 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Antonio D'souza 2003-04-17 21:17:32 UTC
Calculating world dependencies ...done!
>>> emerge (1 of 10) sys-apps/xfsprogs-2.3.9 to /
>>> md5 ;-) xfsprogs-2.3.9.src.tar.gz
>>> Unpacking source...
>>> Unpacking xfsprogs-2.3.9.src.tar.gz to /var/tmp/portage/xfsprogs-2.3.9/work
/usr/sbin/ line 24: include/ Permission denied
!!! ERROR: sys-apps/xfsprogs-2.3.9 failed.
!!! Function src_unpack, Line 27, Exitcode 1
!!! sed failed

Reproducible: Always
Steps to Reproduce:
1. emerge rsync
2. emerge -u world

Actual Results:  
I got the error message shown in the description section. 

Expected Results:  
the ebuild should have built & installed.
Comment 1 Jeffrey Strube 2003-04-18 00:21:51 UTC
I also had this problem. I tried adjusting the permissions on the files involved, to no 
avail. I eventually removed userpriv from my FEATURES. This fixed the problem, 
however this is still only a temporary fix. 
Comment 2 Seth Chandler 2003-04-18 01:25:47 UTC
ths emerges fine for me, you out of space or smoething? 
thats sure what it looks like =) 
Comment 3 Jon Portnoy (RETIRED) gentoo-dev 2003-04-18 09:56:40 UTC
I ran into that too. It's not just him.
Comment 4 Ulrich Plate (RETIRED) gentoo-dev 2003-05-21 11:10:25 UTC
And just in case you were wondering: it's still dying on the 
same error message, and getting rid of FEATURES="userpriv" 
still fixes it. :)
Comment 5 Haroon Rafique 2003-06-09 11:25:32 UTC
Easy fix for this one. The file in question is include/ The original file permissions for this file in the package are 0444 as follows:

-r--r--r--    1 portage  portage      3202 Dec 30 18:09 include/

So, adding a chmod u+w for this file in the ebuild file will take care of the problem under "userpriv" mode. Here's a diff for the fix to the ebuild.

diff -u xfsprogs-2.3.9.ebuild /usr/portage/sys-apps/xfsprogs/
--- xfsprogs-2.3.9.ebuild       2003-06-09 12:21:53.000000000 -0400
+++ /usr/portage/sys-apps/xfsprogs/xfsprogs-2.3.9.ebuild        2003-06-09 12:22:28.000000000 -0400
@@ -22,7 +22,6 @@
        cd ${S}
        cp include/ include/
-       chmod u+w include/
        sed -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" \
            -e 's:-O1::' -e '/-S $(PKG/d' \
            -e 's:^PKG_\(.*\)_DIR[[:space:]]*= \(.*\)$:PKG_\1_DIR = $(DESTDIR)\2:' \
Comment 6 Tobias Sager 2003-06-10 09:00:39 UTC
Why did this go to stable portage while there still is an open bug?

Comment #5 fixes the problem.
Comment 7 Brandon Low (RETIRED) gentoo-dev 2003-06-10 09:12:55 UTC
Because userpriv isn't a stable feature, regardless, applying fix.