Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 195003 - xfce-base/xfce4-4.4.1 - "Alt-*" shortcuts won't work w/ >=x11-misc/xkeyboard-config-0.9
Summary: xfce-base/xfce4-4.4.1 - "Alt-*" shortcuts won't work w/ >=x11-misc/xkeyboard-...
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: XFCE Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-07 15:19 UTC by Serhiy Kalchuk
Modified: 2015-07-05 09:34 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Serhiy Kalchuk 2007-10-07 15:19:58 UTC
At some point I have noticed that such shortcuts as Alt-tab, Alt-F[1...12] and similar stopped working. In logs I found that xfce-base/xfwm was updated to 4.4.1-r1 several days ago,so I suppose this to be a reason.


Reproducible: Always

Steps to Reproduce:
1.Press Alt-tab in order to switch between windows or Alt-F4 to close one.

Actual Results:  
When trying to close a terminal window with Alt-F4 it prints ';3S', everywhere else it just does nothing.
Alt-tab combination acts as if only a Tab-key was pressed.

Expected Results:  
Function as defined in preferences.

emerge --info
Portage 2.1.3.9 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.5-r4, 2.6.21-gentoo-r4 i686)
=================================================================
System uname: 2.6.21-gentoo-r4 i686 AMD Athlon(tm) XP 2500+
Timestamp of tree: Sun, 07 Oct 2007 14:20:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://src.gentoo.pl http://ftp.roedu.net/pub/mirrors/gentoo.org/ ftp://ftp.romnet.org/gentoo/ "
LC_ALL="uk_UA.UTF-8"
LINGUAS="uk en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/home/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X aac acl acpi alsa berkdb bitmap-fonts cairo cdparanoia cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread encode evo exif fam ffmpeg firefox fortran gdbm gif gphoto2 gpm gstreamer gtk hal iconv icq ipv6 isdnlog jabber jpeg kerberos ldap mad midi mikmod mp3 mpeg mudflap ncurses nls nptl nptlonly nvidia ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support quicktime readline reflection scanner sdl session spell spl ssl svg tcpd tiff truetype truetype-fonts type1-fonts unicode usb vorbis win32codecs x86 xml xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="uk en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-10-07 15:36:52 UTC
(In reply to comment #0)
> At some point I have noticed that such shortcuts as Alt-tab, Alt-F[1...12] and
> similar stopped working. In logs I found that xfce-base/xfwm was updated to
> 4.4.1-r1 several days ago,so I suppose this to be a reason.

It works perfectly fine here; if you downgrade to 4.4.1, does Alt-* work again? Really hard to diagnose something with the only info being 'it doesn't work any more'
Comment 2 Serhiy Kalchuk 2007-10-07 17:47:51 UTC
(In reply to comment #1)
Downgrade didn't help, but I found out that in logs I missed an update to xkeyboard-config, which took place also not long ago. There's a bug in xfce's bugzilla http://bugzilla.xfce.org/show_bug.cgi?id=3194 , which now seems to be like my case, because after I had commented out the following line in xorg.conf:

Option "XkbLayout"  "us,ua(winkeys),de,ru(winkeys)"

it worked fine. However, that bug is marked as RESOLVED...


Comment 3 Serhiy Kalchuk 2007-10-07 18:03:35 UTC
If downgrading to x11-misc/xkeyboard-config-0.8-r1 works fine. Current stable version 0.9 and testing 1.1 don't.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-12-05 11:14:12 UTC
(In reply to comment #3)
> If downgrading to x11-misc/xkeyboard-config-0.8-r1 works fine. Current stable
> version 0.9 and testing 1.1 don't.

That'd explain it. I had nothing but pain w/ 0.9.0+ (such as Bug 157837), so I've masked it locally ages ago.
Comment 5 Samuli Suominen gentoo-dev 2008-03-19 15:20:56 UTC
So, what about combination of Xfce 4.4.2 and xkeyboard-config-1.2?
Comment 6 Serhiy Kalchuk 2008-03-19 18:44:59 UTC
(In reply to comment #5)
> So, what about combination of Xfce 4.4.2 and xkeyboard-config-1.2?
> 

Works with xfce 4.4.2 and xkeyboard-config-1.1 (both stable, so haven't tested with 1.2, supposing it's all good there too)