Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 19488 - Dialup users would find gentoo more friendly if the iso's and portage tree were bzipped
Summary: Dialup users would find gentoo more friendly if the iso's and portage tree we...
Status: RESOLVED WONTFIX
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-04-17 12:43 UTC by Jill Mitchell
Modified: 2011-10-30 22:21 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jill Mitchell 2003-04-17 12:43:58 UTC
bzip compresses files to a greater extent than does gzip. By default, rsync uses
gzip, while ISO images aren't compressed at all. This is a distinct disadvantage
to all dialup users, and to metered broadband users. Gentoo would be more
attractive to these large subsets of the Linux user community if the download
sizes were smaller.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Jill Mitchell 2003-04-17 12:45:05 UTC
I'll volunteer to make bzip versions of the packages as they're released.
Comment 2 Jon Portnoy (RETIRED) gentoo-dev 2003-04-17 13:07:36 UTC
As was explained on IRC, our ISO images have the bulk of the filesystem as a compressed file (cloop). This file can't be compressed further with any real benefit. The only space gains result from three uncompressed initrd files. This results in a 10-15mb space gain, which is trivial and not worth the time required to bzip2 each ISO image (in my opinion). That space gain will not increase as the ISO size increases, it's pretty static. 

If it can be shown that there is a significant desire from users for this, it may be worthwhile.
Comment 3 Luca Barbato gentoo-dev 2003-04-17 13:37:25 UTC
The gentoo iso images (at least newer x86 and ppc) are using some compression (ucl or zlib depending on situation) internally, the gain you have today is just because some part (mostly the initrd for bootsplash) aren't compressed at all, the result is that you may now have some gain in having them compressed with bz2 now.
But you have at least 2 problems:
1 bz2 is quite cpu hunger, making that quite BAD for things like rsync
2 every compression algorithm increase the size of a block of data if it can't compress it, and that is more likely if you have already compressed data, the result is that you may even get bz2 bigger than iso.

We were thinking about other algorithm like some ppm ones but we didn't find anything mature/free/available easly yet.

Your point, having iso and rsync stream compressed better, is good, your proposed solution, sadly, isn't.

If you can find a compression algorithm, already implemented and usable, faster than bz2 and better than zlib please tell us and we'll be happy to implement it.
Comment 4 Martin Holzer (RETIRED) gentoo-dev 2003-06-09 16:34:02 UTC
see comment #2 and comment #3