Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 194545 - app-office/openoffice-bin-2.3.0 does not print word processing documents (such as doc, odt and friends)
Summary: app-office/openoffice-bin-2.3.0 does not print word processing documents (suc...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2007-10-02 19:49 UTC by Robert Miesen
Modified: 2007-10-05 07:32 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Robert Miesen 2007-10-02 19:49:44 UTC
I attempted to print a word processing document and after going through the standard print dialog and clicking on OK, nothing happens. I traced the problem far enough to figure out that the problem is that the word processing document does not get sent to cups at all. This was found out by me disconnecting the printer from my computer.

This problem also affects exporting of word processing documents to the pdf format. The document will get exported correctly, but all the pages will be blank. This may be a separate problem, but I suspect they may be one and the same bug, so I'm grouping it with this bug report.
Openoffice has no troubles printing spreadsheets, presentations, and other things; it just doesn't print word processing documents.

Reproducible: Always

Steps to Reproduce:
1. Load up your favorite word processing-type document.
2. Try and print it using Ctrl-P.
3. Select whatever printer you want and click on the OK button.

Actual Results:  

Expected Results:  
A printed version of my document should have been sent to my printer for printing.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-10-02 21:15:55 UTC
It prints just fine here. Maybe you could post some errors and emerge --info output, at minimum.
Comment 2 Robert Miesen 2007-10-02 23:07:42 UTC
Sorry about that. Here is the output for 'emerge --info':

Portage (default-linux/x86/2007.0/desktop, gcc-4.2.0, glibc-2.6.1-r0, 2.6.22-gentoo-r8 i686)
System uname: 2.6.22-gentoo-r8 i686 Genuine Intel(R) CPU T2050 @ 1.60GHz
Timestamp of tree: Tue, 02 Oct 2007 17:50:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r5, 2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r5
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18
sys-devel/gcc-config: 1.4.0-r2
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
CFLAGS="-O2 -mtune=i686 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -mtune=i686 -pipe"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
USE="X a52 aac aalib acl acpi adns alsa apache2 arts bash-completion bcmath berkdb bindist bitmap-fonts bzip2 cairo caps cddp cdr cjk clamav cli cracklib crypt cscope ctype cups curl curlwrappers dbase dbm dbus dga directfb dri dts dvd dvdr dvdread eds emacs emboss encode evo examples exif expat fam fastcgi fbcron ffmpeg fftw firefox flac foomaticdb fortran freetds ftp gd gdbm geoip ggi gif glut gmp gnustep gnutls gpm graphviz gstreamer gtk gtkhtml hal howl icc iconv icq idn imagemagick imap imlib informix innodb ipod ipv6 isdnlog jabber jack java javascript jbig joystick jpeg jpeg2k junit kde kdexdeltas kerberos krb4 ladspa lapack lcms ldap leim lesstif libcaca libg++ libnotify libsamplerate libwww lirc lm_sensors mad maildir matroska matrox mbox mcal midi mikmod mime mmx mono mp3 mpeg mpi mplayer mpm-threadpool msn mudflap mule musepack musicbrainz mysql mysqli nas ncurses nls nntp nocd nptl nptlonly offensive ofx ogg openexr opengl openmp osc oscar oss pam pcntl pcre pdf perl php plotutils png postfix ppds pppd profile python qt3 qt3support qt4 quicktime rdesktop readline reflection sdl session sharedext shorten smp snmp soap sockets source speex spell spl sse sse2 ssl startup-notification svg svga symlink sysvipc tcpd tetex theora threads tidy tiff tokenizer truetype truetype-fonts type1-fonts unicode usb vcd vhosts videos vorbis win32codecs x86 xcomposite xface xine xml xorg xosd xpm xprint xscreensaver xsl xulrunner xv xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"

As for error output, I can't seem to find out where openoffice stores that information. I checked /var/log and even tried running openoffice from the command line to try and get some error output, but got nothing. While I was at it I tried to print from the command line using the -P option and it worked. However, trying to print from the GUI again still resulted in nothing.

Can you direct me to where I can find the error output for openoffice? That would be most appreciated.
Comment 3 Robert Miesen 2007-10-05 07:26:35 UTC
Actually the error turned out to be caused by some random data error in a particular odt document. Printing works for that document. If you would be interested, I can attach the offending file so that it can be analyzed by the open office development team.

Let me know what you decide. Thanks in advance.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-10-05 07:32:50 UTC
That's really beyond the scope of Gentoo, it might be a good idea to report this upstream though -

Thanks for reporting back.