Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 193090 - x11-base/xorg-server - Xorg works without mouse module loaded
Summary: x11-base/xorg-server - Xorg works without mouse module loaded
Status: RESOLVED DUPLICATE of bug 193036
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-19 16:34 UTC by Manuel MArtinez
Modified: 2007-09-19 19:09 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel MArtinez 2007-09-19 16:34:04 UTC
my system works fine. KDE load without problem, but no mouse works in KDE.
I updated Xorg to 1.4, and in the /var/logs/Xorg.0.log i can see this error:

---------------------------------------------------------------------------
II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input//mouse_drv.so
dlopen: /usr/lib/xorg/modules/input//mouse_drv.so: undefined symbol: miPointerGetMotionEvents
(EE) Failed to load /usr/lib/xorg/modules/input//mouse_drv.so
(II) UnloadModule: "mouse"
(EE) Failed to load module "mouse" (loader failed, 7)
----------------------------------------------------------------------------
Comment 1 Manuel MArtinez 2007-09-19 16:36:51 UTC
Portage 2.1.3.9 (default-linux/x86/2006.1/desktop, gcc-4.1.2, glibc-2.5-r4, 2.6.22-gentoo-r6 i686)
=================================================================
System uname: 2.6.22-gentoo-r6 i686 Intel(R) Pentium(R) 4 CPU 2.00GHz
Timestamp of tree: Tue, 18 Sep 2007 09:30:09 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.3.6-r1, 2.4.4-r2, 2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.10-r4
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18
sys-devel/gcc-config: 1.4.0-r2
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="es_ES"
LC_ALL="es_ES"
LINGUAS="es"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/xgl-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac alsa apache2 arts asf berkdb bitmap-fonts cairo cdr cdrw cgi cli cracklib crypt cups dba dbus dlloader dmo doc dri dvd dvdr dvdread eds emboss encode esd fam firefox fortran gdbm geos gif glitz gnome gpm gstreamer gtk gtk2 gtkmm hal iconv ipv6 isdnlog java jpeg kde lame ldap m4a mad midi mikmod mp3 mp4 mpeg mpm mudflap mysql ncurses nls nptl nptlonly nsplugin nvidia ogg opengl openmp oss pam pcre pdf pear-db perl php pic png postgis postgres ppds pppd proj python qt qt3 qt4 quicktime readline reflection sdl server session simplexml smarty soap spell spl ssl tcpd threads truetype truetype-fonts type1-fonts unicode v4l2 vorbis win32codecs wmv x86 xml xmldoclet xmlreader xmlrpc xmlwriter xorg xslt xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es" USERLAND="GNU" VIDEO_CARDS="nv vesa"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Jeroen Roovers gentoo-dev 2007-09-19 16:41:36 UTC
Did you rebuild x11-drivers/xf86-input-mouse after the xorg-server upgrade?
Comment 3 Wulf Krueger (RETIRED) gentoo-dev 2007-09-19 16:57:28 UTC
(In reply to comment #2)
> Did you rebuild x11-drivers/xf86-input-mouse after the xorg-server upgrade?

I've had exactly the same problem and your suggestion solved it, Jeroen, thanks!

Nevertheless, wouldn't it be good to maybe add a little post-install message about this? A non-functional core input device can be rather startling... ;)
Comment 4 Jeroen Roovers gentoo-dev 2007-09-19 19:09:04 UTC

*** This bug has been marked as a duplicate of bug 193036 ***