Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 193036 - Update of x11-base/xorg-server did not trigger reinstall of dependent modules
Summary: Update of x11-base/xorg-server did not trigger reinstall of dependent modules
Status: RESOLVED DUPLICATE of bug 192319
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High minor (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 193090 210255 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-09-19 09:18 UTC by Arie Middelkoop
Modified: 2008-02-15 16:43 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arie Middelkoop 2007-09-19 09:18:45 UTC
After running an emerge --update world --deep --newuse, the xorg-server was updated (among other packages):

x11-base/xorg-server (1.4-r1)

However, two x11-drivers that I use didn't load anymore (probably some binary incompatibility). A reinstall of

x11-drivers/xf86-input-mouse (1.2.2)
x11-drivers/synaptics (0.14.6)

fixed that.

Reproducible: Didn't try

Steps to Reproduce:



Expected Results:  
Force a reinstall of all x11-drivers after updating x11-base/xorg-server?
Comment 1 Jeroen Roovers gentoo-dev 2007-09-19 19:09:04 UTC
*** Bug 193090 has been marked as a duplicate of this bug. ***
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-09-20 12:02:56 UTC
(In reply to comment #0)
> Expected Results:  
> Force a reinstall of all x11-drivers after updating x11-base/xorg-server?

Except that there's no way to do it. 



*** This bug has been marked as a duplicate of bug 192319 ***
Comment 3 Kobboi 2008-02-09 10:22:32 UTC
(In reply to comment #2)
> (In reply to comment #0)
> > Expected Results:  
> > Force a reinstall of all x11-drivers after updating x11-base/xorg-server?
> 
> Except that there's no way to do it. 

Make some kind of X-module-rebuild, like the existing module-rebuild for kernels? Saw it also on 1.4.0.90-r3.


Comment 4 Jakub Moc (RETIRED) gentoo-dev 2008-02-15 16:43:07 UTC
*** Bug 210255 has been marked as a duplicate of this bug. ***