Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 192887 - x11-apps/xinit-1.0.5-r1 fails on eautoreconf
Summary: x11-apps/xinit-1.0.5-r1 fails on eautoreconf
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-18 05:18 UTC by Frank Bartunek
Modified: 2008-04-10 10:00 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
output of "aclocal-1.10 --verbose" (log,31.11 KB, text/plain)
2008-04-10 09:25 UTC, Rémi Cardona
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Bartunek 2007-09-18 05:18:39 UTC
When I try to emerge Xinit, aclocal breaks down and the emerge abruptly stops.  I need this package as my X windows refuses to run in any usable state without it.  I speculate that the ebuild somehow expects a version of autoconf other than the one I'm using (2.61-r1), and for some reason does not state this assumption.

Reproducible: Always

Steps to Reproduce:
1. Have autoconf-2.61-r1
2. emerge xinit

Actual Results:  
 * Running aclocal ...                                                    [ !! ]

 * Failed Running aclocal !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /tmp/portage/x11-apps/xinit-1.0.5-r1/temp/aclocal-2770.out

 * 
 * ERROR: x11-apps/xinit-1.0.5-r1 failed.
 * Call stack:
 *   ebuild.sh, line 1654:   Called dyn_unpack
 *   ebuild.sh, line 768:   Called qa_call 'src_unpack'
 *   ebuild.sh, line 44:   Called src_unpack
 *   xinit-1.0.5-r1.ebuild, line 48:   Called x-modular_reconf_source
 *   x-modular.eclass, line 263:   Called eautoreconf
 *   autotools.eclass, line 94:   Called eaclocal
 *   autotools.eclass, line 131:   Called autotools_run_tool 'aclocal'
 *   autotools.eclass, line 219:   Called die
 * 
 * Failed Running aclocal !
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/x11-apps:xinit-1.0.5-r1:20070918-050434.log'.


Expected Results:  
Since the source file already ships with a working autoconf environment, it should skip the autoconf step.


Contents of log file:

***** aclocal *****

unknown channel 26.12199582258547e-314 at /usr/share/autoconf/Autom4te/Channels.pm line 546
	Autom4te::Channels::msg('26.12199582258547e-314', 'configure.ac:26', 'warning: 26.12801692551336e-314') called at /usr/bin/autom4te-2.61 line 1006
aclocal-1.10: autom4te failed with exit status: 1
Comment 1 SpanKY gentoo-dev 2007-09-19 14:13:01 UTC
you forgot to post `emerge --info` like the bug report page said to
Comment 2 Frank Bartunek 2007-09-19 22:06:20 UTC
My apologies.

-------
 emerge --info
Portage 2.1.3.9 (default-linux/amd64/2007.0/desktop, gcc-4.2.0, glibc-2.6.1-r0, 2.6.23-rc6 x86_64)
=================================================================
System uname: 2.6.23-rc6 x86_64 AMD Sempron(tm) Processor 2800+
Timestamp of tree: Tue, 18 Sep 2007 08:50:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
dev-util/confcache:  0.4.2
sys-apps/baselayout: 1.12.10-r4
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18
sys-devel/gcc-config: 1.4.0-r2
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=athlon64 -fomit-frame-pointer -msse3 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/simutrans/conf /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon64 -fomit-frame-pointer -msse3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache confcache distcc distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.phy.olemiss.edu/mirror/gentoo http://gentoo.mirrors.easynews.com/linux/gentoo/"
LINGUAS="en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="3dnow X Xaw3d aalib acl acpi alsa amd64 berkdb bitmap-fonts bzip2 cairo cdr cli cracklib crypt cups curl dbus devil dlloader dri dvd dvdr dvdread eds emboss encode esd evo fam fftw flash fortran gdbm gif glibc-omitfp gnome gnutls gpm gstreamer gtk gtk2 hal iconv imagemagick ipv6 isdnlog java jpeg jpg kde kerberos ldap libg++ mbrola midi mikmod mmx modplug mp3 mpeg ncurses nls nptl nptlonly offensive ogg opengl openmp oss pam pcre pdf perl png ppds python qt3 qt3support qt4 quicktime readline reflection remix sdl seamonkey session softmmu spell spl sse sse2 ssl svg tcl tcpd tiff tk truetype truetype-fonts type1-fonts udev unicode userlocales voice vorbis xml xorg xscreensaver xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="ati vesa radeon"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2008-01-10 06:46:57 UTC
Looks like broken autoconf install to me, rather than xinit bug...
Comment 4 SpanKY gentoo-dev 2008-01-10 07:00:10 UTC
xinit needs to execute autotools presumably because it applies patches which modify the autotool sources

please go into:
/var/tmp/portage/x11-apps/xinit-1.0.5-r1/work/xinit-1.0.5/

and execute:
aclocal-1.10 --verbose >& log

then post the "log" file as an attachment
Comment 5 Rémi Cardona gentoo-dev 2008-04-10 09:24:10 UTC
Same bug with xinit-1.0.8. Log coming in a minute
Comment 6 Rémi Cardona gentoo-dev 2008-04-10 09:25:01 UTC
Created attachment 149284 [details]
output of "aclocal-1.10 --verbose"
Comment 7 Rémi Cardona gentoo-dev 2008-04-10 10:00:21 UTC
Erf, never mind, my issue was a dupe of bug #217087.

Sorry for the noise, closing NEEDINFO like before