Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 192449 - sci-mathematics/maxima-5.13.0 fails to compile with gcl
Summary: sci-mathematics/maxima-5.13.0 fails to compile with gcl
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Science Mathematics related packages
URL:
Whiteboard:
Keywords:
: 177414 185916 (view as bug list)
Depends on: 205803
Blocks:
  Show dependency tree
 
Reported: 2007-09-13 18:51 UTC by rainer
Modified: 2010-06-23 07:48 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rainer 2007-09-13 18:51:57 UTC
maxima-5.13.0 fails to compile,
I am so far using maxima-5.11.0-r2.

[...]
binary-gcl/nregex.o:nregex.c:(.text+0x0): first defined here
collect2: ld returned 1 exit status
sh: ./binary-gcl/raw_maxima: No such file or directory
Error in LET* [or a callee]: Cannot delete the file #p"./binary-gcl/raw_maxima": "No such file or directory".

Fast links are on: do (use-fast-links nil) for debugging
Broken at DELETE-FILE.  Type :H for Help.
 1 (Abort) Return to top level.
dbl:>>

Here it hangs in some input mode which is unknown to me, I do not even how to 
exit this mode gracefully.

# emerge --info
Portage 2.1.2.12 (default-linux/amd64/2006.0, gcc-4.1.2, glibc-2.5-r4, 2.6.22-gentoo-r5 x86_64)
=================================================================
System uname: 2.6.22-gentoo-r5 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
Gentoo Base System release 1.12.9
Timestamp of tree: Thu, 13 Sep 2007 18:20:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://gentoo.tiscali.nl/ http://gentoo.inode.at/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acpi aim alsa amd64 apache apache2 apm arts audiofile bash-completion bcmath berkdb bidi bitmap-fonts blas bluetooth bzip2 cdparanoia cdr cli cracklib crypt cups curl curlwrappers dga directfb doc dri dts dvb dvd dvdr dvdread eds emacs emboss encode esd evo examples exif fastcgi fbcon ffmpeg fftw flac foomaticdb fortran ftp ggi gif ginac glut gnome gnutls gphoto2 gpm gstreamer gtk gtk2 hal iconv icq idn ieee1394 imagemagick imap imlib ipv6 isdnlog jabber java javascript jikes jpeg jpeg2k kde kdeenablefinal lapack lcms ldap leim libedit libwww lirc lm_sensors lzw lzw-tiff mad madwifi matroska midi mikmod mime mng mnogosearch mono mp3 mpeg mpi msn mudflap mule mysql mysqli nas ncurses nls nptl nptlonly nsplugin nvidia ogg ole openal opengl openmp osc oscar oss pam pcre pdf perl php plotutils png pppd python qt3 qt3support qt4 quicktime radius readline reflection samba scanner sdl seamonkey server session sockets socks5 spell spl ssl symlink szip tcpd tetex theora threads tidy tiff tokenizer truetype truetype-fonts type1-fonts unicode usb v4l v4l2 vcd vhosts vorbis wifi wxwindows xcomposite xface xine xml xmlrpc xorg xosd xpm xv xvid yahoo zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIRC_DEVICES="imon" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS





Reproducible: Always
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-09-13 19:12:51 UTC
*** Bug 185916 has been marked as a duplicate of this bug. ***
Comment 2 Sébastien Fabbro (RETIRED) gentoo-dev 2007-09-13 22:38:09 UTC
Hi,

I just commited a newer maxima with the gcl-alt-link bit removed and set sbcl as the default lisp. Could you tell me whether it still hangs, I tried it with both gcl and sbcl on my boxes, and did fine.

Sebastien
Comment 3 Sverre Anmarkrud 2007-09-14 06:18:09 UTC
I had the exact same problem as the OP. Your new ebuild with sbcl as the default lisp intially failed as I did not have sbcl installed nor did the ebuild pull it in. Adding sbcl to maxima's useflags correctly pulled in sbcl and maxima compiled nicely.
Comment 4 Sébastien Fabbro (RETIRED) gentoo-dev 2007-09-14 08:43:21 UTC
> default lisp intially failed as I did not have sbcl installed nor did the
> ebuild pull it in. 

This was just fixed in cvs. Thanks. 
We should keep this bug open if maxima-5.13.0 don't compile with gcl or other lisps. Report problems here.
Comment 5 Sébastien Fabbro (RETIRED) gentoo-dev 2007-09-14 09:56:17 UTC
*** Bug 177414 has been marked as a duplicate of this bug. ***
Comment 6 rainer 2007-09-15 18:36:57 UTC
maxima-5.13.0 builds just fine for me after pulling in sbcl.
gcl has therefore become redundant and can be removed in my case. 

There seems to be a non-critical error in the ebuild:
/usr/portage/sci-mathematics/maxima/maxima-5.13.0.ebuild: line 103: !use: command not found
Comment 7 Marijn Schouten (RETIRED) gentoo-dev 2007-09-19 17:26:15 UTC
Problems related to gcl are unlikely to get fixed and gcl may be removed entirely sooner or later.

Maxima builds fine with clisp or sbcl, so I suggest using those.
Comment 8 Colin Macdonald 2007-09-19 20:24:52 UTC
just a "me too".  also fixed by switching to sbcl.
Comment 9 juantxorena@gmail.com 2007-10-28 14:04:29 UTC
Since the current maxima ebuild uses sbcl as the default lisp and it warns about problems if the user chooses gcl, this bug shouldn't be closed?
Comment 10 Justin Lecher (RETIRED) gentoo-dev 2010-06-23 07:48:30 UTC
As there is no new report for three years and the version in question left the tree I close this one. In case of objections, reopen or comment.