Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 192400 - dev-lang/php-5.2.4_pre200708051230-r2 can't find LDAP Cyrus SASL support
Summary: dev-lang/php-5.2.4_pre200708051230-r2 can't find LDAP Cyrus SASL support
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2007-09-13 10:59 UTC by Marco Napetti
Modified: 2007-09-13 21:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Marco Napetti 2007-09-13 10:59:36 UTC
I currently have dev-lang/php-5.2.4_pre200708051230-r2 installed.

I added json and soap USE flags, so a rebuild is needed, but it fails:
checking for LDAP support... yes
checking for LDAP Cyrus SASL support... no
configure: error: Cannot find ldap.h

!!! ERROR: dev-lang/php-5.2.4_pre200708051230-r2 failed.
Call stack:, line 1638:   Called dyn_compile, line 985:   Called qa_call 'src_compile', line 44:   Called src_compile
  php-5.2.4_pre200708051230-r2.ebuild, line 188:   Called src_compile_normal
  php-5.2.4_pre200708051230-r2.ebuild, line 330:   Called php5_2-sapi_src_compile
  php5_2-sapi.eclass, line 636:   Called die

[ebuild   R   ] dev-lang/php-5.2.4_pre200708051230-r2  USE="apache2 berkdb bzip2 cdb cli crypt ctype curl doc exif ftp gd iconv imap ipv6 json* ldap mysql mysqli ncurses nls oci8 odbc pcre postgres readline reflection session soap* spell spl ssl threads tidy tokenizer truetype unicode xml xmlreader xmlwriter xpm zlib (-adabas) -bcmath (-birdstep) -calendar -cgi -cjk -concurrentmodphp -curlwrappers -db2 -dbase (-dbmaker) -debug -discard-path (-empress) (-empress-bcs) (-esoob) -fastbuild (-fdftk) -filter (-firebird) -flatfile -force-cgi-redirect (-frontbase) -gd-external -gdbm -gmp -hash -inifile -interbase -iodbc -java-external -kerberos -ldap-sasl -libedit -mcve -mhash -msql -mssql -oci8-instant-client -pcntl -pdo -pdo-external -pic -posix -qdbm -recode -sapdb -sharedext -sharedmem -simplexml -snmp -sockets (-solid) -sqlite -suhosin (-sybase) (-sybase-ct) -sysvipc -wddx -xmlrpc -xsl -yaz -zip -zip-external"

emerge --info
Portage (default-linux/amd64/2006.0, gcc-4.1.2, glibc-2.5-r4, 2.6.22-gentoo-r5 x86_64)
System uname: 2.6.22-gentoo-r5 x86_64 AMD Turion(tm) 64 X2 Mobile Technology TL-50
Gentoo Base System release 1.12.9
Timestamp of tree: Thu, 13 Sep 2007 07:00:01 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
CFLAGS="-march=athlon64 -pipe -O2"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=athlon64 -pipe -O2"
FEATURES="autoconfig distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
USE="X a52 aac aalib acpi alsa amd64 amuled apache2 audiofile avi bash-completion berkdb bitmap-fonts bluetooth branding browserplugin bzip2 cdb cdda cddb cdinstall cdio cdparanoia cdr cli codecs cpudetection cracklib crypt css ctype cups curl dbus dga divx4linux dlloader doc dri dts dv dvb dvd dvdr dvdread dxr3 edl eds emboss emul-linux-x86 encode exif faad fame ffmpeg firefox flac foomaticdb fortran ftp gcj gd ggi gif gimp gimpprint glitz gphoto2 gpm gstreamer gtk gtk2 hal history hou iconv ieee1394 imagemagick imap imlib insecure-drivers ipv6 isdnlog ithreads jack java javascript jpeg jpeg2k json kde kdeenablefinal latin1 lcd ldap libcaca live lm_sensors lzo lzw lzw-tiff mad matroska midi mikmod mime monkey mozbranding mozdevelop mozilla mp3 mpeg mplayer mppe-mppc mudflap musepack musicbrainz mysql mysqli mythtv ncurses netmeeting nls nodrm nowin nowlistening nptl nptlonly nsplugin objc objc++ objc-gc oci8 odbc ogg oggvorbis opengl openmp pam pcre pdf perl php png postgres ppds pppd python qt qt3 qt3support qt4 quicktime readline reflection remote samba scanner sdl sensord session smp sms sndfile soap sou sound speex spell spl ssl svg tcpd tga theora threads tidy tiff tokenizer truetype truetype-fonts type1-fonts unicode usb v4l v4l2 vcd videos visualization vorbis webdav wifi winpopup xanim xine xinerama xml xmlreader xmlwriter xorg xpm xv xvid xvmc zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="nouveau nv vesa"
Comment 1 Marco Napetti 2007-09-13 11:01:50 UTC
I forget to say that the same error occours with dev-lang/php-5.2.4 (wich is ~amd64)
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-09-13 11:10:04 UTC
We absolutely need the config.log; the error messages produces by PHP configure scripts are not useful. Also, use 5.2.4 instead.
Comment 3 Marco Napetti 2007-09-13 14:18:20 UTC
Solved disabling threads...

[ebuild   R   ] dev-lang/php-5.2.4  USE="apache2 berkdb bzip2 cdb cli crypt ctype curl doc exif ftp gd iconv imap ipv6 json ldap mysql mysqli ncurses nls oci8-instant-client odbc pcre postgres readline reflection session soap spell spl ssl tidy tokenizer truetype unicode xml xmlreader xmlwriter xpm zlib (-adabas) -bcmath (-birdstep) -calendar -cgi -cjk -concurrentmodphp -curlwrappers -db2 -dbase (-dbmaker) -debug -discard-path (-empress) (-empress-bcs) (-esoob) -fastbuild (-fdftk) -filter (-firebird) -flatfile -force-cgi-redirect (-frontbase) -gd-external -gdbm -gmp -hash -inifile -interbase -iodbc -java-external -kerberos -ldap-sasl -libedit -mcve -mhash -msql -mssql -oci8 -pcntl -pdo -pdo-external -pic -posix -qdbm -recode -sapdb -sharedext -sharedmem -simplexml -snmp -sockets (-solid) -sqlite -suhosin (-sybase) (-sybase-ct) -sysvipc -threads -wddx -xmlrpc -xsl -yaz -zip -zip-external"

But now, reenabling threads, it compiles fine...
I can't reproduce the error...

The only thing I changed externaly php is apache, where I enabled USE flag mpm-prefork.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-09-13 14:40:50 UTC
Mixing non-threaded apache MPMs w/ threaded PHP and vice versa completely won't work. 

Comment 5 Marco Napetti 2007-09-13 21:38:53 UTC
Jakub Moc, if you try mixing incorrect MPMs apache itself don't start compiling because poratge stops with a warning.

When I disabled threads in php (I need to install pecl::apc), portage forced me to select a non-threaded mpm for apache (I was using no mpm flag, only threads also in apache).

But now, the core problem is that I can't reproduce the bug... I'm sorry...