Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 192381 - package that's not installed (python-2.3.6-r2) is blocking another package.
Summary: package that's not installed (python-2.3.6-r2) is blocking another package.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
: 211070 (view as bug list)
Depends on:
Reported: 2007-09-13 05:17 UTC by Miles Georgi
Modified: 2008-11-24 19:29 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Miles Georgi 2007-09-13 05:17:11 UTC
I have a server that hasn't been updated in over a year.  I did an emerge sync, then, when I try to do an emerge -pvu portage I get a block:

[blocks B     ] <dev-lang/python-2.3.6-r2 (is blocking app-admin/python-updater-0.2)

But I do not have either of these packages installed, as equery shows:

# equery l python
[ Searching for package 'python' in all categories among: ]
 * installed packages
[I--] [  ] dev-lang/python-2.3.5-r3 (2.3)
[I--] [  ] dev-python/python-fchksum-1.7.1 (0)

I do have the executable for python-update installed, though. 

I have tried a number of things to get around this but nothing seems to be working so I figured I'd report this as a bug as it seems to be a bug, reporting a package as blocking another when it's not installed.

Another thing is that my /etc/portage folder is completely empty and I don't think it was that way before my sync (I didn't check, but I find it hard to imagine that I never had files in there before.)  

My old profile was also deleted and I pointed the current /etc/make.profile to the 2007.0 profile.

Reproducible: Always

Steps to Reproduce:
* I can reproduce this locally but doubt you would be able to reproduce it on your end
1. emerge anything dependent on python-update

Actual Results:  
emerge anything dependent on python-update

 # emerge -pv portage

These are the packages that I would merge, in order:

Calculating dependencies ...done!

[blocks B     ] <dev-lang/python-2.3.6-r2 (is blocking app-admin/python-updater-0.2)

Expected Results:  
I should be able to unmerge python-2.3.6-r2 but it says it's not installed...

# emerge -Cv =dev-lang/python-2.3.6-r2

--- Couldn't find =dev-lang/python-2.3.6-r2 to unmerge.

>>> unmerge: No packages selected for removal.

I have spent some time trying to figure out a logical explanation for this and find a way to work around it but have not been able to.  I have also looked for an explanation of this situation but haven't found that either.  I apologize if this is not actually a bug.
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2007-09-13 05:28:35 UTC
Do NOT uninstall Python. This WILL seriously screw up your system since portage (the emerge command and related tools) use it. What that blocker is trying to tell you is that python-updater has a file collision with python versions 2.3.6-r2 and below. The correct way to resolve this is to do this:
emerge -1 python
emerge -1 python-updater
Comment 2 Miles Georgi 2007-09-13 05:52:13 UTC
This doesn't work either :/
# emerge -1 python
Calculating dependencies ...done!

!!! Error: the <dev-lang/python-2.3.6-r2 package conflicts with another package.
!!!        both can't be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers. 

 # emerge -pv1 python

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] <dev-lang/python-2.3.6-r2 (is blocking app-admin/python-updater-0.2)

[ebuild     U ] sys-devel/automake-wrapper-3-r1 [1-r1] 0 kB
[ebuild     U ] sys-devel/autoconf-wrapper-4-r3 [3-r1] 0 kB
[ebuild     U ] sys-devel/m4-1.4.9-r1 [1.4.2-r1] -examples +nls 595 kB
[ebuild     U ] sys-devel/autoconf- 2.61-r1 [2.59-r6] -emacs 1,364 kB
[ebuild  NS   ] sys-devel/automake-1.10  872 kB
[ebuild  NS   ] dev-lang/python-2.4.4-r4  +berkdb -bootstrap -build -doc -examples +gdbm -ipv6 +ncurses -nocxx -nothreads +readline +ssl -tk -ucs2 7,975 kB 
[ebuild     U ] sys-apps/sandbox-1.2.17 [1.2.11] 227 kB
[ebuild  N    ] app-misc/pax-utils-0.1.15  -caps 52 kB
[ebuild     U ] sys-apps/portage- [] -build -doc (-elibc_FreeBSD) +elibc_glibc (-elibc_uclibc) -epydoc -linguas_pl (-selinux) +userland_GNU 328 kB 
*** Portage will stop merging at this point and reload itself,
    recalculate dependencies, and complete the merge.
    You may avoid the remerging of packages by updating portage on its own.
[ebuild  N    ] app-admin/python- updater-0.2  2 kB
[ebuild  N    ] sys-apps/attr-2.4.32  +nls 78 kB
[ebuild  N    ] sys-apps/acl-2.2.39-r1  -nfs +nls 119 kB
[ebuild     U ] net-misc/rsync-2.6.9-r3 [2.6.0-r5] +acl* -ipv6* -static -xinetd 792 kB
[ebuild  N    ] virtual/libiconv-0  0 kB
[ebuild     U ] sys-devel/gettext-0.16.1-r1 [0.14.4] -doc -emacs +nls -nocxx 8,339 kB
[ebuild     U ] sys-apps/coreutils-6.9-r1 [5.2.1-r6] +acl* +nls (-selinux) -static -xattr 5,306 kB 
[ebuild  N    ] dev-python/pycrypto-2.0.1-r6  -bindist -gmp -test 150 kB

Comment 3 Miles Georgi 2007-09-13 06:00:10 UTC
peter, perhaps I could try this...

use --nodeps and install each package one at a time upto and including python-2.4.4-r4

Then try emerge -u portage again

I am trying this at the moment
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-09-13 06:51:18 UTC
We have and #gentoo on Freenode for similar things, this is not a support forum, bugzilla is for bugs. These blockers are not a bug, they are intentional.
Comment 5 Miles Georgi 2007-09-13 07:43:22 UTC
Hi, I seem to need 2.4 in order to install python-updater.  python-updater will not install unless 2.4 is there, but attempting to merge 2.4 attempts to merge python-updater as a dependency.  This results in a block since 2.4 is not already installed.  This still seems like a bug to me.  I read what you linked me to before filing this bug report, though I did make a mistake in not realizing what emerge was telling me, however, I did not imply that blocks themselves are bugs.  Rather the bug here seems to be a circular dependency in the portage tree.  I have made a post on the forum you suggested to see if somebody knows a safe way around this particular block.  If not I will open a new bug with a more clear explanation of the problem, since it's not a package that's not installed causing the block, as I mistakenly originally thought, which makes it look like a support case and not a bug report.  This situation is not standard for me when I have updated gentoo servers in the past and my buddy who works with gentoo was confused by this block as well.  This is the first time I have not been able to get around a block out of several.
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-09-13 07:58:22 UTC
emerge -1 =python-2.3.6-r2 and move on.
Comment 7 Miles Georgi 2007-09-13 08:35:33 UTC
This is one of the many things I had already tried.  The highest I can get for that major version is 2.3.5-r3.

# emerge -1 =dev-lang/python-2.3.6-r2
Calculating dependencies
!!! All ebuilds that could satisfy "=dev-lang/python-2.3.6-r2" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/python-2.3.6-r2 (masked by: ~x86 keyword)
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2007-09-13 08:37:13 UTC
So stick it into package.keywords, dunno what you are requesting here. The thing collides, the blocker is needed.
Comment 9 Miles Georgi 2007-09-13 16:55:20 UTC
I had already tried adding ~x86 to my USE variable.  I have now tried adding it to package.keywords and package.use  I get the same result.
Comment 10 Miles Georgi 2007-09-13 17:20:20 UTC
err ACCEPT_KEYWORDS is where it was supposed to go but that doesn't work either.
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2007-09-13 18:11:03 UTC
(In reply to comment #10)
*Please* read the docs on working with portage already.

echo "=dev-lang/python-2.3.6-r2" >> /etc/portage/package.keywords; emerge -1 =dev-lang/python-2.3.6-r2

Comment 12 Miles Georgi 2007-09-13 20:02:09 UTC
*sigh* the above doesn't work either.  I have read the docs.  

This appears to be working, mentioned by genone on the forum:

Install python-updater with --nodeps, then install >=python-2.4, then install >=portage-2.1.2, then run python-updater, then update or remove python-2.3 (the order is very important)

This seems like a bug to me, python-updater blocks on <2.3.6-r2 which CANNOT be installed, not by the methods you have mentioned nor any other methods I have read about or been recommended.  If it's not a bug and this behavior is desired, then it is at the very least a special case that can't be solved simply by reading the docs, and the forum recommended to me earlier would be the proper channel to discuss this.

If this is a bug please treat it as a bug, if it's not please don't offer support-type responses and rtm responses unless you know they will work.  I don't think you correctly understand the problem I am encountering.
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2007-09-13 20:10:52 UTC
Yeah, great. So it works for you, thanks for reporting back. Closed, no more comments needed.
Comment 14 Jakub Moc (RETIRED) gentoo-dev 2008-02-22 06:48:58 UTC
*** Bug 211070 has been marked as a duplicate of this bug. ***
Comment 15 Alex Zorach 2008-11-24 19:16:01 UTC
I just encountered this bug.  And I've tried everything suggested in this thread, and it didn't work.
Comment 16 Alex Zorach 2008-11-24 19:29:36 UTC
I found a thread on the forums that may be of use to anyone encountering this problem:

I was able to solve it by following the directions there.

In the future, can I recommend being a little more polite and courteous to users?  Gentoo is only as good as its community is supportive.  Ewen expert users can spend hours confounded by a small typo.  By keeping a cool head when we provide support to frustrated users, we can help them find their problem quickly...and who knows?  Maybe they'll return the favor for us some day.