Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 190860 - sys-apps/hal-0.5.9.1-r2: Pulls in two different versions of parted at the same time
Summary: sys-apps/hal-0.5.9.1-r2: Pulls in two different versions of parted at the sam...
Status: RESOLVED DUPLICATE of bug 1343
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
: 205783 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-08-31 10:15 UTC by Alexander Skwar
Modified: 2008-03-27 00:27 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Skwar 2007-08-31 10:15:39 UTC
--($:~)-- emerge -vpt hal

These are the packages that would be merged, in reverse order:

Calculating dependencies -
!!! Multiple versions within a single package slot have been 
!!! pulled into the dependency graph:

('ebuild', '/', 'sys-apps/parted-1.8.7', 'merge') pulled in by
  ('ebuild', '/', 'sys-apps/hal-0.5.9.1-r2', 'merge')

('ebuild', '/', 'sys-apps/parted-1.8.8', 'merge') pulled in by
  ('ebuild', '/', 'sys-apps/hal-0.5.9.1-r2', 'merge')

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.
                                                                                                                            ... done!
[ebuild     U ] sys-apps/hal-0.5.9.1-r2 [0.5.9.1-r1] USE="acpi crypt -debug dell disk-partition doc pcmcia (-selinux)" 0 kB 
[ebuild  N    ]  sys-apps/parted-1.8.7  USE="-debug device-mapper nls readline (-selinux)" 1,410 kB 
[ebuild  N    ]  sys-apps/parted-1.8.8  USE="-debug device-mapper nls readline (-selinux)" 0 kB 

This doesn't look right.

Is this because of the following in the hal-0.5.9.1-r2.ebuild?

        disk-partition? ( >=sys-apps/parted-1.7.1                          
                        <=sys-apps/parted-1.8.7 )

--($:~)-- emerge --info
Portage 2.1.3.6 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.22-gentoo-r2.r08.mit-ide-mod i686)
=================================================================
System uname: 2.6.22-gentoo-r2.r08.mit-ide-mod i686 Genuine Intel(R) CPU T2400 @ 1.83GHz
Gentoo Base System release 1.12.10
Timestamp of tree: Fri, 31 Aug 2007 07:20:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r4
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.4.0
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer"
DISTDIR="/Gentoo/Portage/distfiles"
EMERGE_DEFAULT_OPTS="--alphabetical"
FEATURES="ccache collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="        http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/    http://ftp.heanet.ie/pub/gentoo/        http://ftp.gentoo.or.kr/      http://ftp.uni-erlangen.de/pub/mirrors/gentoo/  http://distfiles.gentoo.org/ "
LANG="de_CH.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/Gentoo/Portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/Gentoo/Portage/build"
PORTDIR="/Gentoo/Portage/tree"
PORTDIR_OVERLAY="/usr/portage/local/layman/java-overlay /Gentoo/Portage/local-tree/misc"
SYNC="rsync://winds03:10873/gentoo-portage"
USE="X acpi alsa berkdb bitmap-fonts bluetooth cairo cdr cli cracklib crypt cups dbus dmi doc dri dvd dvdr dvdread encode fam firefox fortran gdbm gif gnome gnutls gpm gstreamer gtk hal iconv isdnlog jpeg kde kdeenablefinal kdehiddenvisibility ldap libnotify mad midi mmx mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcmcia pcre pdf perl png pppd python qt3 qt3support qt4 quicktime readline reflection samba sdl session spell spl sse sse2 ssl svg tcpd tiff truetype truetype-fonts type1-fonts unicode vorbis wifi win32codecs x86 xine xinerama xml xorg xv zlib" ALSA_CARDS="dummy hda-intel intel8x0 intel8x0m usb-audio usb-usx3y" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics vmmouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="dummy none nv nvidia vga"
Unset:  CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Doug Goldstein gentoo-dev 2007-08-31 12:54:22 UTC
Firstly, you're on Portage 2.1.3.6 when you should be on 2.1.3.7. Secondly, the depends are correct. Since libparted does not have a stable API/ABI and it changes with every minor release, it requires patches to the HAL code to work with the new version. HAL has workarounds in the code from version 1.7.1 (inclusive) to version 1.8.7 (inclusive) so the depends are correct.

Portage people, how is this solved.
Comment 2 Alexander Skwar 2007-08-31 12:57:45 UTC
FWIW: The problem also exists in Portage 2.1.3.7.
Comment 3 Andrew Gaffney (RETIRED) gentoo-dev 2007-08-31 13:46:28 UTC
Just remove the >=sys-apps/parted-1.7.1 from the ebuild. The oldest version in the tree is 1.7.1-r1.
Comment 4 Marius Mauch (RETIRED) gentoo-dev 2007-08-31 13:56:10 UTC
(In reply to comment #1)
> Portage people, how is this solved.

Dupe of bug #4315 as far as we are concerned.
Comment 5 Doug Goldstein gentoo-dev 2007-08-31 14:19:55 UTC
Made agaffney's suggested change.
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2008-01-14 12:27:29 UTC
*** Bug 205783 has been marked as a duplicate of this bug. ***
Comment 7 Ryan Hill (RETIRED) gentoo-dev 2008-03-26 03:19:51 UTC
this bug is back in hal-0.5.10 with parted-1.8.8 installed:

!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

sys-apps/parted:0

  ('ebuild', '/', 'sys-apps/parted-1.8.7', 'merge') pulled in by
    ('installed', '/', 'sys-apps/hal-0.5.10', 'nomerge')

  ('installed', '/', 'sys-apps/parted-1.8.8', 'nomerge') (no parents)

Comment 8 Ryan Hill (RETIRED) gentoo-dev 2008-03-26 03:54:49 UTC
and also with parted-1.8.7 installed:

!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

sys-apps/parted:0

  ('installed', '/', 'sys-apps/parted-1.8.7', 'nomerge') pulled in by
    ('installed', '/', 'sys-apps/hal-0.5.10', 'nomerge')

  ('ebuild', '/', 'sys-apps/parted-1.8.8', 'merge') (no parents)
Comment 9 Zac Medico gentoo-dev 2008-03-26 05:00:47 UTC
(In reply to comment #8)
>   ('installed', '/', 'sys-apps/parted-1.8.7', 'nomerge') pulled in by
>     ('installed', '/', 'sys-apps/hal-0.5.10', 'nomerge')
> 
>   ('ebuild', '/', 'sys-apps/parted-1.8.8', 'merge') (no parents)

One of the following should solve it:

1) unmask a newer version of hal that's compatible with parted-1.8.8
2) correct the hal-0.5.10 deps to indicate compatibility with parted-1.8.8
3) mask parted-1.8.8 to prevent in from being pulled in

*** This bug has been marked as a duplicate of bug 1343 ***
Comment 10 Ryan Hill (RETIRED) gentoo-dev 2008-03-27 00:27:28 UTC
oh for sure, i personally know how to fix it (in this case masking parted-1.8.8 is the only choice).  i'm just pointing out to the gentopia folks that our users might be a little annoyed by the fact that it's currently impossible to do emerge -aD world on a system with hal-0.5.10 installed and the disk-partition USE flag enabled.