Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 189984 - iso-codes-58 fails to install after build
Summary: iso-codes-58 fails to install after build
Status: RESOLVED DUPLICATE of bug 128069
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-24 00:58 UTC by G. Gibson
Modified: 2007-08-24 06:39 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description G. Gibson 2007-08-24 00:58:46 UTC
61 translated messages, 131 fuzzy translations, 218 untranslated messages.
./iso3166tab.py iso_3166.xml > iso_3166.tab.new
Traceback (most recent call last):
  File "./iso3166tab.py", line 45, in ?
    p = make_parser()
  File "/usr/lib/python2.4/site-packages/_xmlplus/sax/sax2exts.py", line 37, in make_parser
    return XMLParserFactory.make_parser(parser_list)
  File "/usr/lib/python2.4/site-packages/_xmlplus/sax/saxexts.py", line 75, in make_parser
    sys.modules[parser_name].create_parser = _create_parser
KeyError: 'xml.sax.drivers2.drv_pyexpat'
make[2]: *** [iso_3166.tab] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-text/iso-codes-0.58/work/iso-codes-0.58/iso_3166'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-text/iso-codes-0.58/work/iso-codes-0.58/iso_3166'
make: *** [install-recursive] Error 1
 * 
 * ERROR: app-text/iso-codes-0.58 failed.
 * Call stack:
 *   ebuild.sh, line 1654:   Called dyn_install
 *   ebuild.sh, line 1089:   Called qa_call 'src_install'
 *   ebuild.sh, line 44:   Called src_install
 *   iso-codes-0.58.ebuild, line 36:   Called die
 * 
 * Installation failed
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-text/iso-codes-0.58/temp/build.log'.
 *
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-08-24 06:39:14 UTC
Please, review http://bugs.gentoo.org/page.cgi?id=fields.html#bug_severity; run revdep-rebuild and re-emerge pyxml.

*** This bug has been marked as a duplicate of bug 128069 ***