Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 189971 - cursor size in ~/.Xdefaults not always honored in X
Summary: cursor size in ~/.Xdefaults not always honored in X
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-23 22:05 UTC by Tiago Marques
Modified: 2010-12-28 16:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tiago Marques 2007-08-23 22:05:54 UTC
I'm using Xcursor.size: 32 on ~/.Xdefaults, so the size of the cursor is increased.
As an example, if I have the mouse on the system tray part of kicker, the size is as i defined it. If I move it to the taskbar, it immediatly shrinks to the default size of the cursor theme.
kdesktop is the same, and other gtk apps too.

Reproducible: Always

Steps to Reproduce:
1.define Xcursor.size: 32,48,64 in ~/.Xdefaults
2.
3.



Expected Results:  
The cursor size should always be the same within X apps.
Comment 1 Wulf Krueger (RETIRED) gentoo-dev 2008-04-26 22:58:55 UTC
Please file an upstream bug for this and add a link to it to this bug.
Comment 2 Tiago Marques 2008-08-02 22:21:58 UTC
Did this:

vi /etc/profile

And added at the end:

XCURSOR_SIZE=32
export XCURSOR_SIZE

And it now works; ~/.Xdefaults
Comment 3 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-26 16:59:15 UTC
Since upstream development for 3.5 is frozen i'm closing this one
Comment 4 Tiago Marques 2009-05-26 19:33:21 UTC
Hi,

This is gentoo specific and not just KDE related. I had this happen also in Xfce, recently, where changing the cursor size in settings does nothing while it does in distro's like Fedora.

I must correct my previous statement, ~/.Xdefaults is not honored, it is where it was previously, but it will honor the value of XCURSOR_SIZE. If we have different values for both, the mouse will have two different sizes in different situations.
Comment 5 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-31 12:33:20 UTC
CC'ing x11 guys. Is there anything we can do here?
Comment 6 Tiago Marques 2009-05-31 14:14:40 UTC
(In reply to comment #5)
> CC'ing x11 guys. Is there anything we can do here?
> 

Probably not. Need me to resubmit the bug or can this be moved elsewhere not KDE related?
Comment 7 Rémi Cardona gentoo-dev 2009-06-01 17:00:12 UTC
It's up to apps and toolkits to respect those prefs. X has no role enforcing this.

Thanks
Comment 8 Tiago Marques 2009-06-01 20:10:40 UTC
So what, is this Qt and GTK related?

Best regards
Comment 9 Samuli Suominen gentoo-dev 2009-10-13 16:51:45 UTC
Some toolkits override the X's cursor, yes. It's not a bug AFAIK.
Comment 10 Tiago Marques 2009-10-13 17:39:03 UTC
(In reply to comment #9)
> Some toolkits override the X's cursor, yes. It's not a bug AFAIK.
> 

No, they don't seem to. On XFCE, the embedded XFCE settings manager thinks it's increasing the cursor size but does nothing. It keeps the 16 pixel size. The cursor size can only be controlled by XCURSOR_SIZE environment variable. If toolkits are overriding, why aren't they setting the appropriate size? Any hints on how to find out how?
Comment 11 Andreas K. Hüttel gentoo-dev 2010-12-28 16:59:06 UTC
Not a KDE problem, and probably nooone really knows what is going on. 

I'm reassigning this pro forma to the x11 guys, but probably it's best to close it NEEDINFO.