Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 189573 - sys-fs/aufs-utils: New ebuild
Summary: sys-fs/aufs-utils: New ebuild
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard: sunrise suggested
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2007-08-20 10:53 UTC by Russell Harmon
Modified: 2012-11-12 08:28 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
aufs-utils-9999.ebuild (aufs-utils-9999.ebuild,598 bytes, patch)
2007-08-20 10:53 UTC, Russell Harmon
Details | Diff
aufs-utils-99999999.ebuild (aufs-utils-99999999.ebuild,598 bytes, text/plain)
2007-08-20 11:05 UTC, Russell Harmon
Details
aufs-utils-20070812.ebuild (aufs-utils-20070812.ebuild,597 bytes, text/plain)
2007-08-20 11:05 UTC, Russell Harmon
Details
aufs-utils-0.1_pre20070812.ebuild (aufs-utils-0.1_pre20070812.ebuild,597 bytes, text/plain)
2007-08-20 11:33 UTC, Russell Harmon
Details
aufs-utils-0.1_pre20070812.ebuild (aufs-utils-0.1_pre20070812.ebuild,582 bytes, text/plain)
2007-08-20 12:36 UTC, Russell Harmon
Details
aufs-utils-9999.ebuild (aufs-utils-9999.ebuild,598 bytes, text/plain)
2007-08-20 12:37 UTC, Russell Harmon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Russell Harmon 2007-08-20 10:53:19 UTC
I wrote an ebuild for the aufs userspace utilities. I run a patched kernel and so don't need the kernel module. A cvs ebuild and a static one for 20070812 will be attached
Comment 1 Russell Harmon 2007-08-20 10:53:47 UTC
Created attachment 128660 [details, diff]
aufs-utils-9999.ebuild

cvs ebuild
Comment 2 Russell Harmon 2007-08-20 11:05:17 UTC
Created attachment 128662 [details]
aufs-utils-99999999.ebuild

I realized the 9999 version number causes some conflicts with the 20070812 version... this version number fixes it.
Comment 3 Russell Harmon 2007-08-20 11:05:47 UTC
Created attachment 128663 [details]
aufs-utils-20070812.ebuild

Static ebuild for 20070812
Comment 4 Russell Harmon 2007-08-20 11:33:12 UTC
Created attachment 128668 [details]
aufs-utils-0.1_pre20070812.ebuild

More sane version numbering.
Comment 5 Russell Harmon 2007-08-20 12:36:41 UTC
Created attachment 128669 [details]
aufs-utils-0.1_pre20070812.ebuild

Forgot to change the name of the distfile when I changed the name of the ebuild.
Comment 6 Russell Harmon 2007-08-20 12:37:22 UTC
Created attachment 128670 [details]
aufs-utils-9999.ebuild

Should go back to the old version number for the CVS build since it no longer causes problems.
Comment 7 Russell Harmon 2007-08-20 23:29:13 UTC
This is now in the sunrise overlay. You can find it at:
http://overlays.gentoo.org/svn/proj/sunrise/reviewed/sys-fs/aufs-utils/
Comment 8 Matteo Spreafico 2007-09-01 16:29:31 UTC
*** Bug 160065 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-04-13 16:15:11 UTC
(this is an automated message based on filtering criteria that matched this bug)
'EBUILD' is in the KEYWORDS which should mean that there is a ebuild attached 
to this bug.
This bug is assigned to maintainer-wanted which means that it is not in the 
main tree.
Heuristics show that no Gentoo developer has commented on your ebuild.

Hello, The Gentoo Team would like to firstly thank you for your ebuild 
submission. We also apologize for not being able to accommodate you in a timely
manner. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The 
sunrise overlay[1] is a overlay for Gentoo which we allow trusted users to 
commit to and all users can have ebuilds reviewed by Gentoo devs for entry 
into the overlay. So, the sunrise team is suggesting that you look into this 
and submit your ebuild to the overlay where even *you* can commit to. =)

Because this is a mass message, we are also asking you to be patient with us. 
We anticipate a large number of requests in a short time. 

Thanks,
On behalf of the Gentoo Sunrise Team,
Jeremy.

[1]: http://www.gentoo.org/proj/en/sunrise/
[2]: http://overlays.gentoo.org/proj/sunrise/wiki/SunriseFaq
Comment 10 Ben de Groot (RETIRED) gentoo-dev 2009-04-30 19:09:55 UTC
I have added an ebuild for aufs2-util (to go with the aufs2 kernel module) to berkano overlay.
Comment 11 Justin Lecher gentoo-dev 2012-11-12 08:28:03 UTC
commit 84a74905bc0976cff3600647fd3641a257f80d36
Author: Justin Lecher <jlec@gentoo.org>
Date:   Mon Nov 12 09:27:02 2012 +0100

    Unsupported by upstream, Please move to aufs2 or aufs3