Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 188717 - qt3 fails to build without fontconfig 'xml' USE flag enabled
Summary: qt3 fails to build without fontconfig 'xml' USE flag enabled
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2007-08-13 15:07 UTC by Jon
Modified: 2007-08-13 16:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Jon 2007-08-13 15:07:11 UTC
Long story short, expat broke my system on the last system update... again.

Anyway, I ran revdep-rebuild to fix the problem but for some reason QT 3 wouldn't finish compiling and stopped after about a third of the way through. There wasn't any ebuild error associated with it nor any specific compile error, but it stopped just as it was making some references to libfontconfig, specifically towards some XML funtions it apparently needed. Needless to say, my installed version of fontconfig didn't have the xml USE flag enabled, but by recompiling it with xml turned on fixed the qt problem.

I wanted to post this to see if anyone else had the problem or, specifically, if the fontconfig with xml USE flag should be added to qt3's build-time dependency list.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-08-13 15:11:01 UTC
Reopen with some errors and emerge --info output; thanks.
Comment 2 Jon 2007-08-13 15:50:19 UTC
Murphey's Law, I spent 3 hours trying to figure this out last night and now that I've fixed it, I can't reproduce the problem. My apologies, I'll close the bug but if I see it again I'll repost the actual compile errors.

Here's the emerge --info anyway:

Portage (default-linux/amd64/2006.1, gcc-4.1.2, glibc-2.5-r4, 2.6.20-gentoo-r8 x86_64)
System uname: 2.6.20-gentoo-r8 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4400+
Gentoo Base System release 1.12.9
Timestamp of tree: Mon, 13 Aug 2007 02:00:01 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.21
CFLAGS="-march=athlon64 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-march=athlon64 -O2 -pipe"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/local/portage"
USE="64bit 7zip X a52 aac alsa amarok amazon amd amd64 ao aoss apache2 background bash-completion berkdb bitmap-fonts blender-game bluetooth bzip2 cairo cal3d calendar cdaudio cdb cdda cddb cdinstall cdparanoia cdr cdrom cdsound cegui cg cli colordiff console cracklib crypt cscope css cups daap dar64 dbus depth32 devil directfb divx dosformat dri dv dvb dvbplayer dvd dvdnav dvdr dvdread emerald esd fbcon fbdev fbsplash ffmpeg firefox fortran freeimage ftp fuse fusion gaim gdbm gif gimp gimpprint glitz glut gmail gphoto2 gpm hal hou iconv id3 imagemagick ipv6 isdnlog java java5 javascript joystick jpeg jpeg2k kcal kde kdecards kdepim kdm lm_sensors logitech-mouse lua midi mp2 mp3 mp4 mp4live mplayer mudflap music musicbrainz mysql ncurses nls nptl nptlonly nsplugin ntfs nvidia obex offensive ogg ogre openal opengl openmp oscar oss pam pcre pdf perl php png ppds python qt3 qt4 rdesktop readline reflection reiser4 reiserfs scanner sdl sdl-image sdl-sound session sftp skins sou sounds spell spl ssl tcpd tga threads tidy tiff timidity truetype truetype-fonts type1-fonts unicode usb v4l v4l2 vcd vga videos vim vim-syntax vim-with-x visualization vnc vncviewer wma wmf wmp wordperfect x11vnc xcomposite xine xorg xscreensaver xvmc zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-08-13 16:01:00 UTC
Well, feel free to reopen if you can find out steps to reproduce and the info requested above. :) Otherwise, for random failures there's Bug 20600.