Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 188531 - emerge of x11-misc/shared-mime-info-0.21-r1 fails (first due to XML::Parser)
Summary: emerge of x11-misc/shared-mime-info-0.21-r1 fails (first due to XML::Parser)
Status: RESOLVED DUPLICATE of bug 128069
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-12 01:17 UTC by Brian Johnson
Modified: 2007-08-13 06:26 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
shared-mine-info-0.21-r1 emerge log after re-installing XML-Parser (shared-mine-info-0.21-r1 emerge log after XML-Parser,9.96 KB, text/plain)
2007-08-12 01:19 UTC, Brian Johnson
Details
shared-mine-info-0.21-r1 emerge log before re-installing XML-Parser (shared-mine-info-0.21-r1 emerge log before XML-Parser,4.34 KB, text/plain)
2007-08-12 01:20 UTC, Brian Johnson
Details
failed build log on AMD64 (build.log,2.61 KB, text/plain)
2007-08-12 01:33 UTC, Danny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Johnson 2007-08-12 01:17:04 UTC
When updating to x11-misc/shared-mime-info-0.21-r1 from x11-misc/shared-mime-info-0.20, there is an error during the configure process. It reports that the perl module XML::Parser is missing and prevents it from being emerged. After emerging dev-perl/XML-Parser, the problem gets significantly worse.

Reproducible: Always

Steps to Reproduce:
1. emerge -av =x11-misc/shared-mime-info-0.21-r1
Actual Results:  
See comments for log results of emerges.

Expected Results:  
x11-misc/shared-mime-info-0.21-r1 is merged into / without a problem.

I thought the problem would be simple, that is, by emerging XML-Parser, but clearly it does not resolve the problem.
Comment 1 Brian Johnson 2007-08-12 01:19:03 UTC
Created attachment 127801 [details]
shared-mine-info-0.21-r1 emerge log after re-installing XML-Parser
Comment 2 Brian Johnson 2007-08-12 01:20:25 UTC
Created attachment 127802 [details]
shared-mine-info-0.21-r1 emerge log before re-installing XML-Parser
Comment 3 Danny 2007-08-12 01:33:10 UTC
Created attachment 127803 [details]
failed build log on AMD64

This one fails for me also, except I'm on AMD64.

#emerge --info
Portage 2.1.2.11 (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.5-r4, 2.6.19.3 x86_64)
=================================================================
System uname: 2.6.19.3 x86_64 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Sat, 11 Aug 2007 22:30:01 +0000
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O3 -pipe -fomit-frame-pointer -fno-ident -frename-registers"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache1-php5/ext-active/ /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=nocona -O3 -pipe -fomit-frame-pointer -fno-ident -frename-registers"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer sandbox sfperms strict userpriv usersandbox"
GENTOO_MIRRORS="http://ftp-mirror.internap.com/pub/gentoo http://gentoo.oregonstate.edu/ http://sunsite.ualberta.ca/pub/unix/Linux/gentoo http://www.ibiblio.org/pub/Linux/distributions/gentoo http://csociety-ftp.ecn.purdue.edu/pub/gentoo/ ftp://ftp.gtlib.cc.gatech.edu/pub/gentoo http://cs.ubishops.ca/pub/gentoo"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac aalib acl acpi adns aim alsa amd64 arts bash-completion berkdb bitmap-fonts bzip2 cli cracklib crypt cups curl dga dri dvd emacs encode exif expat fastcgi ffmpeg firefox flac fortran ftp gcj gd gdbm geoip gif gmp gpm gtk gtk2 iconv icq imagemagick imap imlib isdnlog jabber java jikes jpeg jpeg2k kde leim libcaca lzo mad maildir midi mime mmx mng mozilla mp3 mpeg msn mudflap nas ncurses nls nptl nptlonly nsplugin offensive ogg oggvorbis opengl openmp pam pcre pdf perl php png pppd python qt4 quicktime readline reflection samba sdl session spell spl sse sse2 ssl svg tcpd tetex tga theora threads tidy tiff truetype truetype-fonts type1-fonts unicode usb vcd vorbis wmf x264 xml xorg xpm xv xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="i810"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-08-12 04:05:34 UTC
XML::Parser - Bug 41124
expat - Bug 128069

Please, search and run revdep-rebuild when told so on upgrade.

*** This bug has been marked as a duplicate of bug 128069 ***
Comment 5 Danny 2007-08-13 06:26:43 UTC
> run revdep-rebuild when told so on upgrade
I didn't see any such message.