Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 186939 - net-misc/asterisk-chan_sccp-20080526 version bump
Summary: net-misc/asterisk-chan_sccp-20080526 version bump
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: voip herd (OBSOLETE)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 297995
  Show dependency tree
 
Reported: 2007-07-28 22:08 UTC by Artem Makhutov
Modified: 2010-11-04 23:19 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
asterisk-chan_sccp-0.0.20060408.ebuild (asterisk-chan_sccp-0.0.20060408.ebuild,1.20 KB, text/plain)
2007-07-28 22:10 UTC, Artem Makhutov
Details
chan_sccp-20060408-gentoo.diff (chan_sccp-20060408-gentoo.diff,2.97 KB, text/plain)
2007-07-28 22:11 UTC, Artem Makhutov
Details
asterisk-chan_sccp-0.0.20071213.ebuild (asterisk-chan_sccp-0.0.20071213.ebuild,1.24 KB, text/plain)
2008-08-11 12:32 UTC, Artem Makhutov
Details
chan_sccp-20071213-gentoo.diff (chan_sccp-20071213-gentoo.diff,1.74 KB, text/plain)
2008-08-11 12:33 UTC, Artem Makhutov
Details
asterisk-chan_sccp-0.0.20080526.ebuild (asterisk-chan_sccp-0.0.20080526.ebuild,1.24 KB, text/plain)
2008-08-11 12:33 UTC, Artem Makhutov
Details
chan_sccp-20080526-gentoo.diff (chan_sccp-20080526-gentoo.diff,1.77 KB, text/plain)
2008-08-11 12:34 UTC, Artem Makhutov
Details
asterisk-chan_sccp-0.0.20090602.ebuild (asterisk-chan_sccp-0.0.20090602.ebuild,1.77 KB, text/plain)
2010-03-12 18:34 UTC, Timofey Negrebetsky
Details
chan_sccp-b_20090602-ifdef.patch (chan_sccp-b_20090602-ifdef.patch,559 bytes, text/plain)
2010-03-12 18:35 UTC, Timofey Negrebetsky
Details
Last ebuild for 2.0 Final version (asterisk-chan_sccp-2.0.20090602.ebuild,1.72 KB, text/plain)
2010-09-13 06:02 UTC, Timofey Negrebetsky
Details
asterisk-chan_sccp-3.0_rc1.ebuild (asterisk-chan_sccp-3.0_rc1.ebuild,1.56 KB, text/plain)
2010-09-13 06:05 UTC, Timofey Negrebetsky
Details
asterisk-chan_sccp-3.0_rc2.ebuild (asterisk-chan_sccp-3.0_rc2.ebuild,1.56 KB, text/plain)
2010-09-13 06:06 UTC, Timofey Negrebetsky
Details
asterisk-chan_sccp-3.0_rc2.ebuild (asterisk-chan_sccp-3.0_rc2.ebuild,1.76 KB, text/plain)
2010-09-13 07:04 UTC, Timofey Negrebetsky
Details
asterisk-chan_sccp-3.0_rc2.ebuild (asterisk-chan_sccp-3.0_rc2.ebuild,1.79 KB, text/plain)
2010-09-16 19:25 UTC, Timofey Negrebetsky
Details
asterisk-chan_sccp-3.0_rc3.ebuild (asterisk-chan_sccp-3.0_rc3.ebuild,1.86 KB, text/plain)
2010-11-04 23:19 UTC, Timofey Negrebetsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Artem Makhutov 2007-07-28 22:08:41 UTC
I have updated the asterisk-chan_sccp ebuild to work with version 20060408.

I have attached the new ebuild and patch. Please update the portage.

Regards, Artem

Reproducible: Always

Steps to Reproduce:
Comment 1 Artem Makhutov 2007-07-28 22:10:55 UTC
Created attachment 126269 [details]
asterisk-chan_sccp-0.0.20060408.ebuild
Comment 2 Artem Makhutov 2007-07-28 22:11:32 UTC
Created attachment 126271 [details]
chan_sccp-20060408-gentoo.diff
Comment 3 Artem Makhutov 2008-03-24 16:26:22 UTC
Will there be any updates to this?

Thanks, Artem
Comment 4 Łukasz Damentko (RETIRED) gentoo-dev 2008-08-11 00:38:10 UTC
Reassigning back to herd since Stefan has been retired as a Gentoo Developer (#27693).
Comment 5 Artem Makhutov 2008-08-11 12:32:34 UTC
Created attachment 162671 [details]
asterisk-chan_sccp-0.0.20071213.ebuild
Comment 6 Artem Makhutov 2008-08-11 12:33:01 UTC
Created attachment 162673 [details]
chan_sccp-20071213-gentoo.diff
Comment 7 Artem Makhutov 2008-08-11 12:33:25 UTC
Created attachment 162674 [details]
asterisk-chan_sccp-0.0.20080526.ebuild
Comment 8 Artem Makhutov 2008-08-11 12:34:09 UTC
Created attachment 162675 [details]
chan_sccp-20080526-gentoo.diff
Comment 9 Artem Makhutov 2008-08-11 12:35:56 UTC
I have added the newest versions of chan_sccp-b.

Version 20080526 also compiles fine with asterisk 1.4.
Comment 10 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-07-07 12:49:00 UTC
Artem, I can proxy your changes.
Do you want to be referenced as co-maintainer of the package ? (you will be CC for each bug related to it)
Comment 11 Artem Makhutov 2009-07-11 12:37:53 UTC
Hello,

ok, it would be great.

I will upload some new ebuild during the next days.
Comment 12 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-07-11 13:01:54 UTC
By the way, Artem, I've tried to work on this ebuild but I've seen this was actually a fork of chan_sccp named chan_sccp-b.
Am I right ?
Comment 13 Artem Makhutov 2009-07-11 17:07:24 UTC
Yes, you are right.

Chan_sccp is not longer beeing developed and chan_sccp-b is continuing the work.

I am not sure, if we should rename the ebuild or just keep the old name.
Comment 14 Timofey Negrebetsky 2010-03-12 18:34:28 UTC
Created attachment 223311 [details]
asterisk-chan_sccp-0.0.20090602.ebuild
Comment 15 Timofey Negrebetsky 2010-03-12 18:35:08 UTC
Created attachment 223313 [details]
chan_sccp-b_20090602-ifdef.patch
Comment 16 Tony Vroon gentoo-dev 2010-05-11 13:29:05 UTC
Current chan_sccp fails to build against Asterisk 1.6 and has been masked (for removal on June 15). Please do not file a bug to add the "B" variety of chan_sccp until versioned tarballs are provided by upstream. I am unable to commit the time it would take to track upstream SVN and create tarballs myself at appropriate times.
Comment 17 Timofey Negrebetsky 2010-09-13 06:02:08 UTC
Created attachment 247095 [details]
Last ebuild for 2.0 Final version
Comment 18 Timofey Negrebetsky 2010-09-13 06:05:56 UTC
Created attachment 247097 [details]
asterisk-chan_sccp-3.0_rc1.ebuild

Currently does not support feature-monitor (won't compile) and doxygen docs
Comment 19 Timofey Negrebetsky 2010-09-13 06:06:31 UTC
Created attachment 247098 [details]
asterisk-chan_sccp-3.0_rc2.ebuild

Currently does not support feature-monitor (won't compile) and doxygen docs
Comment 20 Timofey Negrebetsky 2010-09-13 07:04:58 UTC
Created attachment 247102 [details]
asterisk-chan_sccp-3.0_rc2.ebuild

Fixed ebuild: install default config files
Comment 21 Tony Vroon gentoo-dev 2010-09-13 10:17:06 UTC
(In reply to comment #20)
> Created an attachment (id=247102) [details]
> asterisk-chan_sccp-3.0_rc2.ebuild

The MY_P/MY_PV logic will need work, you are not allowed to hardcode these variables.
Comment 22 Timofey Negrebetsky 2010-09-16 19:21:33 UTC
(In reply to comment #21)
> (In reply to comment #20)
> > Created an attachment (id=247102) [details] [details]
> > asterisk-chan_sccp-3.0_rc2.ebuild
> 
> The MY_P/MY_PV logic will need work, you are not allowed to hardcode these
> variables.
> 

I know, but... I think I need to use some tools (e.g. 'tr' to convert to uppercase)?
Comment 23 Timofey Negrebetsky 2010-09-16 19:25:25 UTC
Created attachment 247633 [details]
asterisk-chan_sccp-3.0_rc2.ebuild
Comment 24 Timofey Negrebetsky 2010-11-04 23:19:57 UTC
Created attachment 253237 [details]
asterisk-chan_sccp-3.0_rc3.ebuild