Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 186928 - media-sound/jack-audio-connection-kit-0.109.2 re-keywording
Summary: media-sound/jack-audio-connection-kit-0.109.2 re-keywording
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: MIPS Porters
URL:
Whiteboard:
Keywords: KEYWORDREQ
Depends on:
Blocks:
 
Reported: 2007-07-28 20:56 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2008-11-30 08:20 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2007-07-28 20:56:05 UTC
As per summary, please test and consider to stable the latest version of JACK so that we can start cleaning up the old ones.

PPC, please check for regressions against your latest stable, as there seem to still be a problem with powermac ALSA driver, that is unlikely to be resolved yet, but shouldn't be a regression either, as far as I can see.

HPPA and MIPS: can you either test or drop keywording? Thanks.

Bye,
Diego
Comment 1 Markus Rothe (RETIRED) gentoo-dev 2007-07-30 11:11:37 UTC
seems to work fine on ppc64 with snd-aoa driver. ppc64 stable
Comment 2 Gustavo Zacarias (RETIRED) gentoo-dev 2007-07-30 13:55:33 UTC
sparc stable.
alsa is broken with snd-sun-cs4231 but so was the previous stable. also it seems some other alsa programs are able to "break" it like in bug #141823 (so i blame the driver).
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2007-07-31 21:10:01 UTC
(In reply to comment #0)
> HPPA and MIPS: can you either test or drop keywording? Thanks.

Hi Diego. Any idea why hppa keywords were dropped in the first place? :)
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2007-07-31 21:19:19 UTC
No idea, sorry :( I think the previous maintainers did a bit of a mess, as the keywords were quite sparse.
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2007-07-31 21:30:56 UTC
(In reply to comment #4)
> No idea, sorry :( I think the previous maintainers did a bit of a mess, as the
> keywords were quite sparse.

Could this have anything to do with it?

# grep -r jack gentoo/cvs/gentoo-x86/profiles/default-linux/hppa/use.mask
# jack is not yet supported on hppa
jack
Comment 6 Christian Faulhammer (RETIRED) gentoo-dev 2007-08-02 21:06:27 UTC
x86 stable
Comment 7 Christian Faulhammer (RETIRED) gentoo-dev 2007-08-02 21:11:10 UTC
amd64, do brutefir-1.0i, too.  Current stable fails.
Comment 8 Brian Evans 2007-08-11 14:12:08 UTC
On alpha:

media-soud/jack-audio-connection-kit-0.103.0

1. Compiles nicely
2. Passes test and collision-test
3. Works great with audacious (as an example)

Please also remove the use.mask on jack for alpha.

Portage 2.1.2.9 (default-linux/alpha/2007.0/desktop, gcc-4.1.2, glibc-2.5-r4,
2.6.22-gentoo-r1 alpha)
=================================================================
System uname: 2.6.22-gentoo-r1 alpha EV56
Gentoo Base System release 2.0.0_rc2
Timestamp of tree: Mon, 06 Aug 2007 21:50:01 +0000
distcc 2.18.3 alpha-unknown-linux-gnu (protocols 1 and 2) (default port 3632)
[enabled]
ccache version 2.4 [enabled]
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17.50.0.16
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="alpha"
AUTOCLEAN="yes"
CBUILD="alpha-unknown-linux-gnu"
CFLAGS="-mieee -pipe -O2 -mcpu=ev5"
CHOST="alpha-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config
/usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo
/etc/texmf/web2c"
CXXFLAGS="-mieee -pipe -O2 -mcpu=ev5"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distcc distlocks metadata-transfer parallel-fetch sandbox
sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LC_ALL="en_US"
LINGUAS="en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress
--force --whole-file --delete --delete-after --stats --timeout=180
--exclude=/distfiles --exclude=/local --exclude=/packages
--filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/overlay"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X acl alpha alsa berkdb bitmap-fonts bzip2 cairo cdr cli cracklib crypt
cups curl dbus dri dvdr dvdread encode evo fam fortran gdbm gif gpm gtk hal
iconv ipv6 isdnlog javascript jpeg libg++ libnotify mad midi mikmod mp3 mpeg
mudflap ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre pdf perl png
pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell
spl ssl startup-notification svg tcpd tiff truetype truetype-fonts type1-fonts
unicode vorbis xml xorg xv zlib" ALSA_CARDS="ali5451 als4000 bt87x ca0106
cmipci emu10k1 ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 maestro3
trident usb-audio via82xx ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix
dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter
mulaw multi null plug rate route share shm softvol" ELIBC="glibc"
INPUT_DEVICES="keyboard evdev mouse joystick" KERNEL="linux"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses
text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="radeon vga fbdev"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LDFLAGS,
PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 9 Jose Luis Rivero (yoswink) (RETIRED) gentoo-dev 2007-08-11 15:13:50 UTC
(In reply to comment #8)
> On alpha:
> 
> media-soud/jack-audio-connection-kit-0.103.0
> 
> 1. Compiles nicely
> 2. Passes test and collision-test
> 3. Works great with audacious (as an example)
> 
> Please also remove the use.mask on jack for alpha.
> 

0.103.0 stable on alpha, use mask removed. Thanks a lot Brian.
Comment 10 Raúl Porcel (RETIRED) gentoo-dev 2007-08-11 15:17:52 UTC
ia64 stable
Comment 11 Tobias Scherbaum (RETIRED) gentoo-dev 2007-08-16 00:11:58 UTC
ppc stable
Comment 12 Jeroen Roovers (RETIRED) gentoo-dev 2007-09-03 06:39:34 UTC
Marked ~hppa. I'd like to abuse this bug to rekeyword and unmask the jack USE flag in the next few days, though.
Comment 13 Jeroen Roovers (RETIRED) gentoo-dev 2007-09-07 21:21:28 UTC
Stable for HPPA.
Comment 14 Wulf Krueger (RETIRED) gentoo-dev 2007-09-22 14:11:49 UTC
beandog already marked this stable on amd64 in August.
Comment 15 Willard Dawson 2008-02-18 14:59:25 UTC
109.2 fails to compile on my system (2.6.24-gentoo-r2).

gcc -o netjack_packet.o -c -O2 -I../../ -I../../config -DPIC -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -Wall -I/usr/include/alsa -I/var/tmp/portage/media-sound/jack-audio-connection-kit-0.109.2/work/jack-audio-connection-kit-0.109.2 -I/var/tmp/portage/media-sound/jack-audio-connection-kit-0.109.2/work/jack-audio-connection-kit-0.109.2/config netjack_packet.c
gcc -o jacknet_client net_source.o netjack_packet.o -lm -lpthread -ldl -ljack -lpthread -lrt -lsamplerate -lasound
scons: done building targets.
>>> Source compiled.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-24705.log"

unlink:    /usr/lib/scons-0.97/SCons/__init__.pyc
unlink:    /usr/lib/scons-0.97/SCons/Script/__init__.pyc


etc. etc etc.

# emerge --info
Portage 2.1.4.4 (default-linux/x86/2007.0/desktop, gcc-4.2.3, glibc-2.7-r1, 2.6.24-gentoo-r2 i686)
=================================================================
System uname: 2.6.24-gentoo-r2 i686 Intel(R) Pentium(R) M processor 2.00GHz
Timestamp of tree: Mon, 18 Feb 2008 13:30:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.4.4-r9, 2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=i686 -O2 -pipe -ggdb"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=i686 -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US"
LC_ALL="en_US"
MAKEOPTS=""
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi aiglx alsa apache2 apm arts ati audiofile avahi avi bash-completion berkdb bitmap-fonts bluetooth bzip2 cairo caps cardbus cdr cli cracklib crypt ctype cups dba dbtool dbus diskio djvu dri dvd dvdr dvdread eds emboss encode esd ethereal evo exif expat fam fastbuild ffmpeg fftw fglrx firefox foomaticdb force-cgi-redirect fortran ftp gamin gd gdbm gif glib glitz glut gmp gnome gpm gstreamer gtk gtk2 gtkhtml guile hal iconv idn imlib ipv6 isdnlog ithreads jack java jpeg kde kerberos kqemu lcms ldap libclamav libg++ libwww lirc live lm_sensors lua mad madwifi matroska mdnsresponder-compat memlimit mhash midi mikmod mmx mmxext mng mono motif mozilla mp3 mpeg mudflap mysql ncurses netjack networking nforce2 nls nptl nptlonly nvidia ocaml ogg oggvorbis opengl openmp oss pam pango pch pcre pdf pdflib pear perl php pmu png portaudio posix pppd pulseaudio python qt qt3 qt3support qt4 qtmt quicktime readline real reflection ruby samba sasl sdl session simplexml slang sndfile snmp soap sockets spell spl sqlite sse sse2 ssl svg tcl tcltk tcpd theora threads threadsafe tiff tk tokenizer truetype truetype-fonts type1-fonts udev unicode utempter vorbis wifi win32codecs x86 xanim xinerama xml xmlrpc xorg xscreensaver xsl xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="radeon ati fglrx"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 16 Samuli Suominen gentoo-dev 2008-04-13 18:59:23 UTC
Seems to be also repoman issue with newer portages,

  KEYWORDS.dropped              3
   media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.103.0.ebuild: mips
   media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.109.0.ebuild: mips
   media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.109.2.ebuild: mips

Rekeyword or mips need global use.mask for jack and most likely lose few ebuilds with that road.
Comment 17 Ed Wildgoose 2008-10-23 18:01:27 UTC
(In reply to comment #15)
> 109.2 fails to compile on my system (2.6.24-gentoo-r2).
> 
> gcc -o netjack_packet.o -c -O2 -I../../ -I../../config -DPIC -D_REENTRANT
> -D_POSIX_PTHREAD_SEMANTICS -Wall -I/usr/include/alsa
> -I/var/tmp/portage/media-sound/jack-audio-connection-kit-0.109.2/work/jack-audio-connection-kit-0.109.2
> -I/var/tmp/portage/media-sound/jack-audio-connection-kit-0.109.2/work/jack-audio-connection-kit-0.109.2/config
> netjack_packet.c
> gcc -o jacknet_client net_source.o netjack_packet.o -lm -lpthread -ldl -ljack
> -lpthread -lrt -lsamplerate -lasound
> scons: done building targets.
> >>> Source compiled.
> --------------------------- ACCESS VIOLATION SUMMARY
> ---------------------------
> LOG FILE = "/var/log/sandbox/sandbox-24705.log"
> 
> unlink:    /usr/lib/scons-0.97/SCons/__init__.pyc
> unlink:    /usr/lib/scons-0.97/SCons/Script/__init__.pyc
> 
> 
> etc. etc etc.
> 

emerge -C scons; emerge -1 scons

*** See bug 107013 ***
Comment 18 Nick Prater 2008-11-15 12:41:10 UTC
(In reply to comment #6)
> x86 stable

I'm experiencing problems running 0.109.2-r1 on x86, with jack_client_thread zombified errors, as described by this upstream bug:

http://trac.jackaudio.org/ticket/48

0.103.0 is working fine.


Comment 19 Samuli Suominen gentoo-dev 2008-11-30 07:51:16 UTC
(In reply to comment #16)
> Rekeyword or mips need global use.mask for jack and most likely lose few
> ebuilds with that road.

There is no more jack-audio-connection-kit for mips in Portage. Closing this bug as RESOLVED, CANTFIX because it's been 2 years.
Comment 20 Ryan Hill (RETIRED) gentoo-dev 2008-11-30 08:20:39 UTC
jack has been use.masked on mips since 2004.