Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 186886 - x11-misc/slim - interferes with gensplash at shutdown
Summary: x11-misc/slim - interferes with gensplash at shutdown
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Jeremy Olexa (darkside) (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-28 12:31 UTC by Daniel Pielmeier
Modified: 2010-09-27 15:22 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
slim.conf (slim.conf.txt,2.55 KB, text/plain)
2007-07-28 16:16 UTC, Niklas Närhinen
Details
slim-reboot-shutdown.patch for hal (slim-reboot-shutdown.patch,966 bytes, patch)
2008-03-18 21:52 UTC, Daniel Pielmeier
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Pielmeier gentoo-dev 2007-07-28 12:31:43 UTC
When i shutdown or reboot my system, it seems that the gensplash theme and slim are interfering in some way as the splash theme which shows the progress of shutdown is distorted and looking ugly.
When doing a shutdown within the slim login-screen, (by giving reboot as user-name and the password) the splash theme is displayed properly. It seems that this is only a problem when trying to shutdown from a running X-Session (i use Xfce). Also when i use xdm this problem did not appear. 

I have also mentioned this problem in Bug #107526, see comment 71-73.

P.S.: It did not work with the slim-1.3.0.ebuild from my bug #186822 also.

Regards,

Daniel
Comment 1 Niklas Närhinen 2007-07-28 14:11:32 UTC
You can't use gensplash theme in vt7. It's not supported in slim.
Comment 2 Daniel Pielmeier gentoo-dev 2007-07-28 14:19:28 UTC
(In reply to comment #1)
> You can't use gensplash theme in vt7. It's not supported in slim.
> 

Read comment 73 at Bug #107526. I use it only on tty1 according to /etc/conf.d/splash.
Comment 3 Niklas Närhinen 2007-07-28 14:37:37 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > You can't use gensplash theme in vt7. It's not supported in slim.
> > 
> 
> Read comment 73 at Bug #107526. I use it only on tty1 according to
> /etc/conf.d/splash.
> 

So you try to shutdown your computer from xfce-menu? And then your screen gets messed up? Because when I shutdown from xfce, slim just restarts.
Comment 4 Daniel Pielmeier gentoo-dev 2007-07-28 14:47:55 UTC
(In reply to comment #3)
> So you try to shutdown your computer from xfce-menu? And then your screen gets
> messed up? Because when I shutdown from xfce, slim just restarts.
> 

Yes, thats the case!
When i use the quit button in the xfce menu i can choose between Reboot, Shutdown or Logout.
Comment 5 Daniel Pielmeier gentoo-dev 2007-07-28 15:01:44 UTC
(In reply to comment #3)
> 
> So you try to shutdown your computer from xfce-menu? And then your screen gets
> messed up? Because when I shutdown from xfce, slim just restarts.
> 

You need dbus and hal to be able to reboot or shutdown within xfce. See http://www.gentoo.org/doc/en/xfce-config.xml for details.
Comment 6 Niklas Närhinen 2007-07-28 15:34:35 UTC
(In reply to comment #5)

> You need dbus and hal to be able to reboot or shutdown within xfce. See
> http://www.gentoo.org/doc/en/xfce-config.xml for details.
> 

No, actually my computer does reboot and shutdown properly, slim just doesn't switch to vt1 like other dm's. When it caughts SIGTERM, it restarts. But that's afaik upstreams problem.
Comment 7 Daniel Pielmeier gentoo-dev 2007-07-28 15:40:28 UTC
(In reply to comment #6)
> 
> No, actually my computer does reboot and shutdown properly, slim just doesn't
> switch to vt1 like other dm's. When it caughts SIGTERM, it restarts. But that's
> afaik upstreams problem.
> 

So how does your configuration look like to achieve this?
Comment 8 Niklas Närhinen 2007-07-28 16:16:12 UTC
Created attachment 126242 [details]
slim.conf
Comment 9 Daniel Pielmeier gentoo-dev 2007-07-28 16:34:07 UTC
Hmm, i have compared it with mine and it does not differ besides the hide cursor and the activate numlock setting.
Comment 10 Daniel Pielmeier gentoo-dev 2007-09-08 11:41:52 UTC
(In reply to comment #0)
> When i shutdown or reboot my system, it seems that the gensplash theme and
> slim are interfering in some way as the splash theme which shows the progress
> of shutdown is distorted and looking ugly.

This problem seems to be solved now. But i can't figure out what fixed it. Whether it was a configuration change, an update of splashutils or one of the xorg-packages which also went stable recently.

If nobody complains i will close this bug in a few days.

Regards,

Daniel
Comment 11 Daniel Pielmeier gentoo-dev 2007-10-06 13:47:07 UTC
The Interference has disappeared so closing this bug!
Comment 12 Daniel Pielmeier gentoo-dev 2007-10-20 19:58:11 UTC
I don't know the reasons, but it seemed temporarily working but now it started again!

First i thought it happens only when an external monitor is connected, but it also happens when the monitor is not plugged in!
Comment 13 Daniel Pielmeier gentoo-dev 2008-03-10 22:03:44 UTC
I think i have identified the problem with the help of spock and dberkholz!

The problem at shutdown/reboot from xfce is slim trying to restart X. So the splash which runs on tty12 is interrupted as there is a switch to tty7 where X is started.

dberkholz told me in gnome the gdm is killed when there is a shutdown or reboot. Is it possible to configure xfce in the same way, so it kills slim when rebooting or shutting down?

I just want to know if this doable in gentoo. If not i will file a bug about this issue upstream!
Comment 14 Daniel Pielmeier gentoo-dev 2008-03-18 21:52:23 UTC
Created attachment 146526 [details, diff]
slim-reboot-shutdown.patch for hal

I have found a solution to this problem. I changed the hal reboot and shutdown scripts which are invoked at xfce shutdown/reboot. I just added "pkill slim" to /usr/sbin/shutdown -h/r now. This kills slim immediately after exiting from xfce. However i think this is a bit ugly, maybe someone knows a better solution.
Comment 15 Samuli Suominen (RETIRED) gentoo-dev 2008-04-10 17:49:33 UTC
I don't see why xfce is CC'd here. The proposed "solution" is only a workaround, dig some more..
Comment 16 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-09-23 03:35:48 UTC
(In reply to comment #15)
> I don't see why xfce is CC'd here. The proposed "solution" is only a
> workaround, dig some more..
> 

Daniel, I agree with drac here.

nightmorph: Do you have any insight into this issue? 

I do think that the slim init script needs some work but I haven't identified what needs to be done quite yet.
Comment 17 Daniel Pielmeier gentoo-dev 2008-09-23 08:10:32 UTC
(In reply to comment #16)
> (In reply to comment #15)
> > I don't see why xfce is CC'd here. The proposed "solution" is only a
> > workaround, dig some more..
> > 
> Daniel, I agree with drac here.

I am happy that still someone cares about this bug. I just added xfce because this was my last resort. I have talked to so much people until now and nobody was able to help me besides spock who gave me the tip for the workaround mentioned above. I had contact with dberkholz,drac,uberlord and also a slim maintainer on irc and per email. If anybody is interested I can search for the logs and emails I may have saved somewhere and add this information to the bug.

> nightmorph: Do you have any insight into this issue? 
> I do think that the slim init script needs some work but I haven't identified
> what needs to be done quite yet.

Hm, there is no init script for slim, I think this is all managed from the xdm init script. I have already looked into it but did not really get a clue what could be done there.

The main problem in my opinion is that slim or the init script somehow needs to know if a reboot/shutdown is triggered from the DE/WM. If this is the case slim should be stopped or killed. If the user just logs out from his session slim should reload and present the login screen again.

Maybe bug #238328 which you recently closed has something to do with this. But disabling pam seems to stop slim in any case after executing a reboot/shutdown/logout.

Anyway thanks for taking care. I am not so much into this issue anymore as I am currently happy with my workaround so I may have forgotten some details. But if you are willing to fix this issue I will spend some time on this again and will help where I can.
Comment 18 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-09-24 19:13:11 UTC
(In reply to comment #17)
> (In reply to comment #16)
> > (In reply to comment #15)
> > > I don't see why xfce is CC'd here. The proposed "solution" is only a
> > > workaround, dig some more..
> > > 
> > Daniel, I agree with drac here.
> 
> I am happy that still someone cares about this bug. I just added xfce because

Yup, I care. I'm an exclusive xfce user too. Don't know too much about other WMs

> this was my last resort. I have talked to so much people until now and nobody
> was able to help me besides spock who gave me the tip for the workaround
> mentioned above. I had contact with dberkholz,drac,uberlord and also a slim
> maintainer on irc and per email. If anybody is interested I can search for the
> logs and emails I may have saved somewhere and add this information to the bug.
> 
> > nightmorph: Do you have any insight into this issue? 
> > I do think that the slim init script needs some work but I haven't identified
> > what needs to be done quite yet.
> 
> Hm, there is no init script for slim, I think this is all managed from the xdm
> init script. I have already looked into it but did not really get a clue what
> could be done there.

yea, the other day I issued a "/etc/init.d/xdm stop" and slim didn't die. I didn;t look into it anymore though.

> 
> The main problem in my opinion is that slim or the init script somehow needs to
> know if a reboot/shutdown is triggered from the DE/WM. If this is the case slim
> should be stopped or killed. If the user just logs out from his session slim
> should reload and present the login screen again.

My slim instance gets reloaded if I log out of xfce.

> 
> Maybe bug #238328 which you recently closed has something to do with this. But
> disabling pam seems to stop slim in any case after executing a
> reboot/shutdown/logout.

Which is what bug #238328 was about. I'm confused, did this realization help *this* bug or have no effect?

> 
> Anyway thanks for taking care. I am not so much into this issue anymore as I am
> currently happy with my workaround so I may have forgotten some details. But if
> you are willing to fix this issue I will spend some time on this again and will
> help where I can.
> 

Comment 19 Daniel Pielmeier gentoo-dev 2008-09-24 19:35:07 UTC
(In reply to comment #18)
> > 
> > The main problem in my opinion is that slim or the init script somehow needs to
> > know if a reboot/shutdown is triggered from the DE/WM. If this is the case slim
> > should be stopped or killed. If the user just logs out from his session slim
> > should reload and present the login screen again.
> 
> My slim instance gets reloaded if I log out of xfce.

Yeah, but does it also reload if you do a shutdown or reboot? This is what causes the interference for me.

> > Maybe bug #238328 which you recently closed has something to do with this. But
> > disabling pam seems to stop slim in any case after executing a
> > reboot/shutdown/logout.
> 
> Which is what bug #238328 was about. I'm confused, did this realization help
> *this* bug or have no effect?

Don't know :-)
Comment 20 James Le Cuirot gentoo-dev 2009-01-01 20:45:46 UTC
I use XFCE and I haven't seen this kind of corruption lately but I do find that slim always refuses to stop in general. Even if I haven't logged in with it yet, if I switch to vt1 and enter "/etc/init.d/xdm stop", slim always refuses to stop and I can only successfully stop it by entering "killall X; killall -9 slim" first. I think this could be related.
Comment 21 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-01-23 04:47:45 UTC
(In reply to comment #20)
> I use XFCE and I haven't seen this kind of corruption lately but I do find that
> slim always refuses to stop in general. Even if I haven't logged in with it
> yet, if I switch to vt1 and enter "/etc/init.d/xdm stop", slim always refuses
> to stop and I can only successfully stop it by entering "killall X; killall -9
> slim" first. I think this could be related.
> 

Yea, I've seen this too. Not sure of a fix yet that is safe for all login managers
Comment 22 Sergey Zasenko 2009-09-19 07:32:02 UTC
(In reply to comment #20)
> I use XFCE and I haven't seen this kind of corruption lately but I do find that
> slim always refuses to stop in general. Even if I haven't logged in with it
> yet, if I switch to vt1 and enter "/etc/init.d/xdm stop", slim always refuses
> to stop and I can only successfully stop it by entering "killall X; killall -9
> slim" first. I think this could be related.
> 

I have the same problem on my PC and laptop. Slim refuses to stop by stopping xdm manager. It don't stop correctly by killing it.
Comment 23 Francisco Lloret 2009-12-29 22:17:06 UTC
Try if downgrading xorg-server to xorg-server-1.6.3.901-r2 from 1.6.5-r1 solves your problem. May be related to this bug: https://bugs.gentoo.org/show_bug.cgi?id=297655
Comment 24 Doktor Notor 2010-02-26 14:31:13 UTC
I can't reproduce any splash screen corruption w/ latest ~arch

# qlist -CIv xorg-server splashutils v86d
media-gfx/splashutils-1.5.4.3
sys-apps/v86d-0.1.9
x11-base/xorg-server-1.7.5

# zgrep FB /proc/config.gz | grep -v ^#
CONFIG_FB=y
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
CONFIG_FB_MODE_HELPERS=y
CONFIG_FB_UVESA=y
CONFIG_FB_CON_DECOR=y

Wrt slim refusing to terminate, there's Bug 261359 about htis apparently without any solution, see my comment there.
Comment 25 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-09-27 15:22:01 UTC
Bug 261359 was fixed, I guess this issue is fixed too.