Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 186868 - media-sound/audacious-1.3.2 does not skip bad files anymore
Summary: media-sound/audacious-1.3.2 does not skip bad files anymore
Status: VERIFIED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-28 09:53 UTC by DEMAINE Benoît-Pierre, aka DoubleHP
Modified: 2007-11-12 17:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
/tmp/emerge--info (emerge--info,4.79 KB, text/plain)
2007-07-28 09:54 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details
~/.config/audacious/config (config,2.77 KB, text/plain)
2007-07-28 17:15 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DEMAINE Benoît-Pierre, aka DoubleHP 2007-07-28 09:53:46 UTC
on file opening, audacious used to skip bad files:
- deleted
- unavailable codec/plugin

Since a few weeks, it now hangs on them: playing stops, interface shows the stop state, but in fact is in "pause" state. Then, I have to perform a STOP, then NEXT, then play again.

I would say that 2 or 3 weeks ago, it used to work like XMMS: just skip the track, and keep playing all day long. I sware that when I moved to audacious (when XMMS have been masked), at the beginning (until june), audacious used to play all day long like XMMS used to.

*** *** *** *** *** *** ***

root@moon_gen_2:~# emerge -DpeNuv world |grep -i audaci
[ebuild   R   ] x11-themes/audacious-themes-0.0.3  509 kB [?=>0]
[ebuild   R   ] media-sound/audacious-1.3.2  USE="nls -chardet" 0 kB [?=>0]
[ebuild   R   ] media-plugins/audacious-plugins-1.3.5  USE="aac alsa arts esd flac jack lirc mad modplug musepack nls opengl oss sndfile vorbis wma -adplug -chardet -pulseaudio -sid -timidity -tta -wavpack" 0 kB [?=>0]
[ebuild   R   ] media-plugins/audacious-xosd-0.5  0 kB [?=>0]
root@moon_gen_2:~#
Comment 1 DEMAINE Benoît-Pierre, aka DoubleHP 2007-07-28 09:54:02 UTC
Created attachment 126207 [details]
/tmp/emerge--info
Comment 2 Tony Vroon gentoo-dev 2007-07-28 17:08:08 UTC
You will need to attach ~/.config/audacious/config
Also, please read the bug reporting guide, and never report bugs without supplying emerge --info. I will require additional information before I'll be able to help you.
Comment 3 DEMAINE Benoît-Pierre, aka DoubleHP 2007-07-28 17:15:13 UTC
Created attachment 126243 [details]
~/.config/audacious/config

hell, if you did not see my emerge --info, I am sorry to say that I can not help you. After 2 years filling bugs, you are the first one saying me this. It's overs 30 bugs I attach it, and Jakub who sorts most of my bugs always found it.
Comment 4 Matthias Schwarzott gentoo-dev 2007-08-25 10:23:11 UTC
needed info seems attached already.
Comment 5 Tony Vroon gentoo-dev 2007-11-12 16:39:05 UTC
get_info_on_demand=TRUE

^ You told audacious to assign decoders on demand. As such, files get added to the playlist in bulk without being evaluated. You can control this from the audio tab. Untick 'detect file formats on demand, instead of immediately'.

This is not a bug. This is a feature for people that care so much about their >40k entry playlists loading quickly that they are willing to sacrifice file filtering.

It can do it fast, or it can do it right. You told it to do it fast.
Comment 6 DEMAINE Benoît-Pierre, aka DoubleHP 2007-11-12 17:08:22 UTC
I do not unerstand what is the problem. I agree that my conf says:
get_info_on_demand=TRUE
still actually, when checking my actual settings are still the same as when I opened the bug.

What I do not underestand is what you say about the GUI. I have options:
- detec file format on demand, instead of immediately
- detect file format by extensions.

Second is ticked, not first one.

The popup says: when checked, audacious will detect file format on demand. This will resulte in a messier playlist, but delivers a major speed benefit.

My understanding of this pop-up message is that, I need to tick to get the feature "on". That is not coherent with the content of ~/.config/audacious/config

Either Audacious has a bug, and does not mess with this option properly (between conf file, and GUI), or the conf file is at some other place (I know some other softwares that put conf files at different places depending on moods, such as Rox-lib, depending on if it's installed locally, or via 0install ... and also OpenOffice versions prior to 1.0.0 ... used conf file in ~/.soffice , or the old name of the conf directory of the proprietary software it comes from I forgot it's name).

So, either cases:
- ~/.config/audacious/config is the right file, and GUI does not inherit properly the options
- the file is not this one, bot .foobar, and GUI is coherent with .foobar, and then my GUI settings just say that, your point is compleetely useless.

In both cases, there is a bug. I have to re-open.
Comment 7 Tony Vroon gentoo-dev 2007-11-12 17:10:08 UTC
File it upstream then, this is nothing that the distribution has to carry a patch for.
Comment 8 DEMAINE Benoît-Pierre, aka DoubleHP 2007-11-12 17:13:51 UTC
I have played with the option in the GUI, tick it on, off, restart Auidacious many times ... in any case, whatever the case is ticked or not, I ALWAYS get:

dhp@moon_gen_2:~$ cat ~/.config/audacious/config |grep get_info_on_demand
get_info_on_demand=TRUE
dhp@moon_gen_2:~$ cat ~/.config/audacious/config |grep get_info_on_demand
get_info_on_demand=TRUE
dhp@moon_gen_2:~$ cat ~/.config/audacious/config |grep get_info_on_demand
get_info_on_demand=TRUE
dhp@moon_gen_2:~$ cat ~/.config/audacious/config |grep get_info_on_demand
get_info_on_demand=TRUE
dhp@moon_gen_2:~$

There definitely is a bug ... or we deal with the wrong conf file ... what is also a bug, since, the folder ~/.config/audacious have been created by Audacious itself, ~/.audacious does not exist, and, I consider that creating a conf folder and stop using it as a bug.

FYI:

dhp@moon_gen_2:~/.config/audacious$ ls -la
total 596
drwxr-xr-x  2 dhp dhp   4096 2007-11-12 17:59 .
drwx------ 14 dhp dhp   4096 2007-10-29 14:01 ..
-rw-r--r--  1 dhp dhp  10609 2007-11-12 18:08 accels
-rw-r--r--  1 dhp dhp   2837 2007-11-12 18:08 config
-rw-r--r--  1 dhp dhp  59306 2007-11-12 18:08 log
-rw-r--r--  1 dhp dhp 513131 2007-11-12 18:08 playlist.xspf

so, conf files have been modified ... quiet recently :) just 3 mn ago :)

Unless the line get_info_on_demand does NOT reflect the box called 
- detect file format on demand, instead of immediately
in the GUI ???