Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 185998 - sys-devel/m4-1.4.10 fails with -ffast-math
Summary: sys-devel/m4-1.4.10 fails with -ffast-math
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
: 191081 193462 196063 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-07-20 14:50 UTC by Bugs Bunny
Modified: 2007-10-16 15:45 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild patch filtering -ffast-math (m4-1.4.10-ffast-math.diff,675 bytes, text/plain)
2007-07-20 14:50 UTC, Bugs Bunny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bugs Bunny 2007-07-20 14:50:15 UTC
sys-devel/m4-1.4.10 will fail to build with an undefind reference, this is caused by -ffast-math being in CFLAGS. Simple solution is to filter the flag as it is known to cause issues. Patch attached is the solution to this minor problem.

Reproducible: Always




Portage 2.1.3_rc8 (default-linux/amd64/2007.0, gcc-4.2.0, glibc-2.6-r0, 2.6.22-ck1 x86_64)
=================================================================
System uname: 2.6.22-ck1 x86_64 AMD Athlon(tm) 64 Processor 3800+
Gentoo Base System release 1.12.10
Timestamp of tree: Fri, 20 Jul 2007 02:30:01 +0000
ccache version 2.4 [disabled]
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r7
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17.50.0.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=athlon64 -ffast-math -ftracer -fprefetch-loop-arrays -pipe -fforce-addr -ftree-vectorize"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=athlon64 -ffast-math -ftracer -fprefetch-loop-arrays -pipe -fforce-addr -ftree-vectorize"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/gentoo"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acpi alsa amd64 berkdb branding bzip2 cdr cpudetection cracklib crypt cups dbus dri dvd dvdr dvdread encode ffmpeg firefox gdm gif gnome gtk hal jpeg mad mmx mmxext moznopango mp3 ncurses nptl nptlonly nsplugin nss ogg opengl pam perl pic png python readline sdl spell sse sse2 ssl svg tcpd tiff unicode vorbis x264 xinerama xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x 	ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 	trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="copy linear route mulaw alaw adpcm rate plug multi shm file null empty share meter hooks lfloat ladspa dmix dshare dsnoop asym iec958 softvol extplug ioplug" ELIBC="glibc" INPUT_DEVICES="mouse keyboard synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="radeon fglrx"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Bugs Bunny 2007-07-20 14:50:46 UTC
Created attachment 125466 [details]
ebuild patch filtering -ffast-math
Comment 2 Bugs Bunny 2007-07-20 14:51:08 UTC
fixed the typo in summary
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-07-20 14:52:03 UTC
Erm, nope. You are using retarded global flags -> your problem.
Comment 4 Bugs Bunny 2007-07-20 14:53:21 UTC
Piss off you wanker I have had enough of your bullshit. Just assign the damn bug to the appropriate herd so it can be fixed.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-07-20 14:58:52 UTC
Don't use stupid global C[XX]FLAGS (man gcc)
Comment 6 Bugs Bunny 2007-07-20 15:01:48 UTC
Christel you need to do something with this asshole. This is become rediculous with how he handles bugs. This is a valid bug and I will not have some kids tell me what cflags when upstream and I have spoken on my CFLAGS before this bug just needs to be fixed and done with already.
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2007-07-20 15:03:54 UTC
Your bugzilla account should be suspended. It's really sad that an ex-developer can't read man gcc.
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2007-07-20 15:05:30 UTC
man gcc:

<snip>
This option should never be turned on by any -O option since it can result in incorrect output for programs which depend on an exact implementation of IEEE or ISO rules/specifications for math functions.
</snip>

http://devmanual.gentoo.org/ebuild-writing/functions/src_compile/build-environment/index.html

CLOSED, don't touch this bug.
Comment 9 Bugs Bunny 2007-07-20 15:06:45 UTC
(In reply to comment #8)
> man gcc:
> 
> <snip>
> This option should never be turned on by any -O option since it can result in
> incorrect output for programs which depend on an exact implementation of IEEE
> or ISO rules/specifications for math functions.
> </snip>
> 
> http://devmanual.gentoo.org/ebuild-writing/functions/src_compile/build-environment/index.html
> 
> CLOSED, don't touch this bug.
> 

 HAHA your a nobody a bug wrangler assign the bug and be done with it I will reopen it as long as it takes to get it fixed.
Comment 10 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-07-20 15:27:33 UTC
(In reply to comment #4)
> Piss off you wanker I have had enough of your bullshit. Just assign the damn
> bug to the appropriate herd so it can be fixed.
> 

Anarchy, please {re-}read the CoC - http://www.gentoo.org/proj/en/council/coc.xml
This type of language *won't* be tolerated. If you fail to act courteously, your account will be suspended

(This is an userrel notice)
Comment 11 Bugs Bunny 2007-07-20 17:49:17 UTC
(In reply to comment #10)
> (In reply to comment #4)
> > Piss off you wanker I have had enough of your bullshit. Just assign the damn
> > bug to the appropriate herd so it can be fixed.
> > 
> 
> Anarchy, please {re-}read the CoC -
> http://www.gentoo.org/proj/en/council/coc.xml
> This type of language *won't* be tolerated. If you fail to act courteously,
> your account will be suspended
> 
> (This is an userrel notice)
> 

suspend it I do not care I have 1300 more email addies I can use for bugzilla. Get real and do something with your dumbass bug wrangler who has no fucking clue.
Comment 12 Mike Doty (RETIRED) gentoo-dev 2007-07-20 23:12:28 UTC
(In reply to comment #11)
This account has been disabled.
Comment 13 SpanKY gentoo-dev 2007-07-22 23:47:48 UTC
filtering flags is not a fix.  upstream gnulib has already addressed the issue, so it'll get fixed eventually with a newer version of m4.  wait for that.
Comment 14 SpanKY gentoo-dev 2007-09-02 19:10:54 UTC
*** Bug 191081 has been marked as a duplicate of this bug. ***
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2007-09-23 05:49:32 UTC
*** Bug 193462 has been marked as a duplicate of this bug. ***
Comment 16 Eugene St Leger 2007-09-23 21:16:26 UTC
This does actually appear to be a bug, however it may be triggered.

Shouldn't this bug be marked as verified, so people (like me) can find it more easily?  Shouldn't the ebuild for sys-devel/m4-1.4.10 be tweaked to strip the -ffast-math flag, at least for pragmatic reasons (less reports)?
Comment 17 SpanKY gentoo-dev 2007-09-24 05:16:45 UTC
read comment #13
Comment 18 Jakub Moc (RETIRED) gentoo-dev 2007-10-16 15:45:43 UTC
*** Bug 196063 has been marked as a duplicate of this bug. ***