Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 185507 - app-portage/genlop - Bad error message for --current
Summary: app-portage/genlop - Bad error message for --current
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High trivial (vote)
Assignee: Portage Tools Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-16 09:17 UTC by Jeroen Roovers
Modified: 2012-02-28 19:35 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers gentoo-dev 2007-07-16 09:17:19 UTC
Bug #99823 dealt with the problem that sys-apps/portage had switched from using pid files to using nothing of the sort for genlop to recognise a sandbox process by, apart from the process name in the proc filesystem which was then used in the subsequent version of genlop (bug #100938) that ultimately fixed that bug.

One complaint of mine at the time was that the developers changed the error message in a way that didn't match all the cases in which the error occured:

# genlop -c
!!! Error: no working merge found.
(the -c option only works if there is an ongoing compilation, see manpage)

In this case, for instance, there was no sandbox process for genlop to recognise because FEATURES=userpriv had been set: only an ebuild.sh process owned by portage:portage could tell genlop that there was an ongoing compilation.

genlop -c also fails when there is an emerge running, but no sandbox. Even if the code that recognises ongoing emerge processes were not enhanced to pick up non-sandbox emerge processes as well, the above error message is plainly wrong in its explanation as to why it failed to find any running processes it could use, and adds an insulting RTFM to boot.

Summarising, the error message should probably be replaced with something like this:

!!! Error: no working merge found.

until such time when genlop is again fixed to find these special emerge processes too.
Comment 1 Chad A. Simmons 2007-07-24 11:46:12 UTC
manpage should be updated it does not work here with FEATURES set to sandbox userpriv user-sandbox as per the manpage. Receive same message no working merge found.