Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 184981 - sys-process/cronbase-0.3.2 missing dependency to sys-apps/shadow
Summary: sys-process/cronbase-0.3.2 missing dependency to sys-apps/shadow
Status: RESOLVED DUPLICATE of bug 53269
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-11 18:34 UTC by steveb
Modified: 2007-07-11 18:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description steveb 2007-07-11 18:34:47 UTC
I just installed a new system and emerged some packages. sys-process/cronbase is however failing because it uses the eutils eclass and the eclass uses groupadd but the package providing groupadd is not installed.

error message:
>>> Emerging (3 of 9) sys-process/cronbase-0.3.2 to /
 * checking ebuild checksums ;-) ...                                                           [ ok ]
 * checking auxfile checksums ;-) ...                                                          [ ok ]
 * checking miscfile checksums ;-) ...                                                         [ ok ]
 * Adding group 'cron' to your system ...
 *  - Groupid: 16
/usr/portage/eclass/eutils.eclass: line 708: groupadd: command not found

!!! ERROR: sys-process/cronbase-0.3.2 failed.
Call stack:
  ebuild.sh, line 1637:   Called dyn_setup
  ebuild.sh, line 704:   Called qa_call 'pkg_setup'
  ebuild.sh, line 44:   Called pkg_setup
  cronbase-0.3.2.ebuild, line 16:   Called enewgroup 'cron' '16'
  eutils.eclass, line 708:   Called die

!!! enewgroup failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/sys-process/cronbase-0.3.2/temp/build.log'.

Reproducible: Always
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-07-11 18:35:56 UTC

*** This bug has been marked as a duplicate of bug 53269 ***