Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 184792 - dev-lang/mono-1.2.4: problems with NDesk.GLib on PPC and SPARC
Summary: dev-lang/mono-1.2.4: problems with NDesk.GLib on PPC and SPARC
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
Depends on: 191541
Blocks:
  Show dependency tree
 
Reported: 2007-07-09 23:32 UTC by Henrique Rodrigues
Modified: 2007-09-10 19:10 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Henrique's emerge --info (emerge_info.txt,7.54 KB, text/plain)
2007-07-09 23:34 UTC, Henrique Rodrigues
Details
The result of running banshee with mono-1.2.4 (banshee_log.txt,4.61 KB, text/plain)
2007-07-09 23:35 UTC, Henrique Rodrigues
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Henrique Rodrigues 2007-07-09 23:32:05 UTC
In a clean installation of Gentoo I found out that the following applications would not work because of mono-1.2.4:

media-sound/banshee
media-gfx/f-spot
media-sound/last-exit

After downgrading to mono-1.2.3.1, the applications started working.

I'll attach the output of running Banshee with mono-1.2.4. The others are very similar.

It's interesting to note that I'm on PPC and another person on SPARC had the same problem. Maybe it's an endianness issue?
Comment 1 Henrique Rodrigues 2007-07-09 23:34:30 UTC
Created attachment 124389 [details]
Henrique's emerge --info
Comment 2 Henrique Rodrigues 2007-07-09 23:35:19 UTC
Created attachment 124390 [details]
The result of running banshee with mono-1.2.4
Comment 3 Henrique Rodrigues 2007-07-09 23:36:14 UTC
I forgot to mention that this doesn't seem to affect x86 users.
Comment 4 Jurek Bartuszek (RETIRED) gentoo-dev 2007-09-09 18:41:23 UTC
this seems to be already fixed in 1.2.5, wait until it hits portage
Comment 5 Jurek Bartuszek (RETIRED) gentoo-dev 2007-09-10 19:10:37 UTC
1.2.5 is in portage and this issue should be fixed. Reopen if needed