Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 184551 - app-text/docbook-sgml-utils-0.6.14 fails to merge
Summary: app-text/docbook-sgml-utils-0.6.14 fails to merge
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo SGML herd
URL:
Whiteboard:
Keywords:
: 210493 215849 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-07-07 22:45 UTC by Frank Schmitt
Modified: 2011-11-19 20:03 UTC (History)
14 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
checksums for xml-dtd-4.1.2 (md5-4.1.2,2.39 KB, text/plain)
2008-09-05 17:15 UTC, Guenther Brunthaler
Details
The build.log of my persistent failure (build.log,1.75 MB, text/plain)
2008-09-08 09:35 UTC, Jason Cornez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Schmitt 2007-07-07 22:45:45 UTC
docbook-sgml-utils-0.6.14 fails to merge

Reproducible: Always

Steps to Reproduce:
1. emerge -1 docbook-sgml-utils

Actual Results:  

Making all in HTML
make[2]: Entering directory `/var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/work/docbook-utils-0.6.14/doc/HTML'
SGML_CATALOG_FILES=/etc/sgml/catalog \
        SGML_SEARCH_PATH=../..:../../doc:.. \
                jade -t sgml -i html -d ../../docbook-utils.dsl\#html \
                        -V '%use-id-as-filename%' ../../doc/docbook-utils.sgml
jade:/etc/sgml/sgml-docbook-4.3.cat:1:8:E: cannot open "/usr/share/sgml/docbook/sgml-dtd-4.3/catalog" (No such file or directory)
jade:/etc/sgml/sgml-docbook-4.3.cat:1:8:E: cannot open "/usr/share/sgml/docbook/sgml-dtd-4.3/catalog" (No such file or directory)
jade:/etc/sgml/sgml-docbook-4.3.cat:1:8:E: cannot open "/usr/share/sgml/docbook/sgml-dtd-4.3/catalog" (No such file or directory)
jade:/etc/sgml/sgml-docbook-4.3.cat:1:8:E: cannot open "/usr/share/sgml/docbook/sgml-dtd-4.3/catalog" (No such file or directory)
jade:/etc/sgml/sgml-docbook-4.3.cat:1:8:E: cannot open "/usr/share/sgml/docbook/sgml-dtd-4.3/catalog" (No such file or directory)
jade:/etc/sgml/sgml-docbook-4.3.cat:1:8:E: cannot open "/usr/share/sgml/docbook/sgml-dtd-4.3/catalog" (No such file or directory)
jade:/etc/sgml/sgml-docbook-4.3.cat:1:8:E: cannot open "/usr/share/sgml/docbook/sgml-dtd-4.3/catalog" (No such file or directory)
jade:/etc/sgml/sgml-docbook-4.3.cat:1:8:E: cannot open "/usr/share/sgml/docbook/sgml-dtd-4.3/catalog" (No such file or directory)
jade:/etc/sgml/sgml-docbook-4.3.cat:1:8:E: cannot open "/usr/share/sgml/docbook/sgml-dtd-4.3/catalog" (No such file or directory)
[...]
jade:/etc/sgml/sgml-docbook-4.3.cat:1:8:E: cannot open "/usr/share/sgml/docbook/sgml-dtd-4.3/catalog" (No such file or directory)
make[2]: *** [api.html] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/work/docbook-utils-0.6.14/doc/HTML'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/work/docbook-utils-0.6.14/doc'
make: *** [all-recursive] Error 1

!!! ERROR: app-text/docbook-sgml-utils-0.6.14 failed.
Call stack:
  ebuild.sh, line 1621:   Called dyn_compile
  ebuild.sh, line 973:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  ebuild.sh, line 647:   Called die



emerge --info
Portage 2.1.2.9 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.5-r4, 2.6.18 i686)
=================================================================
System uname: 2.6.18 i686 Pentium III (Coppermine)
Gentoo Base System release 1.12.9
Timestamp of tree: Sat, 07 Jul 2007 18:30:01 +0000
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r7
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium3 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=pentium3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ http://mirror.switch.ch/ftp/mirror/gentoo/"
LANG=""
LINGUAS="de"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS="--bwlimit=90 --exclude='lost+found' --timeout=500"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac alsa avi bitmap-fonts bzip2 chardet cli cups dbus dlloader dri emboss expat foomaticdb gd gencertdaily gif glut gnome gpm gtk gtk2 hal iconv idn isdnlog jpeg lcms lcmsmng libg++ mad mmx mng mozilla moznocompose moznoirc mp3 mudflap ncurses network nls noauthcram nodrm nsplugin ogg opengl openmp oscar pam pcre pdflib png pppd qt3 quicktime readline reflection sdl seamonkey session spl sse ssl svg symlink truetype truetype-fonts type1-fonts udev userlocales vorbis x86 xorg xprint xv xvid zlib" ALSA_CARDS="cmipci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" CAMERAS="ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="r128"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 Andrew Sterling Hanenkamp 2007-07-18 19:48:18 UTC
I'm encountering the same problem. I'm adding 

=docbook-sgml-utils-0.6.14 

to my local mask file to avoid this problem (and masking gnome-base/gnome-applets-2.16.2-r1 as well since it depends on this).
Comment 2 Davide Italiano (RETIRED) gentoo-dev 2007-08-12 23:31:00 UTC
docbook-sgml-dtd and docbook-xml-dtd are SLOT'ted packages.
Seeing the ebuild, in docbook-sgml-utils dependencies section, for example, there isn't one for ~app-text/docbook-sgml-dtd-4.3 .

Maybe the users installed docbook-sgml-dtd-4.3 some time in the past, but for some reason, it got removed, but the catalog system was left corrupt.

Is docbook-sgml-dtd-4.3 installed on your system now ? If not,then has it been installed in the system in the past (symptoms indicate this is the case) and then removed accidentally? 

I suggest to emerge that package again and see if the problem remains or not.
Comment 3 cburroughs 2007-08-15 15:03:21 UTC
David,
I am also unable to build docbook-sgml-utils.  Installing docbook-sgml-dtd-4.3 has no effect.

--------
    mkdir -p -- . /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html
 /usr/bin/install -c -m 644 ./api.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/api.html
/usr/bin/install: cannot stat `./api.html': No such file or directory
 /usr/bin/install -c -m 644 ./backend-spec.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/backend-spec.html
/usr/bin/install: cannot stat `./backend-spec.html': No such file or directory
 /usr/bin/install -c -m 644 ./docbook2man.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/docbook2man.html
/usr/bin/install: cannot stat `./docbook2man.html': No such file or directory
 /usr/bin/install -c -m 644 ./docbook2texi.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/docbook2texi.html
/usr/bin/install: cannot stat `./docbook2texi.html': No such file or directory
 /usr/bin/install -c -m 644 ./fdl.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/fdl.html
/usr/bin/install: cannot stat `./fdl.html': No such file or directory
 /usr/bin/install -c -m 644 ./frontend-spec.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/frontend-spec.html
/usr/bin/install: cannot stat `./frontend-spec.html': No such file or directory
 /usr/bin/install -c -m 644 ./helpers.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/helpers.html
/usr/bin/install: cannot stat `./helpers.html': No such file or directory
 /usr/bin/install -c -m 644 ./index.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/index.html
/usr/bin/install: cannot stat `./index.html': No such file or directory
 /usr/bin/install -c -m 644 ./introduction.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/introduction.html
/usr/bin/install: cannot stat `./introduction.html': No such file or directory
 /usr/bin/install -c -m 644 ./intro-jw.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/intro-jw.html
/usr/bin/install: cannot stat `./intro-jw.html': No such file or directory
 /usr/bin/install -c -m 644 ./intro-sgmldiff.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/intro-sgmldiff.html
/usr/bin/install: cannot stat `./intro-sgmldiff.html': No such file or directory
 /usr/bin/install -c -m 644 ./jw.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/jw.html
/usr/bin/install: cannot stat `./jw.html': No such file or directory
 /usr/bin/install -c -m 644 ./sgmldiff.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/sgmldiff.html
/usr/bin/install: cannot stat `./sgmldiff.html': No such file or directory
make[3]: *** [install-htmlDATA] Error 1
make[3]: Leaving directory `/var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/work/docbook-utils-0.6.14/doc/HTML'
make[2]: *** [install-am] Error 2
make[2]: Leaving directory `/var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/work/docbook-utils-0.6.14/doc/HTML'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/work/docbook-utils-0.6.14/doc'
make: *** [install-recursive] Error 1

!!! ERROR: app-text/docbook-sgml-utils-0.6.14 failed.
Call stack:
  ebuild.sh, line 1632:   Called dyn_install
  ebuild.sh, line 1077:   Called qa_call 'src_install'
  ebuild.sh, line 44:   Called src_install
  docbook-sgml-utils-0.6.14.ebuild, line 52:   Called die

!!! Installation failed
Comment 4 Leonardo Boshell (RETIRED) gentoo-dev 2007-08-20 07:30:15 UTC
(In reply to comment #3)
> David,
> I am also unable to build docbook-sgml-utils.  Installing docbook-sgml-dtd-4.3
> has no effect.

Chris,
The effect that you can't emerge docbook-sgml-utils doesn't necessarily means that it's the same bug that is being reported here (which looks like a local problem, as described in Davide's message).

If you want us to track your problem, please open a new report, and attach the full emerge log.

Thanks.
Comment 5 Nick Cripps 2007-09-23 11:40:52 UTC
I am having the same problem. I installed a new system with 2007.0 about 2 weeks ago. I emerge --sync'd, emerge -uDN world, emerge gnome. I left it for 2 weeks and then emerged --sync, emerged -uDN world again yesterday. Set the USE flags I am using on my old system (up to this point I am using the default 2007.0 desktop profile) and did an emerge -uDN world. I encounter the same problem as mentioned here (same error message). I am posing my emerge --info below.

Portage 2.1.3.9 (default-linux/amd64/2007.0/desktop, gcc-4.1.2, glibc-2.5-r4, 2.6.22-gentoo-r5 x86_64)
=================================================================
System uname: 2.6.22-gentoo-r5 x86_64 AMD Sempron(tm) Processor 3000+
Timestamp of tree: Sat, 22 Sep 2007 13:20:01 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r5
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -mtune=k8 -O2 -fomit-frame-pointer -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=k8 -mtune=k8 -O2 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.utdlug.org/linux/distributions/gentoo/ http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp://mirrors.64hosting.com/pub/mirrors/gentoo/ http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LINGUAS="en_GB"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 arts automount avahi bash-completion berkdb binary-drivers bindist binfilter bitmap-fonts bluetooth bonobo branding bzip2 cairo calendar cddb cdinstall cdparanoia cdr cli colordiff console cracklib crypt css cups dbus dedicated dhcp divx djvu doc dri dts dvd dvdr dvdread dvi eds emboss enca encode escreen esd etwin evo examples fam fbcon fbsplash ffmpeg firefox foomaticdb fortran ftp fuse gd gdbm gif gimp gimpprint gmail gnome gnome-print gpm gs gstreamer gtk gtk2 gtkhtml gzip hal hpn iconv id3 ieee1394 imap imlib ipod ipv6 jabber java javascript jikes jpeg jpeg2k kde kerberos keyring lame largeterminal latex ldap lzo mad mcal midi mikmod mime mmx mmxext mng mouse mozbranding moznopango mozsvg mp3 mpeg mplayer msn mudflap multiuser music ncurses network nls nocd nptl nptlonly nsplugin ntfs odbc offensive ogg openal opengl openmp oss pam pcre pdf perl plotutils png pop pppd python qt3 qt3support qt4 quicktime rar rdesktop readline realmedia reflection reiser4 reiserfs replytolist rpm rss rtc samba sdl server session slp source spell spl sqlite sse sse2 ssl subtitles svg swat sysfs szip t1lib tagwriting tcpd tetex threads thunderbird tiff toolbar tools truetype truetype-fonts type1-fonts unicode usb vcd vim vim-pager vim-syntax vim-with-x vnc vorbis webdav winbind wma wmf wmp wxwindows xanim xcomposite xforms xhtml xinerama xml xorg xpm xprint xscreensaver xv xvid yahoo zeroconf zip zlib zsh-completion" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 6 Nick Cripps 2007-09-23 12:07:20 UTC
(In reply to comment #5)

Actually the error I get isn't the same (saw the same errors at the end and didn't notice it was different higher up). I am posting the build errors below. I can submit this as a new bug if need be but I think it is related. 


Making all in HTML
make[2]: Entering directory `/var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/work/docbook-utils-0.6.14/doc/HTML'
SGML_CATALOG_FILES=/etc/sgml/catalog \
        SGML_SEARCH_PATH=../..:../../doc:.. \
                jade -t sgml -i html -d ../../docbook-utils.dsl\#html \
                        -V '%use-id-as-filename%' ../../doc/docbook-utils.sgml
SGML_CATALOG_FILES=/etc/sgml/catalog \
        SGML_SEARCH_PATH=../..:../../doc:.. \
                jade -t sgml -i html -d ../../docbook-utils.dsl\#html \
                        -V '%use-id-as-filename%' ../../doc/docbook-utils.sgml
jade:/usr/share/sgml/docbook/xml-dtd-4.1.2/ent/iso-amsa.ent:8:19:E: "X21B6" is not a function name
jade:/usr/share/sgml/docbook/xml-dtd-4.1.2/ent/iso-amsa.ent:9:19:E: "X21B7" is not a function name
jade:/usr/share/sgml/docbook/xml-dtd-4.1.2/ent/iso-amsa.ent:10:17:E: "X21D3" is not a function name
jade:/usr/share/sgml/docbook/xml-dtd-4.1.2/ent/iso-amsa.ent:11:18:E: "X21CA" is not a function name
jade:/usr/share/sgml/docbook/xml-dtd-4.1.2/ent/iso-amsa.ent:12:18:E: "X21C3" is not a function name
jade:/usr/share/sgml/docbook/xml-dtd-4.1.2/ent/iso-amsa.ent:13:18:E: "X21C2" is not a function name
jade:/usr/share/sgml/docbook/xml-dtd-4.1.2/ent/iso-amsa.ent:14:18:E: "X21DA" is not a function name
jade:/usr/share/sgml/docbook/xml-dtd-4.1.2/ent/iso-amsa.ent:15:17:E: "X219E" is not a function name
jade:/usr/share/sgml/docbook/xml-dtd-4.1.2/ent/iso-amsa.ent:16:18:E: "X21C7" is not a function name
jade:/usr/share/sgml/docbook/xml-dtd-4.1.2/ent/iso-amsa.ent:17:19:E: "X21A9" is not a function name

...hundreds more lines of the same...

jade:/usr/share/sgml/docbook/xml-dtd-4.1.2/ent/iso-lat2.ent:124:19:E: "X017D" is not a function name
jade:/usr/share/sgml/docbook/xml-dtd-4.1.2/ent/iso-lat2.ent:125:17:E: "X017C" is not a function name
jade:/usr/share/sgml/docbook/xml-dtd-4.1.2/ent/iso-lat2.ent:126:17:E: "X017B" is not a function name
make[2]: *** [api.html] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: *** [backend-spec.html] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/work/docbook-utils-0.6.14/doc/HTML'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/work/docbook-utils-0.6.14/doc'
make: *** [all-recursive] Error 1
 * 
 * ERROR: app-text/docbook-sgml-utils-0.6.14 failed.
 * Call stack:
 *   ebuild.sh, line 1654:   Called dyn_compile
 *   ebuild.sh, line 990:   Called qa_call 'src_compile'
 *   ebuild.sh, line 44:   Called src_compile
 *   ebuild.sh, line 662:   Called die
 * 
 * emake failed
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/app-text:docbook-sgml-utils-0.6.14:20070923-052433.log'.
 * 

Comment 7 Raphael 2007-09-30 05:33:19 UTC
I also can't emerge docbook-sgml-utils-0.6.14 with a similar looking set of errors

[...]
Making all in HTML
make[2]: Entering directory `/var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/work/docbook-utils-0.6.14/doc/HTML'
SGML_CATALOG_FILES=/etc/sgml/catalog \
        SGML_SEARCH_PATH=../..:../../doc:.. \
                jade -t sgml -i html -d ../../docbook-utils.dsl\#html \
                        -V '%use-id-as-filename%' ../../doc/docbook-utils.sgml
jade:/etc/sgml/xml-simple-docbook-4.1.2.4.cat:1:8:E: cannot open "/usr/share/sgml/docbook/xml-simple-dtd-4.1.2.4/catalog" (No such file or directory)
jade:/etc/sgml/xml-simple-docbook-1.0.cat:1:8:E: cannot open "/usr/share/sgml/docbook/xml-simple-dtd-1.0/catalog" (No such file or directory)
[..]

I have remerged  docbook-sgml-dtd but that didn't help.  I attach emerge --info below.

Raphael

 emerge --info
Portage 2.1.3.9 (default-linux/amd64/2006.1/desktop, gcc-4.1.2, glibc-2.5-r4, 2.6.21-gentoo x86_64)
=================================================================
System uname: 2.6.21-gentoo x86_64 AMD Athlon(tm) 64 Processor 3000+
Timestamp of tree: Sat, 29 Sep 2007 07:30:01 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.3.6, 2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.10-r3
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php4/ext-active/ /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php4/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php4/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=k8 -O2"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/"
LANG="en_GB.UTF-8"
PKGDIR="/home/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/home/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/secondlife /usr/portage/local/layman/science /usr/portage/local/layman/drizzt-overlay /usr/portage/local/layman/sunrise /usr/local/portage /usr/local/sci"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac aalib alsa amd64 aotuv arts artworkextra berkdb bindinst bitmap-fonts bootsplash browserplugin cairo cli cracklib crypt cups dba dbus dri dts dv dvd dvdr dvdread eds emboss encode fam fame fbcon fbdev firefox font-server fortran gd gdbm gif ginac gpm gs gstreamer gtk gtk2 hal iconv icq imagemagick ipv6 irc isdnlog jabber java jingle jpeg kde ldap live mad midi mikmod mozilla mp3 mpeg msn mudflap ncurses nls nptl nptlonly offensive ogg oggvorbis opengl openmp oss pam pcntl pcre pdf perl png posix postscript ppds pppd python qhull qt3 qt4 quicktime readline realmedia reflection rss rtsp sdl session spell spl ssl stream subtitles svg tcpd tetex theora tk truetype truetype-fonts type1-fonts unicode vorbis wmp wxgtk1 wxwindows xml xorg xv xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fglrx vesa fbdev"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 8 Daniel Seix 2007-10-02 07:53:03 UTC
I had the same problem as Nick and Raphael. I solved it by issuing:

# emerge -v1 app-text/sgml-common app-text/opensp
# revdep-rebuild --library='libosp.so.*'

and then

# emerge -av1 docbook-sgml-utils

Comment 9 Jochen Radmacher 2007-10-20 21:14:20 UTC
for me this was not enough, I did:
# emerge -1 app-text/sgml-common app-text/opensp
# revdep-rebuild --library='libosp.so.*'
# emerge -C app-text/docbook-xml-simple-dtd
# emerge -C app-text/docbook-xml-dtd
# emerge -C app-text/docbook-sgml-dtd
# emerge app-text/docbook-sgml-utils

The removed packages get pulled again by docbook-sgml-utils

Comment 10 Duncan Webb 2007-10-21 12:56:57 UTC
I know the answer to this, or at least one of the docbook problems :)

There are two problems:

First one of the docbook packages has uppercase entity names ie ↶, IIRC docbook-xml-dtd-4.1.2, and they should be ↶ This has been fixed.

Second /etc/sgml/sgml-ent.cat got deleted and it should contain:
CATALOG "/usr/share/sgml/sgml-iso-entities-8879.1986/catalog"
This is fixed by re-emerging app-text/sgml-common

In this case a re-emerge of "=app-text/docbook-sgml-dtd-4.3-r2" should fix the problem. Simple enough to find out equery belongs sgml-dtd-4.3.

HTH
Comment 11 Evil Compile Person 2008-01-05 01:27:29 UTC
Does that mean there is no way to guarantee it'll compile from a clean stage3 ?
:(
Comment 12 Fabiano 2008-01-11 14:38:06 UTC
Same error as Nick and Raphael.

Solved doing:

# emerge app-text/sgml-common app-text/opensp
# emerge docbook-sgml-utils

But, how this happened? I have a stable system, just tried to update world.
Comment 13 Petteri Räty (RETIRED) gentoo-dev 2008-02-17 17:16:07 UTC
*** Bug 210493 has been marked as a duplicate of this bug. ***
Comment 14 kavol 2008-06-26 13:31:35 UTC
(In reply to comment #12)
> Same error as Nick and Raphael.
> 
> Solved doing:
> 
> # emerge app-text/sgml-common app-text/opensp
> # emerge docbook-sgml-utils

I have no luck re-emerging anything, docbook-sgml-utils still fails :-(
Comment 15 Jason Cornez 2008-09-05 09:14:43 UTC
I only recently started having this problem (ie yesterday), but it is persistent.  I've tried the solutions suggested in comments #8, #9, #10, and #12, but nothing works.

% emerge -pv docbook-sgml-utils
[ebuild   R   ] app-text/docbook-sgml-utils-0.6.14  USE="-jadetex% (-tetex%)" 0 kB

And the error part of the actual emerge looks like...

    mkdir -p -- . /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html
 /usr/bin/install -c -m 644 ./api.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/api.html
/usr/bin/install: cannot stat `./api.html': No such file or directory
 /usr/bin/install -c -m 644 ./backend-spec.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/backend-spec.html
/usr/bin/install: cannot stat `./backend-spec.html': No such file or directory
 /usr/bin/install -c -m 644 ./docbook2man.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/docbook2man.html
/usr/bin/install: cannot stat `./docbook2man.html': No such file or directory
 /usr/bin/install -c -m 644 ./docbook2texi.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/docbook2texi.html
/usr/bin/install: cannot stat `./docbook2texi.html': No such file or directory
 /usr/bin/install -c -m 644 ./fdl.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/fdl.html
/usr/bin/install: cannot stat `./fdl.html': No such file or directory
 /usr/bin/install -c -m 644 ./frontend-spec.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/frontend-spec.html
/usr/bin/install: cannot stat `./frontend-spec.html': No such file or directory
 /usr/bin/install -c -m 644 ./helpers.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/helpers.html
/usr/bin/install: cannot stat `./helpers.html': No such file or directory
 /usr/bin/install -c -m 644 ./index.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/index.html
/usr/bin/install: cannot stat `./index.html': No such file or directory
 /usr/bin/install -c -m 644 ./introduction.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/introduction.html
/usr/bin/install: cannot stat `./introduction.html': No such file or directory
 /usr/bin/install -c -m 644 ./intro-jw.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/intro-jw.html
/usr/bin/install: cannot stat `./intro-jw.html': No such file or directory
 /usr/bin/install -c -m 644 ./intro-sgmldiff.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/intro-sgmldiff.html
/usr/bin/install: cannot stat `./intro-sgmldiff.html': No such file or directory
 /usr/bin/install -c -m 644 ./jw.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/jw.html
/usr/bin/install: cannot stat `./jw.html': No such file or directory
 /usr/bin/install -c -m 644 ./sgmldiff.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/sgmldiff.html
/usr/bin/install: cannot stat `./sgmldiff.html': No such file or directory
make[3]: *** [install-htmlDATA] Error 1
make[3]: Leaving directory `/var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/work/docbook-utils-0.6.14/doc/HTML'
make[2]: *** [install-am] Error 2
make[2]: Leaving directory `/var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/work/docbook-utils-0.6.14/doc/HTML'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/work/docbook-utils-0.6.14/doc'
make: *** [install-recursive] Error 1
Comment 16 Guenther Brunthaler 2008-09-05 12:17:12 UTC
(In reply to comment #15)
> I only recently started having this problem (ie yesterday), but it is
> persistent.  I've tried the solutions suggested in comments #8, #9, #10, and
> #12, but nothing works.

Yeah, everytime an ebuild fails and I spot the string "sgml" somewhere in the error message, my blood pressure starts to rise.

The SGML-stuff is a constant source of troubles in Gentoo.

However, the last time I encountered this problem, the following approach worked for me:

# emerge -pe docbook-sgml-utils \
  | grep -i 'sgml\|xml\|docbook|\template' > depends

Then edit the file and remove any trash left over from "emerge -pe" other than complete package names including the version number part.

Now add "="-characters before the package names, because the output of "emerge -pe" does not do it automatically, but "emerge" requires it when specifying full package names as arguments:

# sed -e 's,^,=,' < depends > depends2 && rm depends

Then re-emerge the resulting package list in order:

# emerge -avO1 $(< depends2) && rm depends2

(The options in the latter command are upper case "O" like in "oscar" and "1" like "one".) This will re-emerge everything the failing package depends on and looks like it has something to do with xml, sgml etc.

This approach might be rather primitive, but actually it worked quite well for me.
Comment 17 Jason Cornez 2008-09-05 14:11:17 UTC
Thanks.  I tried what you suggested and ended up with the following list

=dev-perl/XML-Parser-2.36
=dev-perl/SGMLSpm-1.03-r5
=dev-libs/libxml2-2.6.32
=app-text/sgml-common-0.6.3-r5
=app-text/docbook-sgml-dtd-4.1-r3
=app-text/docbook-sgml-dtd-4.0-r3
=app-text/docbook-sgml-dtd-3.0-r3
=app-text/docbook-sgml-dtd-3.1-r3
=app-text/docbook-xml-simple-dtd-4.1.2.4-r2
=app-text/docbook-xml-simple-dtd-1.0-r1
=app-text/docbook-xml-dtd-4.4-r1
=app-text/docbook-sgml-utils-0.6.14

Everything succeeded until the last which fail in exactly the same way I report above.
Comment 18 Guenther Brunthaler 2008-09-05 15:34:21 UTC
(In reply to comment #17)
> Everything succeeded until the last which fail in exactly the same way I report
> above.

Hmmm. There is one last thing you could try: Manually erase the template catalog files:

# rm -r /etc/sgml

Then re-emerge the above ebuilds again. Also look into the /var/lib/portage/world file, if you spot some other ebuilds there with "sgml" or "docbook" as part of their names, and manually re-emerge them also with

# emerge -a1 $(grep 'sgml\|docbook\|template' /var/lib/portage/world) ...

Background: The files in /etc/sgml are not directly part of any package, but are rather databases which are updated when packages containing SGML catalog files are emerged.

That is, those packages always add something to the catalog files, and should also remove it when they are unmerged.

However, this does not always work. Somtimes, a package forgets to remove all of its entries from a file in /etc/sgml, or is unable to do so for whatever reason.

This can lead to bogus entries in the /etc/sgml files, which typically makes other ebuilds fail with error messages complaining that some required DTDs could not be retrieved.

When the /etc/sgml files are manually removed, all the catalogs are gone, and thus there cannot be any bogus entries left.

The downside is you have to re-emerge any already-installed packages containing SGML catalog files, thus populating the /etc/sgml catalog files again. (But this time with no bogus entries.)

I hope this helps - if not, I'm I afraid I am also out of clues.
Comment 19 Guenther Brunthaler 2008-09-05 15:46:16 UTC
I have a suggestion how the error-prone handling of SGML catalog files in Gentoo might be made more stable:

Instead of letting the pre-remove or post-install functions of ebuild scripts add or remove entries from the catalog files in /etc/sgml, why not handle it the same way the files in /etc/env.d?

That is, let's create some additional directory, such as /etc/sgml.d, where each ebuild adds static files with the entries to be added to the various catalog files.

Those static files will then also be part of the package's file list as displayed by

# equery files <packagename>

(Currently, the catalog files do not "belong" to any package at all.)

Finally, an update script a la env-update should be added - let's call it sgml-update or something, which collects all the snippets in /etc/sgml.d and recreates all the *.cat files in /etc/sgml/ from the snippet contents each time this utitity is run.

This would make all the troubles go away which we have with /etc/sgml/*.cat right now.
Comment 20 Jason Cornez 2008-09-05 16:05:36 UTC
Thanks for the follow-up suggestion.  Removing /etc/sgml and rebuilding did not help.
Comment 21 Guenther Brunthaler 2008-09-05 16:17:08 UTC
(In reply to comment #20)
> Thanks for the follow-up suggestion.  Removing /etc/sgml and rebuilding did not
> help.

Sorry to hear that.

BTW, on my box (which is up-to-date with regard to the 2008.0/desktop profile), only the following subdirectories exist in /usr/share/sgml/docbook/:

sgml-dtd-3.0/ sgml-dtd-3.1/ sgml-dtd-4.0/ sgml-dtd-4.1/ sgml-dtd-4.2/ sgml-dtd-4.4/

To me it seems that sgml-dtd-4.3 might be outdated. So better check whether this directory should exist at all, or is just an leftover from some outdated package:

# equery belongs /usr/share/sgml/docbook/sgml-dtd-4.3

If this does *not* report some package, then this path is a leftover from an incomplete deinstallation and should be removed via "rm -rf".

But even *if* this files belongs to an installed package (which should then be reported as "app-text/docbook-sgml-dtd-4.3"), you should check if the package itself is also required:

# equery depends =app-text/docbook-sgml-dtd-4.3

If no packages are listed which require this package, just uninstall it with

# emerge -Ca =app-text/docbook-sgml-dtd-4.3
Comment 22 Guenther Brunthaler 2008-09-05 16:20:37 UTC
(In reply to comment #20)

Another thing: I noted some of the error messages reported to you were issued by jade. Therefore, re-emerging jade via

# emerge -a1 app-text/openjade

might also help.
Comment 23 Jason Cornez 2008-09-05 16:43:13 UTC
Thanks. I made sure /usr/share/sgml/docbook/sgml-dtd-4.3 and =app-text/docbook-sgml-dtd-4.3 were gone.  I re-emerged openjade.  I get the same problem.

I really do appreciate the effort, however I wonder if anyone has looked at the specific error messages I posted.  For example:

 /usr/bin/install -c -m 644 ./api.html /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/api.html
/usr/bin/install: cannot stat `./api.html': No such file or directory

And indeed this is true:
# cd /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/
dev266-l html # ls -al
total 0
drwxr-xr-x 2 root root 48 Sep  5 18:37 .
drwxr-xr-x 3 root root 72 Sep  5 18:37 ..


Comment 24 Guenther Brunthaler 2008-09-05 17:07:42 UTC
(In reply to comment #23)

> And indeed this is true:
> # cd
> /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/image//usr/share/doc/docbook-sgml-utils-0.6.14/html/

The problem is that /var/tmp/portage is a temporary build directory only. It exists only during the emerge, and will be automatically erased afterwards. So others cannot easily verify what's there.

However I do not get that build error, so I suppose the problem in your case is that the .html file it is complaining about was an automatically generated file, but the generation of the file failed for some reason.

The only other advice I can give you is breaking down the emerge process step-by-step:

# emerge -ua sandboxshell
# ebuild $(equery which docbook-sgml-utils) clean compile
# cd /var/tmp/portage/app-text/docbook-sgml-utils-0.6.14/work/docbook-utils-0.6.14/
# sandboxshell
# . ../../temp/environment
# make

This should put you into the same environment (env variable setups etc) as when the package is actually built, and you can also examine each file's contents, and therefore try to locate missing or misconfigured ones.

BTW, when I did the above, no error messages have been displayed at all.
Comment 25 Guenther Brunthaler 2008-09-05 17:15:35 UTC
Created attachment 164647 [details]
checksums for xml-dtd-4.1.2

(In reply to comment #6)

Your error report contains messages such as

> jade:/usr/share/sgml/docbook/xml-dtd-4.1.2/ent/iso-amsa.ent:10:17:E: "X21D3" is

I therefore would like to make sure your /usr/share/sgml/docbook/xml-dtd-4.1.2 are the same as mine see the MD5 checksums in the attachment.

In order to verify the checksums, do a

# md5sum -c /path/to/md5-4.1.2
Comment 26 Jason Cornez 2008-09-08 09:31:30 UTC
Thanks again for the suggestions in #24.  I have done exactly this and it seems to compile with no errors.  However the emerge of docbook-sgml-utils still runs into the same problem I've already reported.  Now that I've followed the suggestions in #24, is there something I should look for?
Comment 27 Jason Cornez 2008-09-08 09:35:43 UTC
Created attachment 164889 [details]
The build.log of my persistent failure

I've attached the full build.log of the failure I am seeing in case it is useful to anyone.  As can be seen in the comments above, I've more or less tried rebuilding just about everything anyone can think of, but I still see this.  I'm not depending on this for anything, it is just annoying to have it broken.
Comment 28 Guenther Brunthaler 2008-09-08 16:41:52 UTC
(In reply to comment #27)
> Created an attachment (id=164889) [edit]
> The build.log of my persistent failure

Phew! An unbelievable long error message dump... ;-)

It seems to include the usage description of several utility commands, but the actual reason of the problem is still not clear to me.

It seems to boil down to "cannot create system identifier" - but why not?

Do you have enough free space left in /etc, /tmp and /var/tmp?

When did you run a fsck on the partitions the last time? (Perhaps the filesystem has become inconsistent somehow and some file creation operations failed because of that.)

Are some of your partitions mounted read-only where the installation scripts might want to create its "system identifier" files?

Are some of your installation target directories actually network shares? I have encountered several issues with network shares in the past, they simply do not work for all ebuilds as target directories.

It you can rule out all of the above - then alas, I've got no more ideas! ;-)
Comment 29 Jason Cornez 2008-09-08 16:54:35 UTC
I'm fairly sure the system is in good shape, has done fsck recently, and I don't do any emerges using remote drives...  For completeness:

jcornez@dev266-l ~ $ df -l
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda2             56820164  46083800  10736364  82% /
udev                     10240        92     10148   1% /dev
/dev/hda1             58364112  37120352  21243760  64% /mnt/windows
/dev/hdb1            117214656  18289980  98924676  16% /mnt/hdb1
none                   1037512         0   1037512   0% /dev/shm
jcornez@dev266-l ~ $ mount
/dev/hda2 on / type reiserfs (rw,noatime)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec)
udev on /dev type tmpfs (rw,nosuid,size=10240k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,gid=5,mode=620)
/dev/hda1 on /mnt/windows type fuseblk (rw,allow_other,default_permissions,blksize=4096)
/dev/hdb1 on /mnt/hdb1 type reiserfs (rw,noatime)
none on /dev/shm type tmpfs (rw)
none on /proc/bus/usb type usbfs (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)


Again, thanks for looking at this.
Comment 30 Jason Cornez 2008-09-09 14:38:59 UTC
I have finally been able to resolve my problem.  I needed to re-emerge

  app-text/docbook-dsssl-stylesheets

After doing this, the docbook-sgml-utils emerge worked perfectly.  Seems my catalog was missing the Norman Walsh and other DTDs.  Although I know very little about SGML, DocBook and catalogs, the following message was enough to give me a clue...

http://www.cygwin.com/ml/docbook-tools-discuss/2000/msg00451.html
Comment 31 Guenther Brunthaler 2008-09-09 15:06:51 UTC
(In reply to comment #30)
> I have finally been able to resolve my problem.  I needed to re-emerge
> 
>   app-text/docbook-dsssl-stylesheets

Congratulations!

Actually, I was expecting that my advice in Comment # 16 would re-emerge that package also... but it didn't. Which is strange, because the substring "docbook" is clearly present in that package's name.

Can we conclude from this that app-text/docbook-dsssl-stylesheets is actually a build-time dependency of app-text/docbook-sgml-utils, but this fact is not known to Portage?

If this should indeed be the case, I would strongly encourage the package maintainers to fix the ebuild dependency information of the affected packages!
Comment 32 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-09-30 16:54:39 UTC
this seems fixed since the proposed depedency is there
Comment 33 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-09-30 16:59:32 UTC
*** Bug 215849 has been marked as a duplicate of this bug. ***