Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 184537 - firehol requires less; less not installed in default gnap image
Summary: firehol requires less; less not installed in default gnap image
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Hosted Projects
Classification: Unclassified
Component: GNAP (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Network Appliance Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-07 20:02 UTC by Austin McKinley
Modified: 2012-07-20 19:11 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Austin McKinley 2007-07-07 20:02:28 UTC
my GNAP device displays the following while booting:

ERROR:  Command 'less' not found in the system path.
        FireHOL requires this command for its operation.
        Please install the required package and retry. 

and fails to start the firewall. seems like this should be included in gnap-core?

Reproducible: Always

Steps to Reproduce:
1. load a gnap-2.0 image with firehol configured
Comment 1 José Alberto Suárez López (RETIRED) gentoo-dev 2007-08-29 07:30:18 UTC
nets gnap version will include less in core, so not firehol. Any fw system will be installed using extensions or packages.
Comment 2 Costa Tsaousis 2007-10-27 23:38:13 UTC
FireHOL v1.266 (currently in the CVS) uses less, more or cat in that order for a pager, without any warnings if less or more are missing.
Comment 3 Kerin Millar 2008-10-13 01:08:07 UTC
Note that firehol-1.273 is now "InCVS" and will be stabilised after portage-2.2 is.