Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 184270 - gnome-base/gnome-vfs-2.16.3-r1 shoud be dependent from automake-1.9.6
Summary: gnome-base/gnome-vfs-2.16.3-r1 shoud be dependent from automake-1.9.6
Status: VERIFIED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 185732 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-07-05 09:27 UTC by stefan
Modified: 2010-04-08 16:01 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stefan 2007-07-05 09:27:05 UTC
The gnome-base/gnome-vfs-2.16.3-r1 refuses to be compiled if automake 1.9.6 isn't installed:
 * Failed Running automake !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/gnome-base/gnome-vfs-2.16.3-r1/temp/automake-24490.out


!!! ERROR: gnome-base/gnome-vfs-2.16.3-r1 failed.
Call stack:
  ebuild.sh, line 1615:   Called dyn_unpack
  ebuild.sh, line 752:   Called qa_call 'src_unpack'
  ebuild.sh, line 44:   Called src_unpack
  gnome-vfs-2.16.3-r1.ebuild, line 97:   Called eautoreconf
  autotools.eclass, line 97:   Called eautomake
  autotools.eclass, line 194:   Called autotools_run_tool 'automake' 
'--add-missing' '--copy'
  autotools.eclass, line 218:   Called die

!!! Failed Running automake !
!!! If you need support, post the topmost build error, and the call stack if 
relevant.
!!! A complete build log is located at 
'/var/tmp/portage/gnome-base/gnome-vfs-2.16.3-r1/temp/build.log'.

build.log says:
***** automake *****

configure.in:37: version mismatch.  This is Automake 1.9.5,
configure.in:37: but the definition used by this AM_INIT_AUTOMAKE
configure.in:37: comes from Automake 1.9.6.  You should recreate
configure.in:37: aclocal.m4 with aclocal and run automake again.

After I emerge automake-1.9.6-r2 gnome-vfs compiles successfully.

Reproducible: Always

Steps to Reproduce:
1.emerge -v =gnome-base/gnome-vfs-2.16.3-r1
2.
3.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-07-05 09:29:57 UTC
It already does depend on it (WANT_AUTOMAKE=1.9). Upgrade your system properly, using --deep.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-07-18 07:31:06 UTC
*** Bug 185732 has been marked as a duplicate of this bug. ***
Comment 3 Zeno Davatz 2010-04-08 15:27:43 UTC
I am getting the exact same error when trying to install   

 gnome-vfs-2.24.3

 * Running automake --add-missing --copy ...                                                                             [ !! ]

 * Failed Running automake !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/gnome-base/gnome-vfs-2.24.3/temp/automake.out

 * ERROR: gnome-base/gnome-vfs-2.24.3 failed:
 *   Failed Running automake !
 * 
 * Call stack:

 emerge --deep gnome-vfs 

does not help neither doe

 emerge -uD world.

Any hints are welcome!

/var/tmp/portage/gnome-base/gnome-vfs-2.24.3/temp/build.log is

^[[A^[[119C  ^[[34;01m[ ^[[32;01mok^[[34;01m ]^[[0m
 ^[[32;01m*^[[0m Running libtoolize --copy --force --install --automake ...
^[[A^[[119C  ^[[34;01m[ ^[[32;01mok^[[34;01m ]^[[0m
 ^[[32;01m*^[[0m Running aclocal ...
^[[A^[[119C  ^[[34;01m[ ^[[32;01mok^[[34;01m ]^[[0m
 ^[[32;01m*^[[0m Running autoconf ...
^[[A^[[119C  ^[[34;01m[ ^[[32;01mok^[[34;01m ]^[[0m
 ^[[32;01m*^[[0m Running autoheader ...
^[[A^[[119C  ^[[34;01m[ ^[[32;01mok^[[34;01m ]^[[0m
 ^[[32;01m*^[[0m Running automake --add-missing --copy ...
^[[A^[[119C  ^[[34;01m[ ^[[31;01m!!^[[34;01m ]^[[0m

 ^[[31;01m*^[[0m Failed Running automake !
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m Include in your bugreport the contents of:
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m   /var/tmp/portage/gnome-base/gnome-vfs-2.24.3/temp/automake.out

 ^[[31;01m*^[[0m ERROR: gnome-base/gnome-vfs-2.24.3 failed:
 ^[[31;01m*^[[0m   Failed Running automake !
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m Call stack:
 ^[[31;01m*^[[0m     ebuild.sh, line   48:  Called src_unpack
 ^[[31;01m*^[[0m   environment, line 3139:  Called eautoreconf
 ^[[31;01m*^[[0m   environment, line  963:  Called eautomake
 ^[[31;01m*^[[0m   environment, line  932:  Called autotools_run_tool 'automake' '--add-missing' '--copy'
 ^[[31;01m*^[[0m   environment, line  436:  Called die
 ^[[31;01m*^[[0m The specific snippet of code:
 ^[[31;01m*^[[0m           die "Failed Running $1 !";
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m If you need support, post the output of 'emerge --info =gnome-base/gnome-vfs-2.24.3',
 ^[[31;01m*^[[0m the complete build log and the output of 'emerge -pqv =gnome-base/gnome-vfs-2.24.3'.
 ^[[31;01m*^[[0m The complete build log is located at '/var/tmp/portage/gnome-base/gnome-vfs-2.24.3/temp/build.log'.
 ^[[31;01m*^[[0m The ebuild environment file is located at '/var/tmp/portage/gnome-base/gnome-vfs-2.24.3/temp/environment'.
 ^[[31;01m*^[[0m S: '/var/tmp/portage/gnome-base/gnome-vfs-2.24.3/work/gnome-vfs-2.24.3'
Comment 4 Zeno Davatz 2010-04-08 16:01:28 UTC
 emerge -uD gnome-vfs 

solves the problem