Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 183504 - app-cdr/k3b-1.0.2 hangs system on media detection
Summary: app-cdr/k3b-1.0.2 hangs system on media detection
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High critical (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-28 10:30 UTC by Maxim Britov
Modified: 2007-07-04 10:38 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
.config (.config,37.59 KB, text/plain)
2007-06-28 10:30 UTC, Maxim Britov
Details
emerge --info (emerge-info.txt,3.53 KB, text/plain)
2007-06-28 10:32 UTC, Maxim Britov
Details
dmesg (dmesg,14.56 KB, text/plain)
2007-06-28 10:33 UTC, Maxim Britov
Details
k3b output (k3b-output,7.36 KB, text/plain)
2007-07-01 15:47 UTC, Jorge Manuel B. S. Vicetto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Britov 2007-06-28 10:30:07 UTC
k3b hang my system on startup
see also http://bugs.kde.org/show_bug.cgi?id=146131

Reproducible: Always
Comment 1 Maxim Britov 2007-06-28 10:30:59 UTC
Created attachment 123293 [details]
.config

My .config
Comment 2 Maxim Britov 2007-06-28 10:32:11 UTC
Created attachment 123295 [details]
emerge --info
Comment 3 Maxim Britov 2007-06-28 10:33:32 UTC
Created attachment 123297 [details]
dmesg
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-06-28 10:34:27 UTC
emerge -pv k3b output, please.
Comment 5 Maxim Britov 2007-06-28 10:50:11 UTC
[ebuild   R   ] app-cdr/k3b-1.0.2  USE="alsa css dvdr dvdread encode ffmpeg flac hal mp3 musepack musicbrainz vcd vorbis -arts -debug -emovix -kde -sndfile -xinerama" LINGUAS="ru -af -ar -bg -br -bs -ca -cs -cy -da -de -el -en_GB -es -et -eu -fa -fi -fr -ga -gl -he -hi -hu -is -it -ja -ka -lt -mk -ms -nb -nds -nl -nn -pa -pl -pt -pt_BR -rw -se -sk -sr -sr@Latn -sv -ta -tr -uk -uz -zh_CN -zh_TW" 0 kB

and just fyi:
$ ls -l /dev/sr0 /dev/sg0
crw-rw---- 1 root root  21, 0 Jun 28 12:51 /dev/sg0
brw-rw---- 1 root cdrom 11, 0 Jun 28 12:52 /dev/sr0
Comment 6 Constantine Kardaris 2007-06-28 16:21:17 UTC
just upgraded to 1.0.2
can confirm it in amd64 and vanilla kernel 2.6.21.5

emerge --info
Portage 2.1.2.7 (default-linux/amd64/2007.0/desktop, gcc-4.1.2, glibc-2.5-r3, 2.6.21.5 x86_64)
=================================================================
System uname: 2.6.21.5 x86_64 AMD Athlon(tm) 64 Processor 2800+
Gentoo Base System release 1.12.9
Timestamp of tree: Thu, 28 Jun 2007 12:29:01 +0000
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=k8 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://files.gentoo.gr"
LANG="el_GR.utf8"
LINGUAS="en el"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/local/layman/science /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 avi bitmap-fonts blas cairo cdinstall cdr chm cli cpudetection cracklib crypt cscope cups dbus dvd dvdr dvdread effects emboss epydoc fat ffmpeg fftw firefox fortran freetype gd gif gimp glitz gnome graphviz gtk gtk2 hal hdf5 iconv isdnlog jpeg kde kdeenablefinal kipi lapack lcms ldb libg++ lm_sensors mad midi mime mmx mmxext motif mozdevelop moznocompose moznoirc moznomail moznopango mp3 mpeg mudflap ncurses nls nntp nosendmail nptl nptlonly ntfs nvidia objc objc++ ogg oggvorbis opengl openmp pam pcre pdf plotutils png ppds pppd qt qt3 qt3support qt4 quicktime readline reflection replytolist restrict-javascript sbcl session spell spl srt sse sse2 ssl stroke subversion svg syslog tcltk tcpd teamarena tetex theora tidy tiff tk truetype truetype-fonts type1-fonts unicode usb userlocales v4l vcd vim-with-x vorbis wma x264 xforms xine xml xorg xscreensaver xv xvid zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en el" USERLAND="GNU" VIDEO_CARDS="nvidia nv"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

------

[ebuild   R   ] app-cdr/k3b-1.0.2  USE="alsa dvdr dvdread ffmpeg hal kde mp3 vcd vorbis -arts -css -debug -emovix -encode -flac -musepack -musicbrainz -sndfile -xinerama" LINGUAS="el -af -ar -bg -br -bs -ca -cs -cy -da -de -en_GB -es -et -eu -fa -fi -fr -ga -gl -he -hi -hu -is -it -ja -ka -lt -mk -ms -nb -nds -nl -nn -pa -pl -pt -pt_BR -ru -rw -se -sk -sr -sr@Latn -sv -ta -tr -uk -uz -zh_CN -zh_TW" 0 kB 
Comment 7 Maxim Britov 2007-06-29 12:05:30 UTC
/me back to k3b-1.0.1-r1
this one works for me
Comment 8 Maxim Britov 2007-06-29 12:29:27 UTC
On kernel panic I had in console:
" (Kbdevice:Device) /dev/sr0 checking for RAW_R96R

  HARDWARE ERROR
  CPU0: Machine Check Exception: 4 Bank: 4 b2000000000000070f0f TSC 74c4963c42
 
  Kernel panic - not syncing: Machine Check"

mcelog said:
# echo "CPU0: Machine Check Exception: 4 Bank: 4 b2000000000000070f0f TSC 74c4963c42" | mcelog --ascii --dmi --k8
HARDWARE ERROR. This is *NOT* a software problem!
Please contact your hardware vendor
CPU 0 0 data cache STATUS 0 MCGSTATUS 4
Comment 9 Farid 2007-06-30 09:28:44 UTC
I have the exact same thing with app-cdr/k3b-1.0.2, AMD64, 2.6.21-gentoo-r2.
Comment 10 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-07-01 15:46:45 UTC
k3b-1.0.2 doesn't hang my amd64 system.

$ qlist -IUv k3b
app-cdr/k3b-1.0.2 (alsa css dvdr dvdread emovix encode ffmpeg flac hal kde mp3 musicbrainz)

$ emerge --info
atlantis@atl64 ~ $ emerge --info
Portage 2.1.3_rc5 (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.5-r3, 2.6.21-gentoo-r2 x86_64)
=================================================================
System uname: 2.6.21-gentoo-r2 x86_64 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System release 1.12.10
Timestamp of tree: Tue, 26 Jun 2007 17:50:01 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=athlon64 -momit-leaf-frame-pointer -ftracer -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=athlon64 -momit-leaf-frame-pointer -ftracer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans"
GENTOO_MIRRORS="http://trumpetti.tut.atm.fi/gentoo http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp://mirrors1.netvisao.pt/gentoo/"
LC_ALL="pt_PT.utf8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/xeffects /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X acpi alsa amd64 avi berkdb bitmap-fonts cdr cli cracklib crypt cups dbus dri dvd encode fortran gdbm gpm hal iconv ipv6 isdnlog jpeg kde libg++ midi mmx mpeg mudflap ncurses nls nptl nptlonly opengl openmp pam pcre perl png pppd python qt3 readline reflection samba session spl sse sse2 ssl tcpd truetype truetype-fonts type1-fonts unicode xorg zlib" ALSA_CARDS="usb-audio intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 11 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-07-01 15:47:52 UTC
Created attachment 123540 [details]
k3b output
Comment 12 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-07-01 15:52:53 UTC
(In reply to comment #8)
> On kernel panic I had in console:
> " (Kbdevice:Device) /dev/sr0 checking for RAW_R96R
> 

user@host ~ $ ls -l /dev/s[gr]*
crw-rw---- 1 root root 21, 0 2007-06-30 00:23 /dev/sg0
crw-rw---- 1 root root 21, 1 2007-06-30 00:23 /dev/sg1
crw-rw---- 1 root root 21, 2 2007-06-30 00:23 /dev/sg2

I don't have the sr* dev nodes around here. Did you enable the SCSI cdrom support on the kernel - grep CONFIG_BLK_DEV_SR /usr/src/linux/.config? If you have and unless you do have a SCSI cdrom, try taking it out and running k3b again.
Comment 13 Jan Kundrát (RETIRED) gentoo-dev 2007-07-03 14:54:44 UTC
(In reply to comment #8)
> mcelog said:
> # echo "CPU0: Machine Check Exception: 4 Bank: 4 b2000000000000070f0f TSC
> 74c4963c42" | mcelog --ascii --dmi --k8
> HARDWARE ERROR. This is *NOT* a software problem!
> Please contact your hardware vendor
> CPU 0 0 data cache STATUS 0 MCGSTATUS 4

Well, you have a hardware problem. Information at http://en.wikipedia.org/wiki/Machine_Check_Exception might help you diagnose this issue.

There's nothing Gentoo can help with, sorry.
Comment 14 Maxim Britov 2007-07-04 10:38:26 UTC
It seems fixed in 2.6.22-rc7