Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 183451 - media-libs/alsa-lib-1.0.14a - no sound with ALSA_PCM_PLUGINS=""
Summary: media-libs/alsa-lib-1.0.14a - no sound with ALSA_PCM_PLUGINS=""
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo ALSA team
URL:
Whiteboard:
Keywords:
: 183664 184780 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-06-27 19:53 UTC by Grzegorz {NineX} Krzystek
Modified: 2007-07-24 14:46 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grzegorz {NineX} Krzystek 2007-06-27 19:53:38 UTC
after upgrade alsa (media-libs/alsa-lib-1.0.14a media-sound/alsa-headers-1.0.14 media-sound/alsa-utils-1.0.14) all aplicatios stopped emmiting sound
all my sound applications like audacious, ogg123 , mpg321 , mplayer ,artsd
stops work with alsa-*-1.0.14 end emits error:
# ninex@HaMeR ~/Moje Dokumenty/Muzyka/AURAL_PLANET-lightflow $ ogg123 ./01_intro.ogg
ALSA lib dlmisc.c:118:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_empty_open
ALSA lib pcm.c:2108:(snd_pcm_open_conf) symbol _snd_pcm_empty_open is not defined inside (null) 

recompilation of these packages dosn't help
i downgraded to alsa-headers-1.0.14_rc3, alsa-utils-1.0.14_rc2-r3, alsa-lib-1.0.14_rc3 and sound works...

i'm amd64 user, my kernel is 2.6.21-gentoo-r3 , my soundcard is via-hda




Portage 2.1.3_rc5 (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.5-r3, 2.6.21-gentoo-r3 x86_64)
=================================================================
System uname: 2.6.21-gentoo-r3 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System release 1.12.10
Timestamp of tree: Wed, 27 Jun 2007 19:00:01 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -pipe -O2 -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/init.d /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=athlon64 -pipe -O2 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans"
GENTOO_MIRRORS="http://gentoo.prz.rzeszow.pl           http://gentoo.po.opole.pl               http://distfiles.gentoo.org             http://www.ibiblio.org/pub/Linux/distributions/gentoo              http://dev.gentoo.org"
LINGUAS="pl en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 7zip X a52 aac acpi alsa amd64 arj arts audacious bash-completion bzip2 cdparanoia chardet cups dbus deprecated devil dga discouraged divx dri dts dv dvd dvdr dvdread encode exif fbcon ffmpeg gif gnutls gpm hal iconv idea ieee1394 ipv6 java jpeg jpeg2k kde kdeenablefinal lha lm_sensors logitech-mouse logrotate lzo mad midi mmx mmxext mng mp3 mpeg ncurses network-cron nls no-old-linux nptl nptlonly nsplugin ogg opengl pam pcre pdf perl plugins png ppds python qt3 rar slang spell sse sse2 ssl svg symlink test theora threads tiff truetype unicode voice vorbis wifi wma wmf wmp x264 xanim xorg xscreensaver xv xvid zip zlib" ALSA_CARDS="hda-intel" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LINGUAS="pl en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


Reproducible: Always
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-06-27 20:03:27 UTC
post the output of emerge -pv =media-libs/alsa-lib-1.0.14a
Comment 2 Grzegorz {NineX} Krzystek 2007-06-27 20:10:15 UTC
[ebuild   R   ] media-libs/alsa-lib-1.0.14a  USE="midi -alisp -debug -doc" ALSA_PCM_PLUGINS="-adpcm -alaw -asym -copy -dmix -dshare -dsnoop -empty -extplug -file -hooks -iec958 -ioplug -ladspa -lfloat -linear -meter -mulaw -multi -null -plug -rate -route -share -shm -softvol" 0 kB
Comment 3 Grzegorz {NineX} Krzystek 2007-06-27 20:11:16 UTC
wirld but it seems that dmix dosn't work when i set output device to hw:0,0 in audacious music are plaing correctly
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-06-27 20:15:15 UTC
(In reply to comment #3)
> wirld but it seems that dmix dosn't work when i set output device to hw:0,0 in
> audacious music are plaing correctly

Because your ALSA_PCM_PLUGINS is empty as you can see above (despite the fact that all the plugins are enabled by default in base profile). Are you using USE="-*" in your make.conf?
Comment 5 Grzegorz {NineX} Krzystek 2007-06-27 20:23:48 UTC
oops my fault
Comment 6 Bugs Bunny 2007-06-29 01:55:03 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > wirld but it seems that dmix dosn't work when i set output device to hw:0,0 in
> > audacious music are plaing correctly
> 
> Because your ALSA_PCM_PLUGINS is empty as you can see above (despite the fact
> that all the plugins are enabled by default in base profile). Are you using
> USE="-*" in your make.conf?
> 

This is invalid. ALSA_PCM_PLUGINS should not have any effect from a useflag as they are to be defined seperately in make.conf reopen this bug and leave it to the appropriate herd.
Comment 7 Daniel Drake (RETIRED) gentoo-dev 2007-06-29 03:05:52 UTC
They are expanded to use flags via the USE_EXPAND mechanism. If you disagree with the behaviour, file a portage bug (assuming there is not one there already). The alsa package has no control over this behaviour.
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2007-06-29 16:46:30 UTC
*** Bug 183664 has been marked as a duplicate of this bug. ***
Comment 9 Christian Schmidt 2007-07-01 15:06:07 UTC
Just one question... in earlier portage days the behavior seemed to have been "expand to everything if unset". When has that changed?
I noticed that among others with gphoto2 and the CAMERAS variable.
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2007-07-01 15:31:50 UTC
(In reply to comment #9)

This has nothing to do w/ behaviour change. You've explicitely *un*set all the default use-expanded flags by sticking -* to your USE. Don't do it if you don't know what you are doing.
Comment 11 Christian Schmidt 2007-07-01 15:44:42 UTC
Yeah, just using -* since... 3-4years (back when gentoo did not include the year in the release numbers). Back in those days we did not have USE_EXPAND ;)

Anyway, the change was in fact the introduction of the ALSA_PCM_PLUGINS useflags in 14a over 14_rc3, and the problem was me not looking with enough detail to the emerge -auvDNt world output. No problems ;) - now back to the e17 update.
Comment 12 Jakub Moc (RETIRED) gentoo-dev 2007-07-09 21:32:33 UTC
*** Bug 184780 has been marked as a duplicate of this bug. ***
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2007-07-23 19:35:38 UTC
*** Bug 186365 has been marked as a duplicate of this bug. ***
Comment 14 William L. Thomson Jr. (RETIRED) gentoo-dev 2007-07-23 20:33:01 UTC
Re-opening bug for resolution :)

Ok, it looks as if these plugins are no longer optional. IMHO they should not be optional anymore, flags removed etc.

asym dmix empty softvol

Before alsa-lib-1.0.14a this worked
ALSA_PCM_PLUGINS="iec958 ioplug plug"

Now I have to have set
ALSA_PCM_PLUGINS="asym dmix empty iec958 ioplug plug softvol"

Even though alsa-lib builds without those plugin flags set. Till we have a use case where it works less those flags. They should be dropped as flags, and plugins included all the time. Or by default at min, prefixing flags with a no.
Comment 15 Tony Vroon gentoo-dev 2007-07-24 14:45:14 UTC
Discussed on IRC, this is a separate matter which has no relation to setting ALSA_PCM_PLUGINS to "". Closing.