Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 18284 - glibc-2.3 floating point code nonfunctional when using -march=pentium4
Summary: glibc-2.3 floating point code nonfunctional when using -march=pentium4
Status: RESOLVED DUPLICATE of bug 14069
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Martin Schlemmer (RETIRED)
URL: http://forums.gentoo.org/viewtopic.ph...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-03-27 03:23 UTC by Zhen Lin
Modified: 2005-07-17 13:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zhen Lin 2003-03-27 03:23:14 UTC
Many people have reported this. I fixed the problem by reducing my CFLAGS
from="-march=pentium4 -O2 -fomit-frame-pointer -mfpmath=sse" to "-march=pentium3
-O2 -fomit-frame-pointer -mfpmath=sse"

A simple filter-flags should do the trick.

Reproducible: Always
Steps to Reproduce:
1. On a -march=pentium4 glibc-2.3.* box, run python -c 'int(10.1); int(10000.3);
int(1.2)'
Actual Results:  
Floating point number too big

Expected Results:  
exit 0;
Comment 1 Zhen Lin 2003-03-29 21:45:51 UTC
Additional information suggests it is in fact caused by '-march=pentium4', probably because of SSE2 instructions:

http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view%20audit-trail&database=gcc&pr=6104
Comment 2 Martin Schlemmer (RETIRED) gentoo-dev 2003-03-30 14:18:02 UTC
Known issue.  Please use pentium3 without any -mmmx2 or -msse2 or -mfpmath=*


*** This bug has been marked as a duplicate of 14069 ***