Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 182643 - sci-mathematics/maxima missing documentation symlink
Summary: sci-mathematics/maxima missing documentation symlink
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Science Mathematics related packages
Depends on:
Reported: 2007-06-20 08:11 UTC by Guenther Brunthaler
Modified: 2007-09-17 17:48 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

config.log from the failed gcl build (gcl-2.6.7_config.log,19.84 KB, text/plain)
2007-06-22 09:20 UTC, Guenther Brunthaler

Note You need to log in before you can comment on or make changes to this bug.
Description Guenther Brunthaler 2007-06-20 08:11:46 UTC
When the X-frontend for maxima, "xmaxima" is launched, it terminates immediately complaining it cannot find its documentation files.

Reproducible: Always

Steps to Reproduce:

Actual Results:  
Error in startup script: can't read "maxima_priv(pReferenceToc)": no such element in array

Expected Results:  
xmaxima starts up

The problem can easily be solved by adding a symlink:

# ln -s /usr/share/doc/maxima-5.9.1 /usr/share/maxima/5.9.1/doc

(as an example how to fix it for maxima version 5.9.1)

Please add that to the ebuild!
Comment 1 Sébastien Fabbro (RETIRED) gentoo-dev 2007-06-20 23:19:02 UTC
Hi Guenther,

Yes, you are right. This was fixed in later versions though. Please test the ~arch maxima-5.9.11-r2 or even maxima-5.12.0 in the gentooscience overlay 
(using layman). I am planning to get one of these version for stabilization, though many lisps don't compile fine on my boxes.

Comment 2 Guenther Brunthaler 2007-06-22 09:18:47 UTC
Hi Sébastien,

Sorry it took so long for me to respond, but I have a 57 kbps connection right now and it took bloody ages in order to download all the dependencies.

I have installed the overlay, unmasked and downloaded both maxima-5.11.0-r2 as well as maxima-5.12.0.

But I encountered a build failure with gcl, so I was unable to build Maxima by GNU Common LISP which seems to be the default.

However, when I enabled USE=cmucl, Maxima 5.11.0-r2 built just fine.

I did not do extensive tests because I'm still not very proficient in Maxima, but those things that I tested seemed to work just fine (both maxima and xmaxima).

Then I updated to Maxima 5.12, and it also seemed to work fine as well.

As a side remark on building, I noticed *loads* of warnings like

; Note: Unable to avoid inline argument range check
; because the argument range (DOUBLE-FLOAT) was not within 2^64

when CMU CL compiled the sources - I dunno whether that matters; just FYI.

And in case you should be interested in the build failure of GNU CL: It failed while configuration stating

checking for main in -lX11... yes
./configure: line 6962: syntax error near unexpected token `exit'
./configure: line 6962: `echo "${ECHO_T}cannot use bfd" >&6; } exit 1;'
Comment 3 Guenther Brunthaler 2007-06-22 09:20:20 UTC
Created attachment 122786 [details]
config.log from the failed gcl build

Here's the log file containing more information about that failed gcl build.
Comment 4 Sébastien Fabbro (RETIRED) gentoo-dev 2007-09-14 08:40:36 UTC
Hi Guenther,

The doc linking problem was fixed in maxima-5.9.1. However, I suggest to update to maxima-5.13.0, which default lisp is now sbcl. Please report any build failures of this release to bug #192449.

Comment 5 Guenther Brunthaler 2007-09-17 17:48:38 UTC
(In reply to comment #4)

Hi Sébastien,

Thanks a lot for the fix!

> However, I suggest to update
> to maxima-5.13.0

I have done this immediately; it has the additional benefit that 5.13 is back in the main tree now, while 5.12 has been from the overlay only.

For your reference, I have tested 5.13 both with sbcl as well as cmucl - it worked well with either LISP.

> which default lisp is now sbcl. Please report any build

Although sbcl works, I reverted to cmucl because I did not like the bootstrapping approach used by the sbcl ebuild: No matter whether a working CL installation was available or not, the ebuild always used the binary version only of sbcl for compiling itself.

I strongly dislike any pre-built binary compiling my sources (except for initial bootstrapping), so I've re-enabled the cmucl USE flag after testing 5.13 with sbcl.

> failures of this release to bug #192449.

Nothing to report - bug can be closed! :-)