Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 182461 - When running beryl on either x86 or x86_64, Kscreensaver does not show a login box after 1-2 hrs
Summary: When running beryl on either x86 or x86_64, Kscreensaver does not ...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-18 14:37 UTC by Billy DeVincentis
Modified: 2007-07-09 19:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Billy DeVincentis 2007-06-18 14:37:05 UTC
Have  both  x86  and  amd64  installs  on  the  same  computer,  I  have  both  kde  and  gnome  installed  on  both.  When  I  am  running  kde  I  use  the  kscreensaver  with  the  require  password  to  stop  option.  If  I  return  to  the  computer  shortly  after  display  power  management  has  shut  off  the  monitor,  it  will  usually  give  me  the  login  box  to  unlock  the  screen  but  if  I  leave  it  for  an  extended  amount  of  time,  it  will  not.  I  can  usually  just  type  in  my  password  and  unlock  the  screen  but  thats  a  50/50  chance  of  working.  I  have  tried  various  options  with  beryl  and  none  seem  to  make  a  difference.  Whats  more  is  that  an  openSuse  10.2  amd64  install  on  the  very  same  computer  does  not  do  this  with  the  same  version  of  beryl.

Reproducible: Always

Steps to Reproduce:
1.enter  kde
2.start  beryl
3.leave  computer  until  power  management  shuts  off  monitor

Actual Results:  
no  login  box

Expected Results:  
have  a  login  box  to  unlock  screen
Comment 1 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-06-18 15:13:19 UTC
Please try to login through a VT or remotely and confirm if this is not caused by 100% cpu usage.
Also, please attach your emerge --info.
Comment 2 Wulf Krueger (RETIRED) gentoo-dev 2007-06-18 15:44:45 UTC
Are you using the xeffects overlay?
Comment 3 Roderick B. Greening 2007-07-04 13:38:29 UTC
Seeing as Kscreensaver is not part of the xeffects overlay, and beryl is no longer included in the overlay, I think this last question is moot at this point :)

However, if the bug originator could provide the emerge --info it may be a great place to start finding a resolution.

Also, emerge -pv kscreensaver and which version of beryl and what plugins are enabled? It could be one or more plugins are impacting the screensaver. You should try disabling plugins until you get it working. 
Comment 4 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-07-04 18:55:13 UTC
*ping*
Comment 5 Wulf Krueger (RETIRED) gentoo-dev 2007-07-08 21:44:57 UTC
Feel free to re-open after providing the information we asked for.
Comment 6 Billy DeVincentis 2007-07-09 19:30:10 UTC
(In reply to comment #0)
> Have  both  x86  and  amd64  installs  on  the  same  computer,  I  have  both 
> kde  and  gnome  installed  on  both.  When  I  am  running  kde  I  use  the 
> kscreensaver  with  the  require  password  to  stop  option.  If  I  return 
> to  the  computer  shortly  after  display  power  management  has  shut  off 
> the  monitor,  it  will  usually  give  me  the  login  box  to  unlock  the 
> screen  but  if  I  leave  it  for  an  extended  amount  of  time,  it  will 
> not.  I  can  usually  just  type  in  my  password  and  unlock  the  screen 
> but  thats  a  50/50  chance  of  working.  I  have  tried  various  options 
> with  beryl  and  none  seem  to  make  a  difference.  Whats  more  is  that 
> an  openSuse  10.2  amd64  install  on  the  very  same  computer  does  not 
> do  this  with  the  same  version  of  beryl.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.enter  kde
> 2.start  beryl
> 3.leave  computer  until  power  management  shuts  off  monitor
> 
> Actual Results:  
> no  login  box
> 
> Expected Results:  
> have  a  login  box  to  unlock  screen
> 

What  I  am  currently  doing  is  re-emerging  world  to  see  if  that  doesn't  help,  Starngest  thing  is  that  on  another  box  I  have  I  had  the  very  same  problem  for  quite  some  time,  all  of  a  sudden  one  day  it  went  away  (my  box  does  emerge --update --deep --newuse world  every  night).  I  wonder  if  it  didnt  just  get  compiled  out.  When  Its  done  re-emerging  the  world,  I  will  test  and  if  problem  remains  I  will  remerge  all  beryl  packages,  kscreensaver  and  kdesktop  and  post  to  see  if  the  problem  can  be  solved.