Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 182127 - cairo-1.4.8 totally breaks openoffice
Summary: cairo-1.4.8 totally breaks openoffice
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Doug Goldstein (RETIRED)
Depends on:
Reported: 2007-06-15 11:20 UTC by Andreas Proschofsky (RETIRED)
Modified: 2007-06-18 13:58 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Proschofsky (RETIRED) gentoo-dev 2007-06-15 11:20:01 UTC
With cairo-1.4.8 breaks immediately after entering the preferences, afterwards it doesn't start at all anymore. This is caused by a XError in cairo-1.4.8. Downgrading to 1.4.6 solves the problem. See also:

So until there is a fix I'd propose to hardmask 1.4.8 for the time being

Reproducible: Always
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-06-15 11:49:55 UTC
Not only openoffice, see Bug 182058.
Comment 2 Doug Goldstein (RETIRED) gentoo-dev 2007-06-15 13:48:56 UTC
I honestly can't duplicate any of the issues people have been having with the new cairo. On this bug or #182058
Comment 3 Doug Goldstein (RETIRED) gentoo-dev 2007-06-15 14:16:51 UTC
Additionally the following information is missing from your bug report:

- OpenOffice version (bin or compiled)
- Error messages produced at the command line when OpenOffice is run from the command line.
- emerge info
Comment 4 Andreas Proschofsky (RETIRED) gentoo-dev 2007-06-15 16:55:55 UTC
Sorry, about not adding this info before:

(In reply to comment #3)
> Additionally the following information is missing from your bug report:
> - OpenOffice version (bin or compiled)

This happens only with the source built version, tried with both 2.2.0 and 2.2.1, I guess it will happen with 2.1.0 too as AFAIK nothing changed in respect to the cairo stuff

> - Error messages produced at the command line when OpenOffice is run from the
> command line.

There is none, it just crashes, if you want to have more info about what happens see, the Red Hat bug I referenced

> - emerge info

Portage (default-linux/x86/2006.1/desktop, gcc-4.1.2, glibc-2.5-r3, 2.6.21-gentoo-r3 i686)
System uname: 2.6.21-gentoo-r3 i686 Genuine Intel(R) CPU T2400 @ 1.83GHz
Gentoo Base System release 1.12.10
Timestamp of tree: Fri, 15 Jun 2007 04:50:01 +0000
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r7
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.21
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
FEATURES="ccache cvs distcc distlocks metadata-transfer parallel-fetch sandbox sfperms"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTDIR_OVERLAY="/usr/portage/local/layman/xeffects /usr/portage/local/layman/vmware /usr/portage/local/layman/secondlife /usr/portage/local/layman/gnome-experimental /usr/local/portage"
USE="X a52 aac aalib acpi alsa asf avahi bash-completion beagle berkdb bzip2 cairo cdr cli cracklib crypt cups daap dbus dri dv dvd dvdnav dvdread eds emboss encode exif fam ffmpeg firefox flac fortran freetype galago gdbm gedit gif glitz gnome gnutls gphoto2 gpm gstreamer gtk hal hdaps hddtemp iconv ipv6 isdnlog jpeg keyring libcaca libg++ libnotify logrotate mad matroska mikmod mmx mono mp3 mpeg mudflap nautilus ncurses networkmanager nls nptl nptlonly nsplugin ogg opengl openmp oss pam pcre pdf perl png ppds pppd python quicktime rar readline real reflection samba sdl session slang spell spl sse sse2 ssl startup-notification svg tcpd theora tiff truetype truetype-fonts type1-fonts unicode vcd vidix vorbis win32code win32codecs x264 x86 xcb xml xorg xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fglrx radeon"
Comment 5 Andreas Proschofsky (RETIRED) gentoo-dev 2007-06-15 16:58:46 UTC
Having said all that, I'd like to add: This bug is 100 % reproducible, it happens for me on two totally different machines, with different OOo-versions, there already is a thread on the forums about it with users complaining about the crashes

and Red Hat confirms the problem too. So I guess this should count as proof that this problem exists on a wider scale than my own private computers ;)
Comment 6 Doug Goldstein (RETIRED) gentoo-dev 2007-06-15 17:49:07 UTC
I'm not denying that it doesn't exist. I looked at the code where it's happening. It's just odd that it's only reproducable in a subset of users. We had a discussion on IRC about this and not everyone could reproduce it. Some people that could produce the mplayer crash could not produce this, some people that could produce this could not produce the mplayer crash, some had both, and some had none. Some even had openoffice-bin work, while openoffice compiled did not, some had openoffice compiled work and some had openoffice-bin work.

For all these people the issue was 100% reproducible.
Comment 7 Doug Goldstein (RETIRED) gentoo-dev 2007-06-15 21:56:19 UTC
please unmask cairo 1.4.8 and test with the current version. It should apply the following patch:

Comment 8 Andreas Proschofsky (RETIRED) gentoo-dev 2007-06-15 23:31:15 UTC
(In reply to comment #7)
> please unmask cairo 1.4.8 and test with the current version. It should apply
> the following patch:
> cairo-1.4.8-XError.patch

Looks good, the patched version works fine for me, opening the Options doesn't crash anymore, saving also works, so as far as I can see: Problem solved :) Great work, Doug.
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2007-06-16 10:59:38 UTC
Cool, works here as well. Ty! :)