Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 181298 - transparent media damaged under X.org with radeon module and in-kernel DRM
Summary: transparent media damaged under X.org with radeon module and in-kernel DRM
Status: VERIFIED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-08 12:19 UTC by Dmitrij D. Czarkoff
Modified: 2009-02-20 21:34 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
My '/etc/X11/xorg.conf' and '/var/log/Xorg.log'. (xorg-problem.tbz,9.62 KB, application/x-compressed-tar)
2007-06-18 04:44 UTC, Dmitrij D. Czarkoff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitrij D. Czarkoff 2007-06-08 12:19:55 UTC
I have X.org with radeon module and radeon DRM in kernel. Transparent layers in pictures and text are sometimes rendered with random distortion (often black horizontal lines). The effect is seen everywhere in X (KDE apps, OpenOffice, Firefox and stuff).

X.org 7.2, kernel 2.6.21-suspend2-r5 (same happens with gentoo-sources).

fglrx module seems to render everything without distortion.

Additional info:
ddclpc ~ # emerge --info
Portage 2.1.2.9 (default-linux/amd64/2007.0, gcc-4.1.1, glibc-2.5-r3, 2.6.21-suspend2-r5 x86_64)
=================================================================
System uname: 2.6.21-suspend2-r5 x86_64 AMD Turion(tm) 64 Mobile Technology MT-28
Gentoo Base System release 1.12.10
Timestamp of tree: Thu, 07 Jun 2007 21:00:01 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3, 2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="ru_RU.utf8"
LC_ALL="ru_RU.utf8"
LINGUAS="ru"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/root/tmp/"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac aalib acl acpi alsa amd64 amr arts artswrappersuid async audiofile authdaemond bash-completion bashlogger berkdb bitmap-fonts bluetooth branding bzip2 cairo cli crypt css cups dbus dhcp djvu dri dts dvd dvdr dvdread encode examples exif expat fbcon fbsplash ffmpeg flac gif glibc-omitfp gnokii gphoto2 gpm graphviz gs hal hddtemp ical iconv imagemagick imlib ipv6 isdnlog java jingle jpeg jpeg2k justify kde kerberos lcms libg++ lm_sensors logrotate mad mailwrapper md5sum midi mjpeg mmap mmx mng modplug mp3 mpeg mplayer multislot musepack musicbrainz ncurses nls no-old-linux nptl nptlonly nsplugin ntlm_unsupported_patch ogg opengl openmp pam paste64 pcmcia pcre pdf perl pic png ppds pppd python qt3 qt4 quicktime rdesktop readline reflection ruby samba sdl sensord session sms socks5 speex spell spl sqlite sse sse2 ssl subversion svg symlink syslog tcpd theora tidy tiff toolbar truetype truetype-fonts type1-fonts unicode usb utempter vim-pager vim-syntax vim-with-x visualization vorbis vorbis-psy wavpack wifi winbind wmf x264 xcomposite xine xorg xpm xprint xv xvid xvmc zlib" ALSA_CARDS="atiixp atiixp-modem" ALSA_PCM_PLUGINS="ioplug softvol iec958 dmix plug rate adpcm copy" CAMERAS="ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="text X xosd" LINGUAS="ru" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Dmitrij D. Czarkoff 2007-06-08 13:42:42 UTC
I knew something was missing:
ddclpc ~ # lspci
00:00.0 Host bridge: ATI Technologies Inc ATI Radeon Xpress 200 (RS480/RS482/RX480/RX482) Chipset - Host bridge (rev 01)
00:02.0 PCI bridge: ATI Technologies Inc RS480 PCI-X Root Port
00:06.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 11)
00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE Controller ATI
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 02)
00:14.6 Modem: ATI Technologies Inc ATI SB400 - AC'97 Modem Controller (rev 02)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X700 (PCIE)
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller (rev 19)
03:07.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
03:07.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host Controller
03:07.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller
03:07.4 Generic system peripheral [0805]: Texas Instruments PCI6411, PCI6421, PCI6611, PCI6621, PCI7411, PCI7421, PCI7611, PCI7621 Secure Digital (SD) Controller
03:09.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
Comment 2 Dmitrij D. Czarkoff 2007-06-14 05:07:22 UTC
Any ideas?
Comment 3 Joshua Baergen (RETIRED) gentoo-dev 2007-06-18 01:13:47 UTC
(In reply to comment #2)
> Any ideas?
> 

Hmm...not anything good.  Can you attach your xorg log and configuration file, please?
Comment 4 Dmitrij D. Czarkoff 2007-06-18 04:44:17 UTC
Created attachment 122381 [details]
My '/etc/X11/xorg.conf' and '/var/log/Xorg.log'.
Comment 5 Rémi Cardona gentoo-dev 2009-02-20 13:47:42 UTC
This bug hasn't been touched in a year and a half.

Dmitrij, if you can still reproduce the issue with a newer versions of xorg-server and/or xf86-video-ati, don't hesitate to reopen this bug. Meanwhile, I'll be closing this bug.

Thanks
Comment 6 Dmitrij D. Czarkoff 2009-02-20 21:34:45 UTC
(In reply to comment #5)
> Dmitrij, if you can still reproduce the issue with a newer versions of
> xorg-server and/or xf86-video-ati, don't hesitate to reopen this bug.

No, the driver is OK for more then a year. I believe my card wasn't quite well supported at the time of initial commit.