Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 18127 - gawk-3.1.2 makes reboot impossible
Summary: gawk-3.1.2 makes reboot impossible
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Martin Schlemmer (RETIRED)
: 18192 18235 18283 (view as bug list)
Depends on:
Reported: 2003-03-24 21:26 UTC by Georg Müller
Modified: 2003-04-06 11:24 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Georg Müller 2003-03-24 21:26:18 UTC
After emerged gawk-3.1.2 and a reboot my system hangs on startup.
It hadn't started devfsd, eth0 doesn't started and he couldn't make symlinks to

After some tests (searched for bugs in other ebuilds...) and a re-emerge of
gawk-3.1.1-r1 everything worked fine again.

I tested to reinstall it again (no other emerges than this one) and problem came
again/was solved again by emergeing gawk-3.1.1.

I noticed that the header-files installed with 3.1.1-r1 aren't installed with
3.1.2, but I don't know if this has to do anything with the problem...
Comment 1 Brandon Low (RETIRED) gentoo-dev 2003-03-24 21:58:35 UTC
that was my bump, I'm working on it... what a silly gawk.
Comment 2 Brandon Low (RETIRED) gentoo-dev 2003-03-24 22:08:09 UTC
Hey, Martin, I get the weirdest "gawk - relocation error: /lib/ undefined symbol dupnode" with the new gawk, any hint as to why that would happen or why it would be linking against that at all or what?

Comment 3 Brandon Low (RETIRED) gentoo-dev 2003-03-24 22:10:08 UTC
ahh... nvm, I think I see whats going on, looks like the awk module of baselayout gets mixed up symbols as compared to the awk executable... or something?  testing now.
Comment 4 Brandon Low (RETIRED) gentoo-dev 2003-03-24 22:26:59 UTC
eek. needs to be rebuilt on any awk upgrade rather than on any baselayout upgrade... can we move it to the awk ebuild azarah?  Thanks!
Comment 5 Jon Portnoy (RETIRED) gentoo-dev 2003-03-25 14:05:15 UTC
I'm hearing reports from users that 3.1.2-r2 has the same borkage.
Comment 6 Spundun Bhatt 2003-03-25 14:34:00 UTC
Yes the problem is still there with gawk3.1.2-r2....
The simple test to see (without rebooting) is this.

mermaid root # awk '($2 == "devfs") {print "yes"; exit 0 }' /proc/filesystems
mermaid root # awk '($2 == "devfs") {print "yes"; exit 0 }' /proc/filesystems

the command should have returned yes both times.
First time it was executed with the 3.1.2-r2 and then reverting back to 3.1.1-r2
This line is from /sbin/rc
awk has stopped taking filename as a parameter.
cat /proc/filesystems | awk '($2 == "devfs") {print "yes"; exit 0 }'

works in both cases (I havent tested this with 3.1.2-r2 but I tested with 3.1.2-r1 and it worked)
Hope this helps.
Comment 7 Martin Schlemmer (RETIRED) gentoo-dev 2003-03-26 12:48:43 UTC
*** Bug 18192 has been marked as a duplicate of this bug. ***
Comment 8 Martin Schlemmer (RETIRED) gentoo-dev 2003-03-26 14:23:34 UTC
*** Bug 18235 has been marked as a duplicate of this bug. ***
Comment 9 Martin Schlemmer (RETIRED) gentoo-dev 2003-03-27 15:02:12 UTC
*** Bug 18283 has been marked as a duplicate of this bug. ***
Comment 10 Martin Schlemmer (RETIRED) gentoo-dev 2003-03-27 15:05:08 UTC
Special files like those in /proc, report themselves as regular files
of length 0, when in fact they have data in them if you try to read them.
The new record-reading code wasn't quite smart enough to deal with such
a bizarre case.  The following patch fixes the problem, thanks to 
Arnold D. Robbins (Maintainer of gawk).

Anyhow, gawk-3.1.2-r3 should fix this.
Comment 11 Brandon Low (RETIRED) gentoo-dev 2003-04-01 13:19:54 UTC
This seems fine here Azarah, thanks.
Comment 12 Martin Schlemmer (RETIRED) gentoo-dev 2003-04-06 11:24:09 UTC
Right, this can be closed.