Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 181135 - X server consumes all the CPU usage
Summary: X server consumes all the CPU usage
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-06 21:44 UTC by Markos Chandras (RETIRED)
Modified: 2007-06-28 08:53 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markos Chandras (RETIRED) gentoo-dev 2007-06-06 21:44:24 UTC
When power controls ( on display settings ) on KDE are enable , when the monitors turn on after being stand-by , the X server consumes all the CPU usage ( 95% of CPU ) making the Gentoo system useless . X server cant be killed and change session ( ctrl + alt + F[1-9] ) doesn't do anything

Reproducible: Always

Steps to Reproduce:
1.Enable Power Managment on KDE
2.Let the monitors stand-by for 2-3 hours
3.Move the mouse to turn on the monitors

Actual Results:  
1.Enable Power Managment on KDE
2.Let the monitors stand-by for 2-3 hours
3.Move the mouse to turn on the monitors

Expected Results:  
I expect the X server to consume all the CPU Usage
Comment 1 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-06-06 22:00:21 UTC
Please post your emerge --info. Do you use any overlays?
Comment 2 Markos Chandras (RETIRED) gentoo-dev 2007-06-06 22:16:50 UTC
(In reply to comment #1)
> Please post your emerge --info. Do you use any overlays?
> 

Yes I have xeffects and voip overlays

This is the emerge --info


Portage 2.1.2.7 (default-linux/amd64/2007.0/desktop, gcc-4.1.2, glibc-2.5-r3, 2.6.20-gentoo-r8 x86_64)
=================================================================
System uname: 2.6.20-gentoo-r8 x86_64 AMD Athlon(tm) 64 Processor 2800+
Gentoo Base System release 1.12.9
Timestamp of tree: Wed, 06 Jun 2007 11:00:01 +0000
dev-java/java-config: 1.3.7, 2.0.32
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg candy distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="https://ftp.uoi.gr/pub/mirrors/OS/gentoo ftp://ftp.uoi.gr/pub/mirrors/OS/gentoo http://ftp.uoi.gr/pub/mirrors/OS/gentoo ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/"
LINGUAS="en el"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/xeffects /usr/portage/local/layman/voip"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowex 3dnowext X aac acl acpi aiglx alsa amd64 avi berkdb bitmap-fonts cairo cdr cli cracklib crypt cups dbus dga divx divx4linux dri dvd dvdr dvdread emboss encode esd evo ffmpeg firefox flac fortran gdbm gif gmedia gpm gstreamer hal iconv ipv6 isdnlog java joystick jpeg kde kdeenablefinal kerberos ldap libg++ mad midi mikmod mmx mp3 mpeg mplayer mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp oss pam pcre pdf perl png pppd python qt3 qt3support qt4 quicktime readline realmedia reflection sdl session slang snmp spell spl sse sse2 ssl subtitles svg symlink tcpd tiff truetype truetype-fonts type1 type1-fonts unicode usb userlocales v4l vcd vorbis wmp x264 xcomposite xine xinerama xml xorg xv xvid zlib" ALSA_CARDS="snd_ca0106" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard synaptics mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en el" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-06-07 01:30:43 UTC
Are you running beryl or compiz? If so, does this apply if you use kwin? Are you running XGL?
You should also try to rebuild qt and kdelibs from portage and check if the problem persists. If in the end the problem is related to the xeffects overlay you should report it at http://trac.gentoo-xeffects.org
Comment 4 Markos Chandras (RETIRED) gentoo-dev 2007-06-07 06:30:17 UTC
(In reply to comment #3)
> Are you running beryl or compiz? If so, does this apply if you use kwin? Are
> you running XGL?
> You should also try to rebuild qt and kdelibs from portage and check if the
> problem persists. If in the end the problem is related to the xeffects overlay
> you should report it at http://trac.gentoo-xeffects.org
> 

It happens with kwin and with beryl. When u say rebuild ,you mean to re-emerge qt and kdelibs?How would I know that the problem is related to xeffects?should I try to remove them?
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-06-07 08:33:44 UTC
> PORTDIR_OVERLAY="/usr/portage/local/layman/xeffects

Reopen if you still have issues after you've rebuild everything with that overlay removed.
Comment 6 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-06-07 09:13:40 UTC
You should remove the overlay and rebuild all the affected packages - start with qt and kdelibs. If after rebuilding the packages and restarting kde you stop having the issue, then you've hit an xeffects overlay bug.
Comment 7 Markos Chandras (RETIRED) gentoo-dev 2007-06-07 10:55:16 UTC
(In reply to comment #6)
> You should remove the overlay and rebuild all the affected packages - start
> with qt and kdelibs. If after rebuilding the packages and restarting kde you
> stop having the issue, then you've hit an xeffects overlay bug.

Ok so I ll remove it and the I ll do an emerge -uDNpv world ( if this is the way to rebuild the packages )

If not please let me know how to rebuild them

Thanks a lot


Comment 8 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-06-07 13:22:55 UTC
You only need to rebuild the packages that were installed from the xeffects overlay. If you've installed the kde or kde-meta packages, you could use emerge -uDavN [kde|kde-meta].
If you don't know what packages were installed from the overlay, with the overlay listed on make.conf, you could run emerge -epv world and check what packages are marked as [X] with [X] corresponding to the xeffects overlay.
Comment 9 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-06-07 13:36:26 UTC
Run emerge -pv kdelibs. If xeffects is listed as [1], run the following to find what packages need to be reinstalled:

# emerge -epv world | grep "\[1\]"

replace 1 with the correct overlay number
Comment 10 Markos Chandras (RETIRED) gentoo-dev 2007-06-07 16:01:42 UTC
(In reply to comment #9)
> Run emerge -pv kdelibs. If xeffects is listed as [1], run the following to find
> what packages need to be reinstalled:
> 
> # emerge -epv world | grep "\[1\]"
> 
> replace 1 with the correct overlay number
> 

Thanks. I just re-emerge the packages

I ll let you know soon

ps. Before I re-emerge I found out that the same problem occurs also with the Screensaver. When the screensaver runs for 2-3 hours the CPU usage is extremely high
Comment 11 Markos Chandras (RETIRED) gentoo-dev 2007-06-08 07:41:09 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > Run emerge -pv kdelibs. If xeffects is listed as [1], run the following to find
> > what packages need to be reinstalled:
> > 
> > # emerge -epv world | grep "\[1\]"
> > 
> > replace 1 with the correct overlay number
> > 
> 
> Thanks. I just re-emerge the packages
> 
> I ll let you know soon
> 
> ps. Before I re-emerge I found out that the same problem occurs also with the
> Screensaver. When the screensaver runs for 2-3 hours the CPU usage is extremely
> high
> 

Yeah . It was xeffects problem.I am gonna report it. Thank you
Comment 12 Markos Chandras (RETIRED) gentoo-dev 2007-06-08 07:43:36 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > (In reply to comment #9)
> > > Run emerge -pv kdelibs. If xeffects is listed as [1], run the following to find
> > > what packages need to be reinstalled:
> > > 
> > > # emerge -epv world | grep "\[1\]"
> > > 
> > > replace 1 with the correct overlay number
> > > 
> > 
> > Thanks. I just re-emerge the packages
> > 
> > I ll let you know soon
> > 
> > ps. Before I re-emerge I found out that the same problem occurs also with the
> > Screensaver. When the screensaver runs for 2-3 hours the CPU usage is extremely
> > high
> > 
> 
> Yeah . It was xeffects problem.I am gonna report it. Thank you
> 

This link http://trac.gentoo-xeffects.org/

doesnt work

Maybe another one?
Comment 13 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-06-08 09:34:23 UTC
That is the correct link. The bug tracker has been down for a few days. In the meanwhile, you can contact the team in the IRC Freenode network at #gentoo-xeffects.
Comment 14 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-06-08 09:35:06 UTC
Closing as invalid since this is not a Gentoo bug.
Comment 15 Markos Chandras (RETIRED) gentoo-dev 2007-06-13 07:14:09 UTC
(In reply to comment #14)
> Closing as invalid since this is not a Gentoo bug.
> 

Here I am again. Same problem again. Xeffects overlay is not installed and yet every morning X is using 100% CPU . .. 
Comment 16 Matteo Azzali (RETIRED) gentoo-dev 2007-06-14 08:22:11 UTC
This issue is still only on your system,(unable to replicate here on x86)
so there are some really likely chanches:

1) Some Xeffect file is still there and is loaded at X startup, due to a bad ebuild.You need to manually check this, sorry.

2) Some particular hardware/driver (often things with custom drivers)
has issues after an update of xorg. Try to remove any unneeded hardware
and unload any unneeded module,and retest, to discover which component
may cause this.
Also, if you're using an ATI card, please switch kind of drivers 
(yes, if you're using oss ones I'm suggesting you to check fglrx...),
if you're using an nvidia check if your drivers are up-to-date.
Comment 17 Wulf Krueger (RETIRED) gentoo-dev 2007-06-16 17:22:35 UTC
Please make sure the xeffects overlay is gone (rm -rf on its path if that still exists). Then do an "emerge -e world " to ensure all possible remains of the overlay's packages are gone as well.

If this problem still occurs afterwards, please re-open.
Comment 18 Markos Chandras (RETIRED) gentoo-dev 2007-06-18 18:16:11 UTC
Hello again

I double checked the Xeffects overlay and the emerge -ep world. Xeffects are 100% uninstalled and totally removed from my system

I ve also seen some reports on gentoo forums about X Server lockups and some of the possible reasons is the superkaramba or the firefox.

I will have a test with superkaramba closed

The weird part is that this happens after >5hours of stand-by. If the time is less I dont have any problems

Really really weird :\
Comment 19 Markos Chandras (RETIRED) gentoo-dev 2007-06-28 08:53:48 UTC
Finally a solution

aMSN is responsible for the above bug. When aMSN is running during the night makes the X unstable.

Thanks